Stardew Valley 1.4 Mobile: Known Issues and Fixes

Discussion in 'Support' started by Katzeus, Feb 12, 2020.

  1. Debss

    Debss Space Hobo

    THANK YOU SO MUCH!!! ❤️❤️ I don't even know how did you discover that. I just realized that the problem appeared after I played the jukebox for the first time. You should work for them.
     
      HHLSlayer likes this.
    • AdolRonk

      AdolRonk Space Hobo

      Okay, this bug is for iOS, so it's obviously not for the 1.4version. Also, I didn't look SUPER hard to see if it had been reported already, so I apologize if it is redundant. I BELIEVE it is for the newest version available for iOS but I can't seem to find the version number anywhere in the game (it's quite possible it's right in front of my face, sorry if I'm just unobservant). I am playing on an IPhone 6s+ running iOS 11.1 jailbroken with unc0ver (in case that matters).
      I am also using the "jailbroken only" app nControl to allow the usage of bluetooth controllers, in this case a Nintendo switch right joycon.

      The bug I found allows me to duplicate any item in my inventory. Rather, it will turn any item in my inventory into any item. It happens thusly:

      Whilst using an external joypad for control, open a chest. In the split inventory screen, select the item you want to copy in the chest inventory USING TOUCH. Now, using the joypad, move the square selector down to your inventory and have it highlight any item you wish.
      Now, touch an empty space in the chest inventory as if you were trying to transfer the item from your inventory into the chest.
      Instead of just transferring the item from your inventory to the chest, it will also change that item into whatever item you had originally selected in the chest inventory using touch.

      I did this accidentally once or twice before I noticed what was happening. I have not tried it in any other environment, nor with any controller besides the switch joy con. The newer iOSs have built-in joypad support, so I suppose it is possible that this is something that only happens when using nControl to use joypads or I suppose it might just be something that only happens when using a Joycon, idk. However, it feels to me like it isn't (yeah, that's worth a lot, right?) and I would be very interested to see whether it happens in newer, non-jailbroken iOSs. I would have tried it but I just don't have a newer iOS device available to me.
      Again, I apologize if this has already been reported and I didn't notice or if it is something that only happens because of my specific iOS 11.1 jailbroken environment. I haven't run across it being mentioned anywhere and it's a big enough of a bug that I thought I should report it jic it applies to other, normal, environments. It would only take a second to test for it, as I mentioned I would have already tested for it except that I lack a device on which to do so.

      Item duplication is a pretty big deal in a game that is a large part inventory management. It almost ruined the game for me but I transferred my game to the mac OSX 1.4 version and THANK GOODNESS you can't transfer from 1.4 to a pre-1.4 version. So I can't play on my mobile anymore, but I've actually found that I prefer much about the game in its non-touchscreen way of playing.

      Oh, might as well also report that the game will start to slow down heavily and crash sometimes. It happens when I am returning from the desert and the bus is pulling into stardew valley. It has only happened once whilst I was walking around in town, all other times were when the bus was returning. I didn't have it happen to me enough to notice much more about it, sorry.
       
      • sepo

        sepo Developer

        Please could you upload the save which does this.
         
        • sepo

          sepo Developer

          1.4 is now out on iOS. Please update.
           
          • sepo

            sepo Developer

            What version of the game are you playing (build number). Is it a save from 1.3?
             
            • Debss

              Debss Space Hobo

              Hello. The save he fixed was mine. The problem happened when I played the jukebox for the first time, right after it updated for the 1.4.5.139 version. I've already attached my save on my first comment. Thanks!!!
               
              • HHLSlayer

                HHLSlayer Space Hobo

                She was playing on 1.4.5.139 for Android
                 

                  Attached Files:

                  Last edited by a moderator: Feb 27, 2020
                  Debss likes this.
                • sepo

                  sepo Developer

                  What are the steps to create the crash? I loaded it up on my Samsung Note 9. The jukebox played every track fine for me.
                   
                  • TheWumpus

                    TheWumpus Space Hobo

                    Is the performance ever going to be addressed with the iOS version on a 12.9" iPad Pro? It’s never really been playable due to the constant stutter/jerkiness when walking around and scrolling the environment. This can easily be seen in any YouTube videos of people playing it on this device so I know it’s not just me. I have the current model and the 2nd gen and both are equally affected. I should add that zooming in reduces the stutter the further you zoom in, but the frame times don’t appear to be perfectly smooth at any distance. Perhaps we should have the option to disable retina mode for this game. I could deal with a bit of blur for more fluid frame rates.
                     
                      Last edited: Feb 26, 2020
                      Maggiemay1 likes this.
                    • Skinflint

                      Skinflint Scruffy Nerf-Herder

                      1st 1.4 app version for iOS, iPad Pro 10.5" 2017 running iPad OS 13.3

                      I'm getting this weird redraw type of bug as I harvest in my greenhouse on the cactus arms' shadows. I've attached during and after. It pops in while the harvest animation plays, then back out as soon as the animation is over. I annotated 2 instances but most are affected.
                       

                        Attached Files:

                      • sepo

                        sepo Developer

                        Looking at that image I can't see what the issue is.
                         
                        • Kellykz

                          Kellykz Seal Broken

                          Stardew 1.4 on iPad Pro 2018 running iPad OS 13.3

                          Issue: NO Add to Existing Stacks" button when using chest (see photo)

                          Whereas the changelog specified that mobile version has everything equivalent to other platforms.
                           

                            Attached Files:

                            TheRaven81 likes this.
                          • Skinflint

                            Skinflint Scruffy Nerf-Herder

                            If I could send a video, it'd be very obvious: the shadows clip in and out during the animation. The two images I attached are before/after and then during. You can particularly see under the arms of the cactuses where I've annotated. Let me know if there's a way to submit a video.
                             
                            • Diegobrando2468

                              Diegobrando2468 Space Spelunker

                              android bugs recently

                              Most seeds are in English despite in Portuguese if you go buy with pierre or joja

                              Tools sometimes does not work with Gamepads

                              Crashes after leaving penny trailer

                              Many Frame drops if you're getting drops/foraging or mining and during the train passing
                               
                              • FireFruit

                                FireFruit Intergalactic Tourist

                                Hi, not sure if I'm the only one this has happened to but my junimo huts are not collecting my harvests as normal, when they harvest something it just stays on the ground and my magnetism will pick it up if I get close. I realize that if the huts are full this is what is meant to happen but there's completely empty. I tried to switch it off and then on again after resting but the issue persists. I'm currently running 1.4.5.140 on LG G6.
                                 
                                  Kellykz likes this.
                                • TheRaven81

                                  TheRaven81 Big Damn Hero

                                  Yeah this would be very nice to have on Mobile.
                                   
                                  • Skinflint

                                    Skinflint Scruffy Nerf-Herder

                                    1st 1.4 app version for iOS, iPad Pro 10.5" 2017 running iPad OS 13.3

                                    I'm growing a pomegranate tree and keep getting messages it couldn't grow overnight despite everything being cleared around it, and only just now thought to check for Clay by digging up all the tiles. This was NEVER necessary before! Please make sure anything diggable does not impede fruit tree (or even other trees, especially if I used Tree Fertilizer on them) growth.

                                    Also, I'm getting that message even when something new crops up overnight, e.g. a fallen seed. It should grow overnight if I clear its ground earlier that day: I don't remember _ever_ having it stunted overnight despite having cleared it that very day before 1.4. That could be be cause messages about it are new in 1.4, but in any case I strongly disapprove of the idea that it is supposed to be that anytime the game decides to spawn anything around the tree I lose a day of growth even when I spent time clearing its surrounding tiles that day.
                                     
                                      Last edited: Mar 1, 2020
                                    • harryh

                                      harryh Developer

                                      Thanks for pointing this out. Should be fixed on build 141 (android) and 142 (iOS) now both live if you update.
                                       
                                      • Leoleo

                                        Leoleo Space Hobo

                                        I’m playing on iOS, latest update, I think (1.4.5.142), 7th gen IPad.
                                        Issue: butterfly hutches are invisible, I can hold them in my inventory and place them, and they create butterflies but I can’t see them. Everything I’ve gotten from the crane game has the same problem. Exotic trees are the only things with a visible thumbnail, but they show up as long gray tables. Another thing I’ve noticed is farm animals floating outside the map and sometimes when placing furniture it gets placed down across the room from where I tried to put it.
                                         

                                          Attached Files:

                                        • miratus_draco

                                          miratus_draco Aquatic Astronaut

                                          I am experiencing crashes when I go to the cinema and watch a movie. I’ve crashed both times I’ve tried. I went to see the movie alone both times. I am on the newest iOS and most recent stardew version. I have a 2017 iPad 9.7inch

                                          I can’t upload my save file, I have tried but apparently it doesn’t have an extension? Idk.
                                           

                                          Share This Page