Modding Help [Starbound Steam 1.3.3] Problem with unpacking assets

Discussion in 'Starbound Modding' started by ItzNightshade, Feb 26, 2018.

  1. ItzNightshade

    ItzNightshade Space Hobo

    Well... yeah, the title already gives it away. I want to start creating my own mods for Starbound, but I can't seem to get the assets unpacked. My method was to create a Batch file to unpack the assets. Here's the code I used:

    @Echo OFF
    ECHO Don't close this until unpacking is finished!
    "C:\Program Files (x86)\Steam\steamapps\common\Starbound\win32\asset_unpacker.exe" "C:\Program Files (x86)\Steam\steamapps\common\Starbound\assets\packed.pak" "C:\Program Files (x86)\Steam\steamapps\common\Starbound\SB_1.3.3"

    Now to the error I get.
    When I try launching this Batch file, this is what Windows tells me:
    (Yas it's in German, I'll translate it xD)


    This application can't run on this PC.
    Contact the Software Publisher to find a suitable version for this PC.

    Can anyone help me? Please? I've been trying to search for a solution for more than an hour now, and found nothing on this yet. ;w;
  2. Nexus Of Chaos

    Nexus Of Chaos Parsec Taste Tester

    try running the program directly. this will likely do nothing, but if it runs, that means there is a problem with your batch. if the same error comes up, then it is a problem with the file
  3. The | Suit

    The | Suit Agent S. Forum Moderator

  4. ItzNightshade

    ItzNightshade Space Hobo

    Hm, this program doesn't do anything, not even giving me an error message. The log says, it used the asset_unpacker.exe from the win32 folder (which gives me the same error message in the post when launched) to unpack the files and succeeded immediately, not after a few minutes or so. But there's nothing in the directory I wanted to unpack the files to.

    "Unpacking C:\Program Files (x86)\Steam\steamapps\common\Starbound\assets\packed.pak to C:\Program Files (x86)\Steam\steamapps\common\Starbound\unpackedgame...
    Executing C:\Program Files (x86)\Steam\steamapps\common\Starbound\win32\asset_unpacker.exe "C:\Program Files (x86)\Steam\steamapps\common\Starbound\assets\packed.pak" "C:\Program Files (x86)\Steam\steamapps\common\Starbound\unpackedgame"

    But I noticed that the folder asset_unpacker.exe is located in is called win32. There's a win64 folder too, which doesn't have the unpacker in it though. My system is a 64 bit system, not a 32 bit one, so could that be a reason why unpacking won't work for me?
    (I tried putting the unpacker into the win64 folder already, but that doesn't work either. :/)
  5. Nexus Of Chaos

    Nexus Of Chaos Parsec Taste Tester

    no. many programs on a 64 bit computer are actually 32 bit programs. the location of asset_unpacker.exe does not matter, as well as the absense of it in win64.
  6. ItzNightshade

    ItzNightshade Space Hobo

    Ah, thank you... do you have any idea what else could cause the problem?
  7. SpazDiesFirst360.0

    SpazDiesFirst360.0 Phantasmal Quasar

    Possible culprits I can think of...
    • Are "@Echo", "OFF", and "PAUSE" part of the batch file? If so, that is likely the source of the issue.
    • You should check the folder locations to make sure that they are correct if you have not done that already.
    • Make sure that the batch file has the .bat ending, otherwise it is not a batch file.

    This is all that I can think of, otherwise the batch file looks clean. So if none of the above is the reason, I have no idea what else it could be.
  8. slowcold

    slowcold Pangalactic Porcupine

    Here's the batch file I use. Lives in the win32 folder. Shortcut to it in the main starbound directory, and you rename a copy of the pak you want to unpack to temp.pak and put it in the starbound directory. Not my invention - was posted here a while back and I can't remember who wrote it. Works fine with 1.3.3, just tried it.

    @echo off
    echo Unpacking ..\temp.pak into ..\_UnpackedMod\
    echo This may take a long time.
    start /wait /min .\asset_unpacker.exe ..\temp.pak ..\_UnpackedMod
    echo Done.
  9. Nexus Of Chaos

    Nexus Of Chaos Parsec Taste Tester

    you can try the batch file in my signature. I'm absolutely sure it works
  10. slowcold

    slowcold Pangalactic Porcupine

    Damn. Was hoping I were using your bat file. Hate not being able to credit things. :p

Share This Page