1. Welcome to the Starbound support forums. Please check the support FAQs before posting: http://playstarbound.com/support

Bug/Issue Starbound on Linux Server process killed after 1 minute

Discussion in 'Starbound Support' started by Hakuro, Jan 20, 2017.

  1. Hakuro

    Hakuro Intergalactic Tourist

    Hello there!

    I've rented a vServer with 10 Cores and 16 GB RAM to host some games and TS.

    I used the guide http://starbounder.org/Guide:LinuxServerSetup to setup everything on Debian 8.

    Everything worked fine, no error messages.
    Just when I start the server everything is loading, the server is active in a few seconds and I can join it. But after about 1 minute in Putty appears "Killed" and the server is gone.

    I have no clue why this is happening, starbound didn't even use much resources...
    Anybody any clue what I can do or what might be wrong?
     
    Last edited: Jan 22, 2017
  2. Iris Blanche

    Iris Blanche Pudding Paradox Forum Moderator

    Please provide the starbound_server.log located in the storage directory of your server installation path.

    ~ Iris ~
     
  3. Hakuro

    Hakuro Intergalactic Tourist

    [19:39:57.538] [Info] Root: Preparing Root...
    [19:39:57.538] [Info] Root: Done preparing Root.
    [19:39:57.538] [Info] Root: Scanning for asset sources in directory '../assets/'
    [19:39:57.538] [Info] Root: Loaded Configuration in 0.000257858 seconds
    [19:39:57.643] [Info] Root: Scanning for asset sources in directory '../mods/'
    [19:39:57.643] [Warn] Root: Unrecognized file in asset directory 'mods_go_here', skipping
    [19:39:57.643] [Info] Root: Detected asset source named 'base' at '../assets/packed.pak'
    [19:39:57.643] [Info] Root: Detected unnamed asset source at '../assets/user'
    [19:39:57.643] [Info] Loading assets from: '../assets/packed.pak'
    [19:39:57.795] [Info] Loading assets from: '../assets/user'
    [19:39:58.756] [Info] Assets digest is 06cbcabd08c255b023a32ab90661887de878dffa9534c11a0de2b083efe882db
    [19:39:58.756] [Info] Root: Loaded Assets in 1.21804 seconds
    [19:39:58.764] [Info] Root: Loaded NameGenerator in 1.22562 seconds
    [19:39:58.849] [Info] Root: Loaded PlantDatabase in 0.0844759 seconds
    [19:39:58.937] [Info] Root: Loaded ObjectDatabase in 0.18086 seconds
    [19:39:59.049] [Info] Root: Loaded MonsterDatabase in 0.111845 seconds
    [19:39:59.072] [Info] Root: Loaded NpcDatabase in 0.0224818 seconds
    [19:39:59.072] [Info] Root: Loaded StagehandDatabase in 0.000680491 seconds
    [19:39:59.074] [Info] Root: Loaded VehicleDatabase in 0.00143878 seconds
    [19:39:59.076] [Info] Root: Loaded PlayerFactory in 0.00185942 seconds
    [19:39:59.168] [Info] Root: Loaded ProjectileDatabase in 0.319188 seconds
    [19:39:59.169] [Info] Root: Loaded VersioningDatabase in 0.000667306 seconds
    [19:39:59.169] [Info] Root: Loaded EntityFactory in 0.0929738 seconds
    [19:39:59.200] [Info] Root: Loaded ParticleDatabase in 0.0312183 seconds
    [19:39:59.202] [Info] Root: Loaded ImageMetadataDatabase in 1.11794e-06 seconds
    [19:39:59.409] [Info] Root: Loaded MaterialDatabase in 0.240198 seconds
    [19:39:59.413] [Info] Root: Loaded TerrainDatabase in 0.00409835 seconds
    [19:39:59.439] [Info] Root: Loaded BiomeDatabase in 0.0256412 seconds
    [19:39:59.439] [Info] Root: Loaded LiquidsDatabase in 0.000512534 seconds
    [19:39:59.444] [Info] Root: Loaded StatusEffectDatabase in 0.00488781 seconds
    [19:39:59.603] [Info] Root: Loaded DamageDatabase in 0.158322 seconds
    [19:39:59.606] [Info] Root: Loaded EffectSourceDatabase in 0.00363331 seconds
    [19:39:59.609] [Info] Root: Loaded FunctionDatabase in 0.00281866 seconds
    [19:39:59.632] [Info] Root: Loaded TreasureDatabase in 0.0225436 seconds
    [19:39:59.785] [Info] Root: Loaded DungeonDefinitions in 0.153192 seconds
    [19:39:59.785] [Info] Root: Loaded TilesetDatabase in 2.719e-06 seconds
    [19:39:59.787] [Info] Root: Loaded StatisticsDatabase in 0.0016636 seconds
    [19:39:59.787] [Info] Root: Loaded EmoteProcessor in 8.72239e-05 seconds
    [19:39:59.794] [Info] Root: Loaded SpeciesDatabase in 0.00637451 seconds
    [19:39:59.801] [Info] Root: Loaded QuestTemplateDatabase in 0.00758449 seconds
    [19:39:59.802] [Info] Root: Loaded AiDatabase in 0.000875649 seconds
    [19:39:59.803] [Info] Root: Loaded TechDatabase in 0.000542266 seconds
    [19:39:59.806] [Info] Root: Loaded CodexDatabase in 0.00297492 seconds
    [19:39:59.951] [Info] Root: Loaded BehaviorDatabase in 0.145505 seconds
    [19:39:59.953] [Info] Root: Loaded DanceDatabase in 0.00175657 seconds
    [19:39:59.956] [Info] Root: Loaded SpawnTypeDatabase in 0.00308223 seconds
    [19:39:59.958] [Info] Root: Loaded RadioMessageDatabase in 0.00159719 seconds
    [19:40:01.262] [Info] Root: Loaded ItemDatabase in 2.09413 seconds
    [19:40:01.378] [Info] Root: Loaded CollectionDatabase in 1.42049 seconds
    [19:40:01.480] [Info] Server Version 1.2.2 (linux x86_64) Source ID: <<deleted for safety>> Protocol: 729
    [19:40:01.480] [Info] UniverseServer: Acquiring universe lock file
    [19:40:01.485] [Info] UniverseServer: Loading settings
    [19:40:01.486] [Info] UniverseServer: Starting UniverseServer with UUID: <<deleted for safety>>
    [19:40:01.487] [Info] UniverseServer: listening for incoming TCP connections on 0000:0000:0000:0000:0000:0000:0000:0000:21025
    [19:40:02.542] [Info] Root: Writing runtime configuration to '../storage/starbound_server.config'

    (in Putty appears "Killed" 20 seconds to 1 minute afterwards right after the last line I've posted)

    starbound_server.config is vanilla, no changes done. Maybe I have to put the IP of the server in there?
     
    Last edited: Jan 22, 2017
  4. Iris Blanche

    Iris Blanche Pudding Paradox Forum Moderator

    The log looks fine so far. Do you have some entries in the syslog related to starbound or the libraries used by it?

    FYI: removing the ids from the log isn't necessary. Source ID is some sort of checksum of the executable and Universe UUID is just the identifier for the used universe so both are safe to post ^-^

    ~ Iris ~
     
  5. Hakuro

    Hakuro Intergalactic Tourist

    I'm new to linux to know where to look, so I just checked all log files in /var/log and I couldn't find anything related to starbound except user logins I've done.
     
  6. Hakuro

    Hakuro Intergalactic Tourist

    Let's ask a dumb linux question:

    I've installed both ia32-libs and lib32gcc1. Maybe the libs interfere with each other and I have to uninstall the first one? Still getting the message "Killed" after a short time the server is up

    Edit: Ok ia32-libs isn't installed at all, maybe got replaced by lib32gcc1?! A lot to learn about Linux, but enjoyed working with DOS 20 years ago too, so I feel kind of nostalgic ^^
     
    Last edited: Jan 24, 2017
  7. Hakuro

    Hakuro Intergalactic Tourist

    I've done ldd on starbound_server to check the libs

    linux-vdso.so.1 (0x00007ffdfa595000)
    libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f913e05f000)
    libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f913de5b000)
    librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f913dc52000)
    libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f913d951000)
    libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f913d5a6000)
    /lib64/ld-linux-x86-64.so.2 (0x0000556ecab38000)

    Is there missing something? Looking on first line and last I'm not sure if that is right...
     
  8. Hakuro

    Hakuro Intergalactic Tourist

    The provider of my vServer told me to do a strace. Still not sure if it is a problem of starbound_server or the linux itself. Attached the strace stored into a log file. Maybe somebody here can take a look on it and tell me what's wrong...
     

    Attached Files:

  9. Hakuro

    Hakuro Intergalactic Tourist

    Well Iris Blanche, thank your for forwarding this problem to the devs, but it seems they are busy with other stuff, didn't contact me the last weeks while I was waiting...

    Doesn't seem to be any solution here for the problem. Everything is loading fine as it seems but somehow "sigkill" keeps appearing between 15-60 seconds after everything is fully loaded no matter if somebody is connecting in that time and doing stuff with their toons or not.
    But it doesn't matter anymore. Me and my friends moved on to another game meanwhile and if we really want to keep playing in our galaxy, we just start the gameserver on a local machine in windows

    thanks and good bye o/
     

Share This Page