1. Lose your pre-order key? Try using Humble's key resender. Also, please check the support FAQs before posting: http://playstarbound.com/help/
  2. Hey Guest! Our new game Wargroove has released! Check out the forums or wiki for more information!
    Dismiss Notice

Closed STARBOUND BETA: BUGS DATABASE (UPBEAT GIRAFFE) -Bug testers needed

Discussion in 'Support' started by Alucard I, Dec 21, 2014.

Thread Status:
Not open for further replies.
  1. Valkyrie_pl

    Valkyrie_pl Big Damn Hero

    From pleased giraffe:
    When I wanted to buy fuel in outpost (I had a bit over 10k pixels, probably 11k+), I selected it in shop and clicked left arrow next to the amount shown. It's generally the fastest way to buy / craft maximum amount you can. Previously, under 10k pixels (around 5-6k), it just defaulted to 1000 and I could repeatedly buy 1000 until I no longer had enough pixels. With over 10k it remained at 1, while total cost jumped to my current amount of money. I confirmed purchase and only got 1000 fuel, while all my funds were consumed. Damn shady merchant.

    Edit:
    Rocket boots sound can still glitch and get stuck in a loop that doesn't end till you exit to main menu.
     
    Last edited: Aug 28, 2015
  2. llearch

    llearch Intergalactic Tourist

    I've had this. If you resize the screen, it seems to reset the sound as well - at least, for me. See my previous page post on lag for full details of screen sizing - this is still a valid bug in the latest update on steam. Can you test if this resets the sound for you?
     
  3. Valkyrie_pl

    Valkyrie_pl Big Damn Hero

    When I get it again and if I remember...
     
  4. knohr

    knohr Space Hobo

    Possible DoS vulnerability in current Steam version of starbount_server.

    From my reddit post "unable to link due to just creating this account"

    TL;DR; High server CPU usage is linked to clients attempting to connect on default port but never authorizing.


    Hi all. I've been googling around, but I can't seem to find the help I am looking for.

    We are currently running a dedicated server from my wife's windows 7 box (64gb 2400 ram quad channel, 3930k @ 4.0 ghz)

    Yet, even when everyone is off of the server, it still eats up 83% of the cpu (which is 12 logical cores). Anyone have tips on lowering the cpu usage?

    I mean, we could run this inside of a virt and limit the cores available, but I'd like to avoid it.

    EDIT: It seems to coincide with 10x failed connection attempts from random IPS. I had discounted this as simple port scanning as no client every connects in this case, is there simply a bug in how session management works or something?

    EDIT 2: Unable to reproduce with actual logins from the game client.

    EDIT 3: Unable to reproduce with simple telnet sessions to the client. Did I get hit with some sort of DoS attack?

    EDIT 4: Out of time, need to head to work. Everything still seems to be tied to those 10 ips that attempt a connection, but do not authenticate.

    EDIT 5: Added a password, added accounts, disabled anon logins. After about an hour another "failed to connect msg" from a random IP and the CPU load went from 1-2% to 15%. Resterted server, it's back to 0-1%. I now feel this is directly related. *said spikes never happen when it is our actual players connecting.

    EDIT 6: After changing to a non-standard port, the random connections have ceased. And so far no cpu usage spikes. I feel that people are actively looking for starbound servers and DoSing them.

    EDIT 7: Found reports of a server vulnerability from back in january, could this be related to my issue? http://community.playstarbound.com/...lities-workarounds-and-fixes-available.88613/
     
    Last edited: Sep 3, 2015
  5. OciexGamer

    OciexGamer Void-Bound Voyager

    Graphical glitches after i play for a while weird numbers like o x 9 comes all over the screen graphics goes all over the place, a quick restart fixes the problem.
     
  6. Mrpoppants

    Mrpoppants Void-Bound Voyager

    I was doing he Floran Hunt Mission. And after I defeated the bone spider those little boney things kept spawning even after its death...\

    Those things killed me at the last second I defeated that DAMN thing.
     
  7. Fawnalie

    Fawnalie Void-Bound Voyager

    I've got a bug where when Starbound updated last on Steam that an item I needed to create for the quest "Stirred not Shaken" the Stirring Spoon is not a recipe anywhere (yes, I am using the Metalwork Station and I have enough Steel Bars). I've also tried making new characters and trying to make it but it's also not there for them.
    [​IMG]

    I also had a bug where upon using the Paint Tool on a Mushroom block in a cave prior to the latest update it completely crashed my game and my entire save file corrupted, I couldn't open up the file it would just crash the game. I had to completely delete that character and remake and it was very upsetting.
     
  8. hoboshoe

    hoboshoe Astral Cartographer

    got this too
     
  9. Valkyrie_pl

    Valkyrie_pl Big Damn Hero

    Yep, toggling fullscreen with F11 does fix the sound loop.
     
  10. 0xE1

    0xE1 Scruffy Nerf-Herder

    Version: Giraffe - Update 4
    Classification: NPC, Items
    Severity: Minor
    Attempting to buy or sell items with 0 price would not activate "Buy" or "Sell" button.
    I presume button is activated when price is non 0 rather then item being selected (for buy) or amount of items for sell.
     
    Last edited: Sep 6, 2015
  11. Micholinos

    Micholinos Space Hobo

    My problem would be categorized in the 4th one because while playing the game it bugged and the program closed without my consent . After that I logged in again and my character disappeared without me deleting him. Is there a way to recover him?
     
  12. fuzzznuttzzz

    fuzzznuttzzz Space Spelunker

    Bug Post:
    Game crashes with every type(32,64 normal and openGL) upon startup.
    Sometimes brings up the loading screen and does nothing after but mainly just stops at the Chucklefish logo


    Version: Pleased Giraffe
    Date: September 10,2015 Update 5
    Classification: 3

    Pastebin Crash Log:
    R3dFFE3n
    This is only posted for a month!

    I'm hoping this is fixed soon I really want to play!
     
  13. Dunto

    Dunto Guest

    Remove your mods and try a fresh character.
     
  14. Micholinos

    Micholinos Space Hobo

    i started the game again made a new character and started playing when i left the ship to beam down to the planet for the first time after only a couple of seconds the game and my whole computer crushed without reason this is the second time something like that happened . The first time 1 week ago was when the character with whom i have been playing for almost a month now got delete. What exacly am i doing wrong or is it because of the new update ? Before this one i had no problem with the stable version. And i am not using any mods.
     
  15. fuzzznuttzzz

    fuzzznuttzzz Space Spelunker

    I have tried deleting characters but it keeps giving me the same thing and I also forgot to say this was running on windows 10 if that helps... I also have no mods installed... I have even removed everything from starbound off my computer and it still does the same error.
    Either way thanks for the reply!
     
  16. Dunto

    Dunto Guest

    Start a thread in the Support forum if you haven't already. Don't forget to include a copy of your starbound.log (in a spoiler) when you post.
     
  17. Exar Kun

    Exar Kun Void-Bound Voyager

    Version: Pleased Giraffe
    Date: September 11,2015 Update 5 (and earlier ones)
    Classification: 3. Moderate bug

    Random planet traveling gets me infinite FTL. Save and exit gets my ship to random new location. On recent try today, cant return on previous location because it CTD when i enter old navigation coordinates i wish to go. And just go into a cyrcle again....

    Using only "S3r1ous mod pack" that is up to date.
     
  18. Alucard I

    Alucard I King Homestuck I

    Did you guys delete all the previous pages of stuff? Nice.
     
  19. Gilligan Lanley

    Gilligan Lanley Hard-To-Destroy Reptile

    Problem:
    Unable to pick up a stack of iron ingots on personal ship when dropped.

    What I think the cause is:
    Unsure, haven't encountered a bug like this until now.

    Evidence:
    imgur -- qi2Op67
    (I can't post external links yet, working on it!)



    Bits and Pieces:
    • Version: Pleased Giraffe - Update 5
    • Date: 9/19/2015, 3: 39 p.m. (UTC -3: 30)
    • Classified : Type 0 - Items
    Summary:
    Unable to pick up item(s) dropped in space ship, deleted upon client restart.

     
  20. Alucard I

    Alucard I King Homestuck I

    @Dunto are you guys still doing the thing? That's so nice of you, really! <3
     
Thread Status:
Not open for further replies.

Share This Page