1. Lose your pre-order key? Try using Humble's key resender. Also, please check the support FAQs before posting: http://playstarbound.com/help/
  2. Hey Guest! Our new game Wargroove has released! Check out the forums or wiki for more information!
    Dismiss Notice

Closed Starbound and Visual C++ 2015 installer issues

Discussion in 'Support' started by Healthire, Aug 26, 2015.

Thread Status:
Not open for further replies.
  1. OmnipotentEntity

    OmnipotentEntity Code Monkey Forum Administrator

    Excellent idea. A quick note about using the regsvr32 command is that you can also use it to unregister dlls as well as register them. And for a repair registration it might be beneficial to run regsvr32 /u dllname.dll first, then followed by regsvr32 dllname.dll to be fully effective.
     
    The | Suit and lazarus78 like this.
  2. Shadaziel

    Shadaziel Big Damn Hero

    Hi guys just want to say thanks for making this thread as I wasted alot of time trying to get this to work and failing It helped alot. you've managed to help me fix more Microsoft problems than Microsoft I'm never asking them about anything again anyway thanks for the help and good luck on making more awesome stuff. :DD

    This is a bit off topic but I was also wondering why you changed version of C++ to use, I'm not a very good programmer but I got the impression from other heavier users I know that the code doesn't change much between newer versions save a couple of extra functions more or less and I wouldn't have thought it would help to much to change unless its more compatible with windows 8 and 10?
     
  3. The | Suit

    The | Suit Agent S. Forum Moderator

    Omni made a post about it in reddit a while back, let me just pull it up.
    I have no idea what it means, but it revolves around changing a dohiky with a watcha ma call it and now the game is speaking the common tongue.
    https://www.reddit.com/r/starbound/...s_how_to_get_new_nightly_build_to_run/cu4pkki
     
  4. MisterHalt

    MisterHalt Scruffy Nerf-Herder

    Guess I won't be playing Starbound again any time soon. Even after running /sfc scannow, chkdsk, and all that other junk I can't get Service Pack 1 to install, as it fails right at 99% and reverts. And since the whole process takes like a bloody hour each time I try, I'm not exactly in the mood to just keep reattempting until I know exactly what the problem is.
     
  5. The | Suit

    The | Suit Agent S. Forum Moderator

    There should be a log when it fails, or an error message of some sort.
    But Sp1 not installing generally means something isn't all too good with your windows installation so you should take it a bit seriously as - it will be much more vulnerable to other issues without getting the latest updates.
     
  6. MisterHalt

    MisterHalt Scruffy Nerf-Herder

    I didn't see an error message, and I don't know where to start looking for a log.
     
  7. The | Suit

    The | Suit Agent S. Forum Moderator

  8. MisterHalt

    MisterHalt Scruffy Nerf-Herder

    That Fixit thing was useless. None of the problems there came close to mine.

    After Googling around some more I installed several hotfixes that supposedly helped when installing the Service Pack, downloaded and ran that update readiness thing (which just installed another hotfix), clean booted, disabled my anti-virus... And SP1 still won't install, claiming "Failure configuring Service Pack. Reverting Changes." Got an error message this time though:

    "The service cannot accept control messages at this time." ERROR:ERROR_SERVICE_CANNOT_ACCEPT_CTRL(0x80070425)
     
  9. The | Suit

    The | Suit Agent S. Forum Moderator

    http://answers.microsoft.com/en-us/...ror-code/109b0d53-9486-4905-88a8-03bae119a79e
    A thread discussing your issue
     
  10. MisterHalt

    MisterHalt Scruffy Nerf-Herder

  11. Leven89

    Leven89 Scruffy Nerf-Herder

    So this guy i know.. *cough*.. not me, has a pirated version of windows. I guess I am out of luck on getting this resolved? I already tried the re-installs for Visual C++, but they failed. I doubt there's a way around it huh?
     
    1Meg6502 likes this.
  12. The | Suit

    The | Suit Agent S. Forum Moderator

    Generally speaking how pirated windows works is it disables authentication checks by the operating system.
    In many cases disables windows updates preventing you from getting required KB files.

    Now specific updates requires those authentication checks to work in order for them to be applied.

    ==
    Remember none of the issues in this thread at all deals with the game in general.
    Everyone in this thread who had an issue so far was because of something wrong with their windows installation.

    In all honesty this should have been something resolved on Microsoft community support forums, but Devs are being awesome enough to spend time helping people to resolve an unrelated Windows issue.
     
  13. Leven89

    Leven89 Scruffy Nerf-Herder

    But to be fair the game worked for me up until it was changed just recently. I realize that this IS a windows problem (or my mistake for using a pirated version for that matter), but at the same time it was never a problem to play until recently. All I'm asking and i don't think it's much, is if there is a way around this that can help me to play this great game again.
     
  14. The | Suit

    The | Suit Agent S. Forum Moderator

    Well can't really support users who are trying to circumvent piracy.
    I am sure microsoft won't be too happy with CF if they are trying to help pirates find a way to get past their circuit checks on updates. So you will need to find some where else to ask.
    But linux is always a good option since Dual booting is reasonably simple to do.[DOUBLEPOST=1440864764,1440864345][/DOUBLEPOST]Just an update

     
  15. torrrenz

    torrrenz Space Spelunker

    I have x64 Windows 7 with SP1. I get the api-ms-win-crt-runtime-I1-1-0.dll error when trying to launch the game. Installing the prereqs ends in a setup error saying "0x80070003 - System cannot find path."
    My windows update has been deactivated for like 3 years ever since it stopped working at some point giving me 0x80070003 errors and I've never been able to fix it.
    Installing the lastest version package simply tells me the installation failed with error 0x80070003. Using the FixIt to reregister components finishes with "Windows Update-Problem 0x80070003 - Not Fixed".

    I've wasted so much time on this already, I can't believe it's suddenly keeping me from playing Starbound. What else can I try?
     
  16. The | Suit

    The | Suit Agent S. Forum Moderator

    You will need to get windows update to work first
    https://support2.microsoft.com/common/survey.aspx?scid=sw;en;3779&showpage=1
     
  17. SilverDevil

    SilverDevil Void-Bound Voyager

    I don't speak asian I cant do this :(
     
  18. LostSeeker

    LostSeeker Subatomic Cosmonaut

    I was having this problem as well on a Windows 7 PC, but I MANAGED to fix it after enough gnashing of teeth. Fortunately, I wrote down a rough list of events on my desk I went through that lead up to the fix. Here's how it went for me:
    • Fired up Windows Update, looked at the list of optional updates (which I overlooked before on failed attempts), and noticed that the labels looked a LOT like the numbers and letters found after the Service Pack 1 downloadable. I ended up checking to download all that had that resemblance
    • 1 update was successful, 8 failed. Reasons given were error code 80070003, and error code 80070308. I noticed both were listed as links.
    • Clicking on either sent me to a Windows Help and Support section listing numerous error codes (excluding 80070308:mad:) I clicked on the one with error 80070003 listed, and the first link it listed was a "Windows Update Troubleshooter"
    • Clicking on the link, it promptly downloaded a "WindowsUpdateDiagnostic.diagcab".
    • I ran it, and it went to work attempting to correct the update issues. The results was this:
    :cancel: Service Registration is missing or corrupt
    :cancel:Windows Update error 0x80070005 (2015-08-29-T-05_39_53P)
    :confirm: Some security settings are missing or have been changed
    :confirm:Problems installing recent updates. (3 of these in a row)
    • Proceeded to restart, windows configured itself before restarted completed.
    • Ran windows Update again and... ALL 7 UPDATES SUCCEEDED! :DD
    • Restarted my PC again
    • Ran both vc_redist.64.exe and vc_redist.86.exe for good mesure. BOTH SUCCEEDED this time. :pwease:
    • Fired up Starbound. Immediately heard a familiar chuckle after a few seconds. :chucklefish:
    • Immediately started flailing fists in the air in sheer joy.
    That's my story for how I fixed i on my end. Sorry if it may be sloppy, too much lurking and not enough posting and haven't had much practice making things easy on the eyes... Anyways, I REALLY hope this can help some people.

    Edit: found a way to keep the list from taking up less space while still being spaced apart
     
    Last edited: Aug 30, 2015
    The | Suit likes this.
  19. darkside555

    darkside555 Yeah, You!

    I already have SP1 for Windows7 but the "api-ms-win-crt-runtime|1-1-0.dll" continues
     
  20. Birdbody

    Birdbody Void-Bound Voyager

    Your fixes are indeed helpful however there is a variance in the issue I am facing. The visual c++ x64 pre-req file repairs successfully, I do have windows 7 64bit with service pack 1 and the game worked before this most recent patch. I tried an uninstall/install of c++ as well as starbound however there is no action when I try to launch the game via steam. I ran steams verify game integrity feature and it came up successful. If i single click the play button nothing loads if i double click I get a brief flash of "preparing to launch starbound" in the steam mini-window however no action or errors. I tried running the x64 exe from the directory and get an error "The procedure entry point ucrtbase.terminate could not be located in the dynamic link library api-ms-win-crt-runtime-l1-1-0.dll." I tried to run the launcher via exe in the directory and received the following error "The application was unable to start correctly (0xc000007b). Click ok to close the application. I attempted to comb the starbound folders but could not locate a helpful error logfile. Any suggestions on what else I could try to get this game running? Thanks in advance!!
     
Thread Status:
Not open for further replies.

Share This Page