1. This forum is primarily for mobile related issues - for support for PC/Console visit the support section of forums.stardewvalley.net

Resolved [SOLVED] Weird snow(?) pixels that won't go away after tilling a tile on my farm.

Discussion in 'Support' started by brip1296, Nov 17, 2019.

  1. brip1296

    brip1296 Scruffy Nerf-Herder

    FIXED! See bottom of post for my solution!

    Hi! Sorry if this is better off in Modding Help - I'm not sure if I'm experiencing a base-game issue or one introduced by SMAPI or a mod or combination of mods. Thanks in advance for any help someone might be able to offer! And sorry for the long post!!

    I made a new save a week or so ago to play with the mod Stardew Valley Expanded and the optional Immersive Farm 2 Remastered map for the Standard farm. I'm running some more mods alongside those and until today, it was going great and without any big issues that I haven't been able to sort out on my own or after some quick research. However, about an hour ago I ran into something strange that I can't figure out how to fix.

    I'm in the first week of Winter now, and I was trying to scrounge up some Winter Roots and Snow Yams by tilling the ground on my farm before going on to the next day. Upon tilling one particular tile, though, this weird clump that I'm assuming is supposed to be a bit of snow appeared on top of the tilled ground.

    (Imgur Link)

    It displays on top of my farmer and any objects I place on that tile, and I can't get it to go away. It was definitely not there before and just blending in with the snow, as I've had a Bee House in that spot for most of this save file's lifetime. I only moved it elsewhere at the very start of Winter.

    I loaded a save backup to the 1st of Winter, before I tilled that tile, and it's now there on that save. I have no idea why this is happening, even on that backup. I've also tried restarting my computer, to no avail. I'm kind of stuck now, so I'd really appreciate it if someone could point me in the right direction!

    If it helps to diagnose the issue at all, I'll also upload my SMAPI-latest.txt to the SMAPI log parser and include it below! Thanks again! I'll be going to bed shortly after I post this, but I'll check back periodically in the morning in case I can answer any questions that might help us figure this out! :D

    (Link for my SMAPI-latest.txt)

    EDIT: I uploaded the wrong SMAPI-latest.txt lmao, that was an old one, sorry, I'm super tired! Uploaded the right one and fixed the link!

    EDIT 2: This morning I made a new save file with the same mods, and the issue was gone. However, it's still present on my current file. I don't have time at the moment to do more testing with the new save file, but later I'll move her to Winter and see if I can replicate the issue then. :D

    EDIT 3: I found the cause and fixed it! For anyone else with this issue that stumbles across this thread, there's a lamp post in the winter_extras.png in \[CP] Immersive Farm 2 Remastered\assets\default, with snow on top of it. The top of the snow matched the pixels I was seeing, so I edited the pile of snow to be two pixels shorter, and the mystery pixels are gone! :D
     
      Last edited: Nov 18, 2019

    Share This Page