Modding Help SOLVED: SMAPI & Missing Steam Overlay

Discussion in 'Mods' started by Minininny, Apr 29, 2017.

  1. Minininny

    Minininny Void-Bound Voyager

    Hello all,

    I'm having a bit of an issue with SMAPI and Steam. Last night, I could use the Steam overlay with SMAPI just fine. However, today, I can't have it show up.

    To begin, I do have Steam configured to run StardewModdingAPI.exe instead of the original .exe:

    The whole launch string is: "C:\Program Files (x86)\Steam\steamapps\common\Stardew Valley\StardewModdingAPI.exe" %command%

    Anyway, that's fine and all. But I noticed that last night when I was playing, there was a string of text in SMAPI as it would start up that I would presume would correlate to Steam (as I recall, it said minidump and some other numbers, likely correlating to my steam id).

    But now it doesn't do that:


    The red arrow is where that string of text was (roughly) located, but now it's missing. Steam still launches SMAPI, but I just can't get the overlay to appear.

    I'm not really sure what happened in between last night and now, but it's a bit annoying (and also a perplexing mystery).

    If anyone could help me out, I'd really appreciate it!

    Also in case it's hard to read the screenshot: I'm running SMAPI 1.10 and Stardew Valley 1.2.26.

    UPDATE (Solution):

    It's really the simple things that work. I just had to restart Steam.


    It's all fixed now. Hopefully this can help someone else with the issue, I guess! (And I added the yellow highlight with the snipping tool, it's actually just white in SMAPI.)
      Last edited: Apr 30, 2017
    • macaro0n

      macaro0n Void-Bound Voyager

      I wish it was that simple, ever since Im using SMAPI I can no longer use Steam overlay, and of course I cant screenshot :(

      (that Setting breakpad minidump and the line after Steam_SetMinidumpSteamID appear well without any difference as you shown)

      EDIT :
      I redo the custom launch command (Stardrew Valley-->lmb click-->Properties-->Set launch options) and it works now :D
        Last edited: Jul 16, 2018

      Share This Page