1. Welcome to the Starbound support forums. Please check the support FAQs before posting: http://playstarbound.com/support

Tutorial [SOLUTION] Game crashing upon attempting to load a character

Discussion in 'Starbound Support' started by thetraindoctor, Jun 15, 2017.

  1. thetraindoctor

    thetraindoctor Orbital Explorer

    After having numerous problems on the Linux version of the game I have found a way of resolved this issue on all versions of the game.
    The error I encountered was this one specifically:
    [Error] Application: exception thrown, shutting down: 
    std::exception: tinyformat: Not enough conversion specifiers in format string
    This error is what occurs when, at least to my knowledge, only when you have a corrupted save file.

    First, navigate to your save location by going to your Steam installation of the game by right clicking on the game's name in Steam, go to Properties, Local Files (make sure you have re-validate your files and uninstalled all mods) and Browse Local files. This will take you to the installation location.

    From here you need to attempt to launch the game. If the game crashes with the same error as before continue with this guide.

    Next up at this point go to the storage folder in your Starbound installation I mentioned earlier. Make backups of your universe and player folders in case you want to attempt to find which mods might fix the issue if the corruption is simply caused by a lack of a mod. Go ahead and launch the game in it's vanilla state. It should be working order and load a world in for your new character. Finally, I have some sad news to tell you, but first some good news. You can actually play the game now! Hooray! Unfortunately, your character and universe is likely irretrievable. Go ahead, let it out, you can cry on my shoulder.

    TL;DR Validate all of your game-files, unsubscribe from all mods and manually subscribe to each one after backing up your player and universe folders and removing all files within the original player and universe folders to the backups you made.



    Error summary from my previous post.
    • What: Crash on attempting to load character
    • How/Activity: Attempting to launch from executable, steam or ./run-client.sh script
    • Repetition: 100% reproduction rate out of 50 attempted launches
    • OS: Windows, Linux, Mac
      • Since I figured out this was to due to save corruption I now know this error occurs on all platforms.
    • OS: Linux 64-bit, specifically openSUSE Leap 42.2 within the Plasma 5 desktop
      • (This error does not seem to occur on Windows but I have not been able to properly test it on Windows.
    • Mods?: I have tested with and without mods. 25 of my 50 attempted launches were done without mods
    • Error Logs: Included below, one for ./run-client.sh or executable/Steam
  2. Angelice

    Angelice Space Hobo

    Please I need help, I have 461 hours logged on starbound through steam and countless hours off of steam, it is my favorite game i own but yesterday i encountered an issue where trying to load my character it will get to the point where it loads the guy but no objects and it just shuts the game window with no error messages whatsoever! i made a new character just to see if it was the game and it wasn't, the new guy loads perfectly every time however that's a lot of time and effort down the drain if i cant get back on my character and i don't want to lose everything I've worked for just because! i don't understand why it is doing this as i don't use any mods at all and i have contacted chucklefish about it but they seem unresponsive about it, please if there is anything you might be able to tell me that could help me fix this issue i would be extremely grateful for the information!!!

Share This Page