Tool SMAPI: Stardew Modding API

Discussion in 'Mods' started by ClxS, Mar 6, 2016.

  1. Pathoschild

    Pathoschild Giant Laser Beams

    @Aryade Unfortunately we can't directly diagnose errors in the game's Update method (I'm hoping for a change in Stardew Valley 1.3 to fix that). Here are some things to try:
    1. Remove all your SMAPI mods temporarily; does it still happen? If not, reinstall your mods one at a time until it starts happening again. That should tell you which mod causes it.
    2. If it still happens with no SMAPI mods installed, try resetting your content files.
    Let me know what the results are and I'll help you from there. :)
     
    • Jaata

      Jaata Master Chief

      reinstalling with newest update let's see which mods work this go round haha :)
       
      • Loony Luna

        Loony Luna Poptop Tamer

        Can someone help me? My game keeps crashing with this message.
        An error occured in the overridden update loop: System.NullReferenceException: Object reference not set to an instance of an object.
        at StardewValley.Game1.Update(GameTime gameTime)
        at StardewModdingAPI.Framework.SGame.Update(GameTime gameTime) in D:\source\_Stardew\SMAPI\src\StardewModdingAPI\Framework\SGame.cs:line 260
         
        • Pathoschild

          Pathoschild Giant Laser Beams

        • Loony Luna

          Loony Luna Poptop Tamer

          So this is the full crash report.
           

            Attached Files:

          • Pathoschild

            Pathoschild Giant Laser Beams

            @Loony Luna It's hard to diagnose errors in the game's Update method (at least until Stardew Valley 1.3), so we need a few tests to find the issue. Try this:
            1. Remove all your SMAPI mods temporarily; does it still happen? If not, reinstall your mods one at a time until it starts happening again. That should tell you which mod causes it.
            2. If it still happens with no SMAPI mods installed, try resetting your content files.
            Let me know what the results are and I'll help you from there. :)
             
            • Loony Luna

              Loony Luna Poptop Tamer

              I removed the advanced machinery mod and it seems to work now!! Thanks so much for your help!!! I'm not sure if you can help with this other problem that I'm having. I have the expanded shop mod and the framework mod, but some of the items say that they have no value. I tried going into the config file, but it keeps reverting back.

              Again thank you so much!
               
              • Pathoschild

                Pathoschild Giant Laser Beams

                @Loony Luna It might be something wrong in your config file. Try this:
                1. Edit the config file again.
                2. Attach a copy of the config file before you play.
                3. Launch the game and attach a screenshot of the shop items.
                4. Attach a second copy of the config file.
                5. Attach your latest SMAPI log.
                So that should be four attachments: config file before & after playing, screenshot, and SMAPI log.
                 
                • Loony Luna

                  Loony Luna Poptop Tamer

                  So when I changed the config, the items were in the shop, but the config reverted back to not having values after I closed the game.
                   

                    Attached Files:

                  • Pathoschild

                    Pathoschild Giant Laser Beams

                    @Loony Luna Shop Expander doesn't support setting a custom price, which is why the fields disappear. Did you see documentation somewhere that mentions a Value field?
                     
                    • Loony Luna

                      Loony Luna Poptop Tamer

                      It's ok. It started to work. Thanks again for all your help!!!
                       
                        Pathoschild likes this.
                      • Lily123

                        Lily123 Space Hobo

                        Just installed Stardew Valley (GOG edition), started a new game to create the ini, and ran the SMAPI installer from this site here: https://github.com/Pathoschild/SMAPI/releases

                        When I run the "StardewModdingAPI.exe" the game starts but the resolution is messed up. The game appears half way off the screen and when I hit alt+enter to go full screen it either crashes or only takes up part of the screen, the rest of the screen is black.

                        What am I missing here? Any help with this would be greatly appreciated, thank you.

                        FYI - I did recently uninstall the steam version of the game and install the GOG version but after doing do I deleted my old save data and appdata files then reran the game start up to make sure everything was fresh. The game seems to run fine using the normal game .exe. I have no mods installed yet.
                         

                          Attached Files:

                        • Lily123

                          Lily123 Space Hobo

                          Edit: I uninstalled everything and deleted the appdata folder then reinstalled the game and started a new game without using the SMAPI. On further inspection I noticed the game doesn't seem to be saving my settings. I started a new game, changed the resolution from 4k to 1600x900 then slept to save the game and exited. Upon re-entering the resolution reset to 4k again.
                           
                          • Pathoschild

                            Pathoschild Giant Laser Beams

                            Hi @Lily123. Make sure you have the latest Stardew Valley 1.2.33; the earlier 1.2 releases had various bugs including resolution issues.
                             
                            • Pathoschild

                              Pathoschild Giant Laser Beams

                              SMAPI 2.0 beta 2 is now available for Linux/Mac/Windows! (download link)

                              See what's new in SMAPI 2.0 beta. Here are the changes since beta 1:
                              • For players:
                                • Updated mod data for compatibility & update checks.
                                • Fixed "collection was modified" error for some players when starting the game.
                                • Fixed error when update-checking a mod which isn't in SMAPI's data.
                              • For modders:
                                • Added warning when a mod uses dynamic, which won't work on Linux/Mac.
                                • Updated Json.NET from 8.0.3 to 10.0.3.
                                • Fixed InputEvents providing decimal tile coordinates.
                                • Fixed SMAPI allowing custom maps to reference tilesheets using absolute or directory-climbing (../) paths. These are unlikely to work for most players.
                              Feedback and bug reports are welcome here! For help with mod compatibility, see how to fix mods broken in SMAPI 2.0.

                              [Edit: download removed. See latest version instead.]
                               
                                Last edited: Oct 14, 2017
                              • Rhiannon94

                                Rhiannon94 Intergalactic Tourist

                                I'm sorry if this has already been asked, but I'm trying to install Seasonal Immersion and am not sure what to do. I have the folder and unzipped it but where does it go?
                                 
                                • Pathoschild

                                  Pathoschild Giant Laser Beams

                                • Rhiannon94

                                  Rhiannon94 Intergalactic Tourist

                                • Pathoschild

                                  Pathoschild Giant Laser Beams

                                  SMAPI 2.0 beta 3 is now available for Linux/Mac/Windows! (download link)

                                  Changes since beta 2:
                                  • For modders:
                                    • Fixed initial assets not being reloaded for a mod which implements IAssetEditor or IAssetLoader directly.
                                    • Fixed recipe data not being reassigned when it's reloaded.
                                  [Edit: download removed. See latest version instead.]
                                   
                                    Last edited: Oct 14, 2017
                                  • Pathoschild

                                    Pathoschild Giant Laser Beams

                                    SMAPI 2.0 is now available for Linux/Mac/Windows!

                                    This is the biggest release since SMAPI 1.0, and it's the culmination of months of planning, development, updating mods, and testing. Feel free to post feedback or issues here, and have fun!
                                     

                                    Share This Page