Tool SMAPI: Stardew Modding API

Discussion in 'Mods' started by ClxS, Mar 6, 2016.

  1. springacres

    springacres Sandwich Man

    Got the error again, and I think I finally figured out what's causing it. Seems like it throws the error when I try to eat something and the cursor isn't hovering over my character, but only when I'm in the mines... does that make any sense at all?
     

      Attached Files:

      Last edited: Jul 13, 2017
    • julezmartell

      julezmartell Intergalactic Tourist

      Hi Guys,

      i know there's a SMAPI installation guide for Mac, but it doesn't seem to install correctly on my mac.
      Perhaps some of you guys knows what to do next, here are my screenshots.

      http://imgur.com/a/eMzYz
      http://imgur.com/a/5EmpB

      I would really appreciate your help so I don't have to install BootCamp and Windows on Mac for modding.

      Thanks!
       
      • springacres

        springacres Sandwich Man

        Wow, I've never had that crop up. What version of Mono are you running? (and that reminds me, I should make sure mine is up to date)
         
        • ShneekeyTheLost

          ShneekeyTheLost Existential Complex

          Patch 1.2.33 indicates that it changed the linux/mac distros to be built with MonoGame-built content instead of XNA 'for easier modding'. This may have had an impact, as currently SMAPI takes into consideration that everything is XNA under the hood.

          Changelog notes
           
          • Donny Donster

            Donny Donster Void-Bound Voyager

            Hello, I decided to get mods for stardew valley for the first time and installed SMAPI. I ran it the first time with only that trainer mod that came with SMAPI; it didn't work. Then I did it again with mods and it also didn't work. Here is the log.

            EDIT: Figured out the problem and fixed it.
            1. Go to your windows search bar and type in CMD, Cortona should bring up the Command Prompt.
            2. Right click on the Command Prompt and click run as administrator.
            3. Once the Command Prompt opens up, type "sfc /scannow" without the quotes.
            4. Wait until it reaches 100% and restart your PC when it tells you to.
            5. Everything should be fixed by then.
             

              Attached Files:

              Last edited: Jul 14, 2017
            • springacres

              springacres Sandwich Man

              No, that was a bug. Patch 1.2.33 was supposed to have fixed that and reverted back to XNA.
               
                13akoors and MysticTempest like this.
              • Tomazz

                Tomazz Orbital Explorer

                When I use the zoom in and zoom out buttons, my game crash :( :( :( :(
                AND THIS IS A BIG PROBLEM FOR ME.
                I thank you, if anyone can help me :)
                PS: I use the latest versions of Stardew Valley (1.2.33) and Smapi (1.15.1)
                 

                  Attached Files:

                • cynicalalien

                  cynicalalien Intergalactic Tourist

                  I'm having an issue where whenever I try to open the StardewModdingAPI, a message pops up that reads "Oops! SMAPI can't find the game. Make sure you're running StardewModdingAPI.exe in your game folder. See the readme.txt file for details."

                  I AM running it from my game folder. Is this just user error (as I am but a noob to the mods world) or is it something else?
                   
                  • zidanreign

                    zidanreign Master Chief

                    Whatever happened to the Farmhand API that was supposedly in dev?
                     
                    • 13akoors

                      13akoors Big Damn Hero

                      It's on hiatus
                       
                      • Xuomi

                        Xuomi Zero Gravity Genie

                        I'm having an issue with a Cursors.xnb file. I am using Vintage Interface Mod but for some reason, every time I go into Shane's 4-Heart event in Marnie's Ranch, the game CTD's at a point. When I remove their Cursors.xnb file then the cutscene works fine. I'll attach my error log but nothing really happens until that crash. Here is the error I am getting:
                        Code:
                        [02:22:23 ERROR SMAPI] An error occured in the base update loop: System.ArgumentOutOfRangeException: Index was out of range. Must be non-negative and less than the size of the collection.
                        Parameter name: index
                           at System.ThrowHelper.ThrowArgumentOutOfRangeException(ExceptionArgument argument, ExceptionResource resource)
                           at System.Collections.Generic.List`1.set_Item(Int32 index, T value)
                           at StardewValley.Event.addSpecificTemporarySprite(String key, GameLocation location, String[] split)
                           at StardewValley.Event.checkForNextCommand(GameLocation location, GameTime time)
                           at StardewValley.GameLocation.UpdateWhenCurrentLocation(GameTime time)
                           at StardewValley.Game1.UpdateLocations(GameTime time)
                           at StardewValley.Game1.Update(GameTime gameTime)
                           at StardewModdingAPI.Framework.SGame.Update(GameTime gameTime) in D:\source\_Stardew\SMAPI\src\StardewModdingAPI\Framework\SGame.cs:line 593
                        [02:22:23 ERROR SMAPI] An error occured in the overridden draw loop: System.NullReferenceException: Object reference not set to an instance of an object.
                           at StardewValley.Event.draw(SpriteBatch b)
                           at StardewModdingAPI.Framework.SGame.DrawImpl(GameTime gameTime) in D:\source\_Stardew\SMAPI\src\StardewModdingAPI\Framework\SGame.cs:line 1011
                           at StardewModdingAPI.Framework.SGame.Draw(GameTime gameTime) in D:\source\_Stardew\SMAPI\src\StardewModdingAPI\Framework\SGame.cs:line 647
                        [02:22:23 TRACE SMAPI] Recovering sprite batch from error...
                        I can just play that cutscene by removing the xnb file but I'm planning multiple playthroughs so it's a little annoying...

                        Edit: I changed out the .yaml file in the edited one with the .yaml from the default Cursors.xnb and it seems to be working now.
                         

                          Attached Files:

                          Last edited: Jul 27, 2017
                        • heyyum

                          heyyum Space Hobo

                          Hi guys. My game got crashed last time when I was going to sleep and before it got saved. When I try to start the game again, it won't load my saved game.... HELP
                           

                            Attached Files:

                          • kimfish

                            kimfish Space Hobo

                            I have some major problems aswell, it crashed and now it wont open again. plz help???
                            p.p1 {margin: 0.0px 0.0px 0.0px 0.0px; font: 11.0px Menlo; color: #ff3b1e; background-color: #ffffff} span.s1 {font-variant-ligatures: no-common-ligatures}

                            /Users/Sabrina/.config/StardewValley/ErrorLogs/SMAPI-crash.txt
                             
                            • OfficialDia

                              OfficialDia Space Hobo

                              I played with my friends and then I changed my reselution. My game (I host) crashed and then I said to the others that they should leave. I created a new host lobby and every time when we start the lobby my game crashes. (Crash log attatched to this post) pls help
                               

                                Attached Files:

                              • Ririyo

                                Ririyo Space Hobo

                                Hello ^^ I am a mac user and went through the full process of adding mods. When I start the game; the terminal pops up like expected only it says that it skipped the mods because it didn't have a manifest. I went through the whole process and to my knowledge did everything right. I am very lost at this point. Could I please have some assistance with this issue?
                                 

                                  Attached Files:

                                • leon01288

                                  leon01288 Void-Bound Voyager

                                  umm game works fine until i try reloaded a saved file
                                   

                                    Attached Files:

                                  • Aurorialis

                                    Aurorialis Big Damn Hero

                                    extracted this from your log:

                                    [14:21:37 ERROR Console.Out] System.InvalidOperationException: Collection was modified; enumeration operation may not execute.
                                    at System.ThrowHelper.ThrowInvalidOperationException(ExceptionResource resource)
                                    at System.Collections.Generic.List`1.Enumerator.MoveNextRare()
                                    at System.Collections.Generic.List`1.Enumerator.MoveNext()
                                    at SpaceCore.Overrides.SeasonGraphicsForSeasonalLocationsPatch.setGraphicsForSeason() in G:\StardewValley\Mods\SpaceCore\Overrides\Game1.cs:line 55
                                    at SpaceCore.Overrides.SeasonGraphicsForSeasonalLocationsPatch.Prefix() in G:\StardewValley\Mods\SpaceCore\Overrides\Game1.cs:line 137
                                    at setGraphicsForSeason_Patch1()
                                    at StardewValley.Game1.loadForNewGame(Boolean loadedGame)
                                    at StardewValley.SaveGame.<>c.<getLoadEnumerator>b__51_1()
                                    at System.Threading.Tasks.Task.InnerInvoke()
                                    at System.Threading.Tasks.Task.Execute()


                                    SpaceCore.Overrides.SeasonGraphicsForSeasonalLocationsPatch, I would guess, points to some sort of patch on the author's part, though I didn't see any season-altering mods in your lineup. Try replacing your current SpaceCore with a fresh one. If that doesn't work (for curiosity's sake) try starting an entirely new farm (you don't need to override your old one, just see if it starts). If all else fails, politely let SpaceCore know you're running into something odd.


                                    A manifest should be provided by your mod author if it's a SMAPI mod. Not all mods are. For example, the "Natural Color Reshade" mod doesn't appear to be a SMAPI mod, and does include its own install instructions (see here). In addition, I feel like I should warn you that it has an external dependency on ENBInjector which is sort of its whole own thing. Didn't check the other mod, but probably same story.

                                    Some folks here were dealing with a similar issue. I'd suggest trying the ideas in that thread, see if anything helps.

                                    Fortunately, I'm not able to access files stored on your computer without your permission and some setup! :) You'll need to upload that crash text, not just post the path to it. Try the "Upload a File" button. Also, just so you're aware, the path you posted contains a first name (starting with S) which I assume is yours. I dunno if that bothers you, you might want to edit it out.


                                    [15:34:55 ERROR Console.Out] Microsoft.Xna.Framework.Content.ContentLoadException: Error loading "Animals\horse". File not found. ---> System.IO.FileNotFoundException: Error loading "Content\Animals\horse.xnb". File not found.

                                    You're missing at least one file (horse.xnb). Drop some sort of replacement horse.xnb into Content\Animals. You can get one from any horse texture replacement mod, assuming you didn't back up your Content folder (which is a thing you should do). If you did back up your content folder, excellently done! You can just grab the horse.xnb from there.
                                     
                                    • AndreaBerg

                                      AndreaBerg Space Hobo

                                      I have a question. I have installed all modifications and now I always see the cursor in the game (I play it with a pad) and it bothers me. Can i change it anyway?

                                      my installed mods:
                                      SMAPI
                                      Get Dressed
                                      Gift Taste Helper
                                      NPC Map Locations
                                       
                                      • santobi2

                                        santobi2 Intergalactic Tourist

                                        my game already crashed a few times when I tried to load my immersive farm. does anyone know how to fix the problem?Edit: I reinstalled Entoarox Framework and now it only sends me back to the beginning animation (with chucklefish etc.) instead of crashing
                                         

                                          Attached Files:

                                        • Pathoschild

                                          Pathoschild Space Kumquat

                                          Oops, the forums stopped sending me notifications for this thread. :wut:

                                          The error screenshot you posted doesn't exist anymore. Can you post a new one?

                                          That may be a coincidence. Try resetting your content files, or come ask in #modding on Discord and we'll help you get it working.

                                          Come ask in #support on Discord and we'll help you get it working.

                                          Come ask in #modding on Discord and we'll help you install it correctly.

                                          Farmhand was officially abandoned in May.

                                          You seem to be missing one of the game files. Try resetting your content files to fix that.

                                          Updating to the latest version of the game (at least 1.2.30) should fix that.

                                          That seems to be an issue with SpaceCore as @Aurorialis said. You can report the error on its mod page to let the author know.

                                          Try deleting the installer folder and redownloading it. Mac sometimes adds a special mcs file that confuses the installer. If you still need help, come ask in #modding on Discord and we'll help you get it working.

                                          I don't think that's related to the mods you installed. Try removing the mods temporarily; does the issue still happen?

                                          That's an issue with Entoarox Framework. Try installing SMAPI 1.15.2 and the latest version of Entoarox Framework and XNB Loader to fix that.
                                           

                                          Share This Page