Tool SMAPI: Stardew Modding API

Discussion in 'Mods' started by ClxS, Mar 6, 2016.

  1. Ladysarajane

    Ladysarajane Phantasmal Quasar

    Already posted in Stardew Valley Expansion too. :) Thank you for looking at the log though.
    • Soulofthefarmer

      Soulofthefarmer Seal Broken

      After update the version stardew valley 1.2.29, the mods are worked at the first time when i started the game.
      And the next day, mods are not worked!
      I think this version of smapi needs to update. :(
      • Pathoschild

        Pathoschild Giant Laser Beams

        Does this happen every time you go to bed, or only sometimes? Can you attach your latest SMAPI log after it happens?
        • Soulofthefarmer

          Soulofthefarmer Seal Broken

          Every times, this happened. For using mods, i have to restart the game when the day is saved at the first time :(
          All of my mods which i installed are worked without any problem before i go to bed haha..
          But unfortunately, in the log, theres is any message about this error.

          OS : Mac sierra
          Game version : 1.2.29
          SMAPI : 1.11

          Since i used smapi for 3 weeks, it worked really good except "Get dressed"(i have the same issue like other mac users). But after the update to Stardew valley 1.2.29, it's a little bit odd.. All of my mods are working usefully when i turn on the game, and since the next day, those aren't working. i dunno why is that occured and why are those errors are not appeared in the log.

          + After 2nd day, the terminal is just stop creating the logs.

          Last login: Wed May 3 04:56:20 on ttys000

          gimboyeong-ui-MacBook-Air:~ gimboyeong$ /Users/gimboyeong/Library/Application\ Support/Steam/steamapps/common/Stardew\ Valley/Contents/MacOS/StardewModdingAPI.bin.osx ; exit;

          [05:38:53 INFO SMAPI] SMAPI 1.11 with Stardew Valley 1.2.29 on Unix

          [05:38:53 DEBUG SMAPI] Mods go here: /Users/gimboyeong/Library/Application Support/Steam/steamapps/common/Stardew Valley/Contents/MacOS/Mods

          [05:38:53 DEBUG SMAPI] Preparing SMAPI...

          [05:38:54 DEBUG SMAPI] Starting game...

          Setting breakpad minidump AppID = 413150

          Steam_SetMinidumpSteamID: Caching Steam ID: 76561198258020600 [API loaded no]

          [05:39:07 DEBUG SMAPI] Detecting common issues...

          [05:39:07 DEBUG SMAPI] Loading mods...

          [05:39:08 INFO SMAPI] Loaded AutomatedDoors by , v1.1.1 |

          [05:39:08 INFO SMAPI] Loaded Fishing Mod by Zoryn, v1.6 | Lets you change some things about fishing based on a config file.

          [05:39:08 INFO SMAPI] Loaded Gate Opener by , v1.3 | Opens and closes gates based on their proximity to you.

          [05:39:08 INFO SMAPI] Loaded Luck Skill by , v0.1.4 | Adds ways of getting the vanilla luck skill.

          [05:39:08 INFO SMAPI] Loaded NPC Map Locations Mod by Bouhm, v1.4.6 | Shows NPC locations on the map

          [05:39:08 INFO SMAPI] Loaded SkullCavernElevator by lestoph, v1.1.1 | Elevator for the Skull Cavern

          [05:39:08 INFO SMAPI] Loaded Trainer Mod by SMAPI, v1.9 | Adds SMAPI console commands that let you manipulate the game.

          [05:39:08 INFO SMAPI] Loaded VariableGrass by , v0.1.3 | Variable Grass

          [05:39:08 WARN SMAPI] AutomatedDoors used the Config class, which is deprecated since SMAPI 1.0. This will break in a future version of SMAPI.

          [05:39:08 DEBUG Fishing Mod] Initialized (press F5 to reload config)

          [05:39:08 DEBUG SMAPI] Loaded 8 mods.

          [05:39:08 WARN SMAPI] AutomatedDoors used Mod.Entry(object[]) instead of Mod.Entry(IModHelper), which is deprecated since SMAPI 1.0. This will break in a future version of SMAPI.

          [05:39:08 INFO Luck Skill] Experience Bars not found

          [05:39:08 DEBUG SMAPI] Starting console...

          [05:39:08 INFO SMAPI] Type 'help' for help, or 'help <cmd>' for a command's usage

          [05:39:08 INFO Luck Skill] All Professions not found.

          [06:04:29 WARN SMAPI] Luck Skill used TimeEvents.OnNewDay, which is deprecated since SMAPI 1.6. This will break in a future version of SMAPI.

          • Soulofthefarmer

            Soulofthefarmer Seal Broken

            + Before i used the SMAPI 1.11 with stardew valley 1.2.28?
            All of my mods is worked good :(
            • nirasa1957

              nirasa1957 Industrial Terraformer

            • demonhunter352

              demonhunter352 Twenty-three is number one

              So, I just tried to run SDV with SMAPI1.11 and this happened

              Screenshot 2017-05-03 12.47.43.png

              It worked fine just moments before, with smapi 1.10; I'd exited the game partly because i remembered i hadn't installed the smapi update yet and partly because of a seperate issue; this screenshot was immediately after installing smapi 1.11. No other changes, and nothing in the console or error log to indicate the cause of the problem.

              EDIT: Interesting. Rolling back Entoarox Framework to 1.7.4 (from 1.7.9) corrected it. Seems to be the combination of SMAPI 1.11 and framework 1.7.6+ that's responsible

              Disregard. Deleting the Entoarox framework config file and allowing framework 1.7.9 to re-generate it corrected the issue.
                Last edited: May 3, 2017
              • Pathoschild

                Pathoschild Giant Laser Beams

                Thanks for reporting the issue. It's fixed in the upcoming SMAPI 1.12, which I'll release ahead of schedule tomorrow. (This only affects players on Linux and Mac due to a bug in that version of the game.)
                  Soulofthefarmer likes this.
                • nirasa1957

                  nirasa1957 Industrial Terraformer

                  Yes, I have the same mistake... :-(
                  • DietCrow

                    DietCrow Orbital Explorer

                    All mods already on their latest version last time (except longevity which now i have just upgraded from 1.6.1 to 1.6.2).
                    I Try a new game without mod that simply replace file except longevity's MCM, this time the problem happens when i change window mode, change dress with getdressed or go to another location (same thing happen when I load save with Stardew Valley.exe but it crashed instead) not when I load save file.
                    Even after I do a complete back up and load every previous mod except anything from longevity, the same problem still happens.
                    That mods list works fine in Stardew Valley 1.1 + 7< mods that replaced xnb file plus Entoarox framework and Advanced location loader and 3 submods (The "+" and "plus" mods i just delete in 1.2 because that problem).
                    Getdressed, Better Sprinkler, Chestlabel System i get from you at this place

                    Edit: I notice that @Koihime Nakamura also have same Smapi Error with different cause in page 84.

                      Attached Files:

                      Last edited: May 3, 2017
                    • tearful0eye

                      tearful0eye Master Chief

                      thank you so much for looking into all of our problems @Pathoschild! i appreciate it so much :)
                        Pathoschild likes this.
                      • Pathoschild

                        Pathoschild Giant Laser Beams

                        @DietCrow Does the "Cannot access a disposed object" error happen if you run the game with no mods installed? If not, try reinstalling each mod one at a time until the problem comes back to find the mod that's causing it.
                        • Pathoschild

                          Pathoschild Giant Laser Beams

                          SMAPI 1.12 is now available for Linux, Mac, and Windows!

                          Changes in this version:
                          • For players:
                            • The installer now lets you choose the install path if you have multiple copies of the game, instead of using the first path found.
                            • Fixed mod draw errors breaking the game.
                            • Fixed mods on Linux/Mac no longer working after the game saves.
                            • Fixed libgdiplus DLL-not-found errors on Linux/Mac when mods read PNG files.
                            • Adopted pufferchick.
                          • For mod developers:
                            • Unknown mod manifest fields are now stored in IManifest::ExtraFields.
                            • The content API now defaults to ContentSource.ModFolder.
                            • Fixed content API error when loading a PNG during early game init (e.g. in mod's Entry).
                            • Fixed content API error when loading an XNB from the mod folder on Mac.
                          As always, feel free to post bugs/suggestions/comments in this thread. :)
                            nirasa1957 and DietCrow like this.
                          • DietCrow

                            DietCrow Orbital Explorer

                            Oh yeah, I found it, it's because of the better sprinkler mod (already upgraded with
                            Download a whole new stardew valley 1.2.28 and update smapi 1.2 to test, despite the fact that there is still a problem, this time the problem starts when I change window mode and after that exit tab a lot (not just change window mode) or randomly when changing dress so smapi 1.2 has some progress.
                            That thing also corrupted my save file once i ever save a game with it and I kinda unexpected so it passes my previous check.
                            Much appreciated for your help but look like no room for bettersprinkler this time and i can re-download Extoarox and it's submod (BetterSprinkler bug cause Smapi report Entoarox bug).
                            Edit: No problem found with no mods installed.
                            Edit2: Still have problems even with only BetterSprinkler and Trainermod.

                              Attached Files:

                              Last edited: May 3, 2017
                            • DietCrow

                              DietCrow Orbital Explorer

                              After another 4 days in stardew valley, that bug happen again even without bettersprinklers, with the same cause...
                              • Pathoschild

                                Pathoschild Giant Laser Beams

                                @DietCrow: based on some testing with another user, the ObjectDisposedException errors seem to be a bug in the game itself. We'll need to wait for the game developers to patch it.
                                  DietCrow likes this.
                                • DietCrow

                                  DietCrow Orbital Explorer

                                  • nirasa1957

                                    nirasa1957 Industrial Terraformer

                                  • Naddin

                                    Naddin Space Hobo

                                    Sorry, I don't know English. Online translator.
                                    SMAPI working on the laptop. Not working on my computer. Please help.

                                      Attached Files:

                                    • Pathoschild

                                      Pathoschild Giant Laser Beams

                                    Share This Page