Tool SMAPI: Stardew Modding API

Discussion in 'Mods' started by ClxS, Mar 6, 2016.

  1. Oxyligen

    Oxyligen Tentacle Wrangler

    Strange, get the same error since today.

    Game Exe does work.
     
    • hikamikisito

      hikamikisito Aquatic Astronaut

      SMAPI 1.10 beta is not working on StardewValley 1.2.24
      [​IMG]
       
      • hikamikisito

        hikamikisito Aquatic Astronaut

      • linxianger123

        linxianger123 Space Spelunker

        You can refer to the #1602
        Common solutions:
        • Close your browsers and any other open application before playing.
        • Remove any mods intended to change the game’s audio (e.g. more music).
         
        • Pathoschild

          Pathoschild Space Kumquat

          The latest Stardew Valley 1.2.24 beta has some changes that make SEHException errors much more common. I'm looking into it; if you're affected and the common solutions don't help, keep an eye on this thread for updates.
           
            Oxyligen likes this.
          • Pathoschild

            Pathoschild Space Kumquat

          • KnightMagicBoxs

            KnightMagicBoxs Space Hobo

          • KnightMagicBoxs

            KnightMagicBoxs Space Hobo

            don't log in steam,and start game.
             
            • nirasa1957

              nirasa1957 Aquatic Astronaut

              SMAPI 1.10 beta on Stardew Valley 1.2.24 beta (via Steam) is working in LinuxMint 18.1 :)
               
              • Pathoschild

                Pathoschild Space Kumquat

                Stardew Valley 1.2.25 should fix the increased rate of SEHException errors. If you were affected by the issue in 1.2.24, can you retry now?
                 
                • Oxyligen

                  Oxyligen Tentacle Wrangler

                  Yes, it's working again!
                   
                  • Sugar-Fable

                    Sugar-Fable Star Wrangler

                    I followed the instructions but when trying to run the game get a "stopped working" crash. Here is what my screen looks like if anyone can help? [​IMG]
                    It's probably really simple and I'm just missing it. I'm not great with these things~
                     
                    • Pathoschild

                      Pathoschild Space Kumquat

                      Hi @Sugar-Fable. Make sure you install SMAPI using the installer (see the official instructions), then delete the SMAPI-1.9 folder you downloaded. The "Part 2: configure Steam" section in the instructions explains how to launch SMAPI through Steam. If you have any questions or need help, feel free to ask in the #modding channel on Discord. :)
                       
                      • Sugar-Fable

                        Sugar-Fable Star Wrangler

                        Got it thanks~
                         
                        • Pathoschild

                          Pathoschild Space Kumquat

                          Stardew Valley 1.2.26 is released and out of beta! A SMAPI 1.10 release will be ready soon.
                           
                            Stardews, Almonda and Ladysarajane like this.
                          • cnstntnpl

                            cnstntnpl Intergalactic Tourist

                            hey man! soon as in "a week"? or as in "an hour or two"? :)
                             
                            • Mission001

                              Mission001 Space Spelunker

                              Would the beta version still work for the new release?

                              Thanks for the updates though. :)
                               
                              • Pathoschild

                                Pathoschild Space Kumquat

                                DragonAion, Almonda and Oxyligen like this.
                              • Xernito

                                Xernito Yeah, You!

                                Hello,

                                I updated Stardew Vally to V1.2. I use SMPI 1.10 but when I load my save game I only a black screen. I deleted the config file in the %appdata% folder but I have still this problem. When I load a save game wich I saved without SMAPI it works.

                                Have someone an idea what I can do?
                                 

                                  Attached Files:

                                • Almonda

                                  Almonda Orbital Explorer

                                  Hello, thank you so much for the new SMAPI 1.10. I can start my game again, but am getting a warning which I didn´t have before with Stardew Valley 1.11.
                                   

                                    Attached Files:

                                  Share This Page