Tool SMAPI: Stardew Modding API

Discussion in 'Mods' started by ClxS, Mar 6, 2016.

  1. Pathoschild

    Pathoschild Space Kumquat

  2. theworldwhispers

    theworldwhispers Space Hobo

    I swear, I wondered if this was maybe the issue, but my antivirus usually pops up a notification when it does something or removes something, so I'd convinced myself that couldn't be it. Of course, it was, and now I feel very silly for wasting so much time trying to fix it, haha. It worked perfectly fine after doing that. Thank you!! Sorry for making the mistake of not trying that before commenting. You guys are the best! :)
     
      Pathoschild likes this.
    • Pathoschild

      Pathoschild Space Kumquat

      SMAPI 1.5 beta is now available. This is a preview of the upcoming release, which I'll publish soon if no issues are reported with the beta.

      Release highlights:
      • SMAPI now shows a friendly error if you install a known incompatible mod, and suggests where to find a compatible version (see screenshot).
      • You can now disable update checks using the new StardewModdingAPI.config.json file.
      • Various fixes, improvements, and deprecations; see the release notes for details.
      To try the beta, follow the using mods guide using the attached release. Feedback, suggestions, and bug reports are welcome here. :)

      [Edit: download removed, see latest version instead]
       
        Last edited: Jan 16, 2017
        ShneekeyTheLost and Surenu like this.
      • betasword

        betasword Void-Bound Voyager

        Well, SMAPI itself seems to work just fine. However, using it seems to keep Steam from being able to do anything overlay related, which is also making use of the Steam Controller impossible. I'm not sure if the fact that it opens the console first is messing with things or not, but the Steam overlay works just fine running off the base executable, but not running off the SMAPI one. This is from both 1.4 and the 1.5 beta.

        Edit: I can get the Steam overlay to work if I add the SMAPI executable as a non-steam game, however that keeps me from being able to use my Steam controller bindings, and anything else actually specific to the game itself, thus kinda defeating the purpose. I've also set everything to run as admin (SMAPI, the main exe, and Steam), restarted steam, and all that fun stuff.
         
          Last edited: Dec 27, 2016
        • Pathoschild

          Pathoschild Space Kumquat

        • betasword

          betasword Void-Bound Voyager

          Yep. Used both "StardewModdingAPI %command%" and also using the entire path to the executable. Both do the same thing: Start SMAPI, but disable the overlay. Like I said, SMAPI itself works perfectly fine. It's just... Disabling the overlay, for some reason. Not entirely sure how to go forward from here, without using a separate shortcut in Steam for the actual SMAPI exe, and just trying to copy over my controller config, and hoping it'll still work with achievements properly.
           
          • Pathoschild

            Pathoschild Space Kumquat

            That's weird. I don't have the Steam version, so unfortunately I can't help with that. Hopefully another Steam user who's seen that before can help. :)
             
            • betasword

              betasword Void-Bound Voyager

              Haha, it's all good. I'll figure some way around this. Weirdest part is, when I launch SMAPI from its own Steam shortcut, Steam still says regular Stardew Valley is running, not the SMAPI shortcut. So it's seeing that properly. Just... Something about running SMAPI through launch options is causing Steam to freak out and not want to do the overlay. Weird!
               
              • FieryChaos

                FieryChaos Scruffy Nerf-Herder

                Steam overlay usually loads for me; most of the time it loads (I'd say probably 95% of the time), sometimes it doesn't, and usually when it doesn't, it loads later eventually while I'm playing. *shrug*. I do use the [ "D:\Program Files\Steam\steamapps\common\Stardew Valley\StardewModdingAPI.exe" %command% ] method. Tried several times just now using [ StardewModdingAPI %command% ] and it never loaded. Switched back to full filepath and Steam overlay loaded on the 1st launch pretty much right after the game window came up.
                 
                • HypeSuprem84

                  HypeSuprem84 Space Hobo

                  i don't have any mod and still the game wont start
                   
                  • Pathoschild

                    Pathoschild Space Kumquat

                  • Pathoschild

                    Pathoschild Space Kumquat

                    SMAPI 1.5 is now available!

                    Release highlights:
                    • SMAPI now shows a friendly error if you install a known incompatible mod, and suggests where to find a compatible version (see screenshot).
                    • You can now disable update checks using the StardewModdingAPI.config.json file.
                    • Various fixes and improvements; see the release notes for details.
                    For mod developers:
                    • This release deprecates Manifest and Version (in favour of IManifest and ISemanticVersion), and increases the deprecation level for some rarely-used interfaces from notice to info. For more information, see the 1.5 release notes and deprecation guide.
                    • Don't have time to update your mods for the SMAPI 1.0+ changes? I can do it for you!
                    Feedback, suggestions, and bug reports are welcome here. :)
                     
                    • nirasa1957

                      nirasa1957 Aquatic Astronaut

                      SMAPI 1.5 = it works manually, but via Steam don't. The situation is the same :(
                       
                      • Pathoschild

                        Pathoschild Space Kumquat

                        @nirasa1957 I added a change in SMAPI 1.5 that might help. First, can you try again and then attach your latest error log?
                         
                          holland5 likes this.
                        • holland5

                          holland5 Intergalactic Tourist

                          Hi there made an account first off to thank you but also for a question :)

                          i made this great thing work on my macbook and didn't even have to change the opening path on steam. Moreover, it shows on steam that the game is running yet I cant open the community overlay- does this mean I will or will not get achievements?

                          thanks for your dedication, appreciate it!
                          (according to terminal, it is running stardewvalley.bin.osx and results in all mods working + steam showing its running, but community overlay not showing)
                           
                          • ShneekeyTheLost

                            ShneekeyTheLost Existential Complex

                            On Linux, it seems Steam isn't able to run the executable built by SMAPI, but when I manually run the executable, it recognizes that SDV is running, and I get achievements logged.

                            I also get a TON of errors about permission denied when various mods try to check to see if there's an update to inform you of. Linux doesn't much like it when a program tries to reach out to the web without sudo permission.
                             
                            • Taena

                              Taena Space Spelunker

                              Hi - New to this, just tried to install SMAPI (after like 2 hours of getting Microsoft .net framework to install...) for the first time.

                              Using Windows 7. I downloaded the SMAPI-1.5 zip file. I unziped it. When I went into the folder and clicked on the installer and tell it to run.

                              It opens a black window with a promt, a few lines come up. Then I get a windows error saying that the installer has stopped working and asking if I want to check for a solution online or close the program. I have tried deleting the file and downloading it again, but the problem still comes up. If I tell it to check online for solutions it closes the program after a second or two saying it's looking for a solution but can't find one.

                              Under the view problem details this is what it says -

                              Problem signature:
                              Problem Event Name: CLR20r3
                              Problem Signature 01: install.exe
                              Problem Signature 02: 1.5.0.0
                              Problem Signature 03: 5862b9ce
                              Problem Signature 04: StardewModdingAPI.Installer
                              Problem Signature 05: 1.5.0.0
                              Problem Signature 06: 5862b9ce
                              Problem Signature 07: 11
                              Problem Signature 08: 0
                              Problem Signature 09: System.MissingMethodException
                              OS Version: 6.1.7601.2.1.0.768.3
                              Locale ID: 1033
                              Additional Information 1: 0a9e
                              Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
                              Additional Information 3: 0a9e
                              Additional Information 4: 0a9e372d3b4ad19135b953a78882e789
                               
                              • Pathoschild

                                Pathoschild Space Kumquat

                                I'm not sure achievements will work if the overlay doesn't appear. I can't help much since I don't have a Mac or the Steam version, but hopefully another Steam on Mac player here will be able to help. :)

                                Can you try running the game through Steam again, then post your latest error log? That's a known issue for some Linux players, but we need more information to figure out why it happens.

                                You can disable SMAPI's update check by editing the StardewModdingAPI.config.json file. (That won't affect individual mods that check for updates; SMAPI doesn't provide an update service for mods yet, so those mods have their own code to do it.) Does disabling it affect the launch issue?

                                A MissingMethodException normally means you have an older version of .NET Framework. Try installing the latest version of .NET Framework.
                                 
                                • ShneekeyTheLost

                                  ShneekeyTheLost Existential Complex

                                  Unfortunately, it doesn't generate an error log from SMAPI. I strongly suspect this is a permissions issue with Steam no longer having permission to run the file because Steam isn't the one who created/installed it, and Linux is kind of paranoid about programs accessing other programs that it didn't create or hasn't been given permission to touch.

                                  More specifically: Because the user is running "mono install.exe", it sees the user as creating the file StardewValley, instead of going through Steam. So Steam doesn't have permission to run it, because it didn't create it. This is to keep certain program's fingers out of more sensitive pies on the computer as a security measure.

                                  Let me show you what I've got. Basically, at the end you see all the mono security errors. It doesn't crash or keep you from launching successfully or playing the game flawlessly.
                                   

                                    Attached Files:

                                  • Laken

                                    Laken Master Chief

                                    This is giving me a horrible headache I use to be able to do this so well. I'm following this guide http://canimod.com/guides/using-mods#installing-smapi and i'm stuck here -
                                    1. Download the latest version of SMAPI.
                                    2. Extract the .zip file somewhere.
                                    3. Double-click install.exe, and follow the on-screen instructions.
                                      The installer will detect your game and add SMAPI for you.
                                    The installer keeps giving me an error! I'm not sure what i'm doing wrong to be honest. It doesn't seem like it's detecting the game at all? Note I unzipped right to the folder that holds Stardew Valley. I'm so lost can someone help me please? It says it has stopped working. @_@
                                     

                                    Share This Page