1. Hey Guest! Our new game Wargroove has released! Check out the forums or wiki for more information!
    Dismiss Notice

Tool SMAPI: Stardew Modding API

Discussion in 'Mods' started by ClxS, Mar 6, 2016.

  1. newcomer12

    newcomer12 Intergalactic Tourist

    Hi,my game just crashed twice when I tried to go to sleep in the game at the 11th day in autumn. My SMAPI is 2.11 and my game version is 1.3.36.
    Here is the crash log: https://log.smapi.io/A5M4Y9xE
    And this is what SMAPI showed.
    upload_2019-3-16_2-42-14.png
    If anyone could help that would be great! thx
     
    • paxchristos

      paxchristos Subatomic Cosmonaut

      Then you need a version of Stardew Valley compatible with 1.5 versions either 1.1 or 1.11

      If you bought on GOG, then you can download an old version, but it might be easier to look for a similar function mod that has been updated since December of 2016
       
      • 13akoors

        13akoors Scruffy Nerf-Herder

        It looks like you're having a dialogue issue. My first suggestion would be to update the "MissCoriel's NPC Unique Courtship Response" mod, and the other mod that needs updating for good measure. Also, if any of your Dialogue mods has a dependency that isn't Content Patcher, I'd suggest removing those mods first.

        If updating all your mods doesn't fix the issue, try removing all dialogue mods.

        If there's still an issue, Pathos will have more information

        If the mod you're using does not work with SMAPI 2.11 and Stardew Valley 1.3.36, then I'm afraid you just can't use it. You're welcome to look for a similar mod, or if the mod is open source ask Pathos to look into updating it, but otherwise there's nothing you can do.
         
          Last edited: Mar 15, 2019
          blouwho? likes this.
        • TranquilizerDart

          TranquilizerDart Space Hobo

          I've made a video showing you what I did, please explain what I did wrong. And I only downloaded two Mods. Both of them were CBJ Cheat Mods, CBJCheatMenu, and CBJItemSpawner. Neither of them worked when I tried them separately and when I tried them together aswell
          Video Link:
           
          • 13akoors

            13akoors Scruffy Nerf-Herder

            Okay, let's start with your installing of SMAPI, and then move from there.

            After installing SMAPI, you add all the installer files into smapi-internel. This is incorrect. SMAPI fully instals itself after you push "1" on the command prompt and you see all the green text you highlighted. After you see that, you can delete the entire SMAPI 2.11 installer folder.

            Also, you placed the modding files directly into the Mods folder, rather than how you had it at the start of the video, which was the correct method.

            I'm not sure why SMAPI didn't launch after you'd deleted all the added files. I would suggest completely uninstalling SMAPI and Stardew Valley, then reinstalling them. I think some file has been improperly altered, and this is the easiest way to fix that

            As an additional note, any time you get an error, you can use https://log.smapi.io/ to post the error here. it works like docs, but is easier to read.
             
            • RhiDee

              RhiDee Aquatic Astronaut

              Can someone please help me with whatever went wrong here? Cause it seems like at least ten things did and I cannot even find where the issue begins
               

                Attached Files:

              • 13akoors

                13akoors Scruffy Nerf-Herder

                When reporting an error, make sure to post your log to https://log.smapi.io/

                Well, it looks like SMAPI (and basically every mod you have) is out of date. I would start by updating every mod you're using
                 
                • camir

                  camir Void-Bound Voyager

                  Greetings everybody! I seem to be having trouble with SMAPI and no solutions on Google could help me.
                  I updated SDV and SMAPI to the latest version, and starting SDV normally works. But as soon as I use SMAPI I get this error: https://log.smapi.io/8VRxyb13
                  I have speakers connected to the computer so this cannot be the issue (as Google suggested). After this error occuring I cannot start the game normally again. What can I do? Thanks in advance for any help. :)
                   
                  • Mizzion

                    Mizzion Big Damn Hero

                    Are you sure the speakers work? You can even try plugging in some broken headphones. The game requires a sound device of any kind.
                     
                    • Pathoschild

                      Pathoschild Cosmos Killer

                      Can you reinstall the latest version of SMAPI, and post that error here? (SMAPI 1.5 was released in 2016 and definitely won't work with current versions of the game.)
                       
                      • Pathoschild

                        Pathoschild Cosmos Killer

                        SMAPI 2.11.1 is now available!

                        This update mainly disables mods which crash the game after Stardew Valley 1.3.36, and prepares for the upcoming Stardew Valley 1.4.

                        Release notes:
                        • For players:
                          • Added crops option to world_clear console command.
                          • Prepared compatibility check for Stardew Valley 1.4.
                          • Updated mod compatibility list.
                          • Fixed world_clear console command removing chests edited to have a debris name.
                        • For modders:
                          • Added support for suppressing false-positive warnings in rare cases.
                        • For the web UI:
                          • The log parser now collapses redundant sections by default.
                          • Fixed log parser column resize bug.
                        Feel free to report issues or ask for help here.
                         
                        • Keileon

                          Keileon Space Spelunker

                          Having issues crashing when I try to sleep to end the day.

                          https://log.smapi.io/7L65TPs0

                          All the mods it says to update have been updated I don't really know why it thinks they haven't. This started happening when I got Automate, but removing it isn't fixing it. All the "Day started" messaged in the log are me saving with Save Anywhere so I could make sure that was working fine (and then getting confused as there was weird behavior in the game and experimenting with it).

                          Day 3, Summer, Year 1 if that matters. Crash starts at 02:54:41.
                           
                          • Valkyr

                            Valkyr Big Damn Hero

                            Hello sorry to post again but I am absolutely just dumb as rocks, here's a crash log https://log.smapi.io/5BCzM1HD

                            i took all the json assets type mods and zipped them into a little punishment folder i'll unzip once i have a clue what i'm doing
                             
                            • BellatrixLeStrange

                              BellatrixLeStrange Space Hobo

                              Hi, I encountered an error when running my SDV through Steam.. however, i tried to run the SDV.exe and this works fine. please help i don't want to loose my progress in the game. thank you!
                              this is the error that i am encountering:
                              upload_2019-3-24_22-47-7.png
                              and here aremy game logs:
                              SMAPI-crash.txt: https://log.smapi.io/39LGXZAj
                              SMAPI-latest.txt: https://log.smapi.io/0zHbNjd2
                               

                                Attached Files:

                              • Pathoschild

                                Pathoschild Cosmos Killer

                                @Keileon That error seems unrelated to Automate. Does it still happen if you remove Save Anywhere? If so, what if you remove all mods listed under "Patched game code" in that log?

                                @Valkyr You have recipes duplicated between Even More Recipes - Meat and for Even More Recipes - Meat Animal Husbandry Patch. I think you're only supposed to install the patch version, not both.

                                @BellatrixLeStrange Stardew Valley 1.3.36 was released recently, so updating to the latest SMAPI version should fix it (just unzip the download and run the installer, it'll update the old files automatically).
                                 
                                • Keileon

                                  Keileon Space Spelunker

                                  It does still happen if I remove Save Anywhere. I tried removing all the "patched game code" mods aside from SpaceCore and PyTK because I don't know all of the mods that need them or what happens if you remove them but leave in mods that depend on them; still getting the same crash.
                                   
                                  • Meowium99

                                    Meowium99 Space Hobo

                                    Oh boi I'm having a bunch of fun.
                                    My game crashes the moment I attempt to boot it up through the modding API.
                                    I think it has something to do with it getting stuck on a particular line of code.
                                    Before I forget, a link to the error log. https://log.smapi.io/A5CHd5aW

                                    Oopsidasy
                                    Just updated SMAPI and it works now.
                                    UwU
                                    I can be an idiot at times.
                                     
                                      Last edited by a moderator: Mar 28, 2019
                                    • Pathoschild

                                      Pathoschild Cosmos Killer

                                      @Keileon Have you used any mods on that save that add custom buildings (except Sauvignon)?
                                       
                                      • Keileon

                                        Keileon Space Spelunker

                                        Yes; I've used More Buildings and removed it because the one building I wanted to use wasn't working properly. Removing it turned that building into a mill so I thought it was fine. I can demolish it and see if that fixes things.

                                        Edit: Yep, that fixed it! Thanks for putting up with me being dumb.
                                         
                                          Last edited: Mar 27, 2019
                                        • Valkyr

                                          Valkyr Big Damn Hero

                                          Once again, I am quite dumb https://log.smapi.io/HFffWaqD

                                          The duplicate recipes are required to satisfy the mod dependencies of the Coffee Shoppe mod, and I swear to god I have updated the things it says to update three times today, always pasting the same information over itself. I absolutely will not uninstall UI Info Suite because the game is borderline unplayable without it.
                                           

                                          Share This Page