1. Hey Guest! Our new game Wargroove has released! Check out the forums or wiki for more information!
    Dismiss Notice

Tool SMAPI: Stardew Modding API

Discussion in 'Mods' started by ClxS, Mar 6, 2016.

  1. lbg_

    lbg_ Space Hobo

  2. blessicalynn

    blessicalynn Space Hobo

    https://log.smapi.io/gjv30gzV

    Entering the blacksmith's shop only shows shadows of clint and farmer before crashing the whole game- no idea why. Does not happen without mods but cannot seem to figure out which mod/what else could be causing the crash. At a loss on what to do next. Any help appreciated!

    edit: solved!
     
      Last edited: Jan 4, 2019
    • Pathoschild

      Pathoschild Cosmos Killer

      @blessicalynn Can you cause the crash again, then post a new log without relaunching the game?
       
      • blessicalynn

        blessicalynn Space Hobo

        Forgot to edit I solved it- had Longevity mod installed incorrectly, cause I am a fool. Thanks for helping though!
         
        • Snarkypie

          Snarkypie Void-Bound Voyager

        • 13akoors

          13akoors Scruffy Nerf-Herder

          Oh boy, where to even start on this one..

          Firstly, could you update to the latest version of SMAPI, as well as update the 10 mods that have updates (and possibly the 11th one that didn't load at all due to being out of date)? One of these updates is the most likely cause.

          Secondly, do you have any XNB mods installed? if so, could you remove those and see if the error stops.

          If none of these help, it seems you have a lot of Content Patcher errors and JSON Assets warnings. I'd suggest removing those mods and their dependencies first and see if one of those is causing the issue,
           
          • Moragaine

            Moragaine Big Damn Hero

            Try taking out Cranber's Fireflies, unless it's the modified version.
             
            • hoetorii12345

              hoetorii12345 Yeah, You!

              hello! im having a problem thats making me have to walk out of my house/cellar to trigger the sleep cycle. it didnt happen before downloading this mod, but all they are are portraits and i dont understand how that could be the problem. and yes, i understand to simply "dont use this mod" but i want to see if there is a solution so i can play with this mod, if simply its incompatible thats fine lol. heres my CP mod folder. thank you for any help! i found the CP version that somebody made but it didnt make a difference either.
               

                Attached Files:

                • sga.PNG
                  sga.PNG
                  File size:
                  70.4 KB
                  Views:
                  4
              • Pathoschild

                Pathoschild Cosmos Killer

                @hoetorii12345 That's usually caused by outdated mods which change the farmhouse interior. Did you install anything like that recently? Does it still happen if you temporarily remove the portrait mod?
                 
                • Pathoschild

                  Pathoschild Cosmos Killer

                  Stardew Valley 1.3.33 is released on PC! SMAPI is fully compatible with the update, but three mods broke (Crops Transplant, Magic, and Prismatic Tools). You can check mods.smapi.io to see if a mod is compatible and where to find the latest updates, unofficial updates, or alternatives.
                   
                  • Digus

                    Digus Ketchup Robot

                    @Pathoschild Is there a expected date for the release of SMAPI 3?
                    Someone brought to me that some of my mods are giving warns on the use of deprecated events.
                    I'd like to know if it is something I need to plan to do right now because the release is imminent or I can wait a while longer to do everything on one go.

                    Edit: By the way, Crop Transplant mod is already update for version 1.3.33
                     
                    • Pathoschild

                      Pathoschild Cosmos Killer

                    • Digus

                      Digus Ketchup Robot

                      Many thanks! I don't keep a close eye on my github account and they don't give me any warning about pull request. (maybe I need to config e-mail notification or something)
                      I'll take a look at it over the weekend.
                       
                      • k3rizz3k

                        k3rizz3k Intergalactic Tourist

                        Last edited: Jan 15, 2019
                      • 13akoors

                        13akoors Scruffy Nerf-Herder

                        That seems to be an issue with Custom Farming Redux, or one of its child mods. Try removing that mod and see if the crash continues.
                         
                        • maeru_maeru

                          maeru_maeru Aquatic Astronaut

                          Hello all. Just started using mods today and am finding that after installing SMAPI, Content Patcher and one compatible mod, the crashes immediately when trying to load a file. Looking at the SMAPI log for this error (https://log.smapi.io/xQzuHZRs), it looks as though there's some kind of draw loop going on with SMAPI. I only have the one texture mod installed and the log lists no errors in the mod itself- does anyone have any idea how to fix this? Does this have anything to do with the new version of Content Patcher released today?
                          Many thanks!
                          Edit: When trying to open the vanilla game without mods using Stardew Valley.exe, it immediately goes back to the title screen when trying to load a save.
                           
                            Last edited: Jan 17, 2019
                          • Skuldi

                            Skuldi Space Hobo

                            Hi I recently started adding mods to my game everything been working fine. Now im on Spring day 27 of the first year. I went to robin's to get the cellar upgrade, made my character sleep and everything fine and saved and now I try and make my character sleep again and the game crashes here is my crash log. can anyone help me please https://log.smapi.io/ZdFV2UyT
                             
                            • hoetorii12345

                              hoetorii12345 Yeah, You!

                              hi, sorry for the late reply. yes i do have an interior mod. but is it the bed its self or the house border mods? (bed) im gonna try replacing the bed with an updated version.
                               
                                Last edited: Jan 18, 2019
                              • hoetorii12345

                                hoetorii12345 Yeah, You!

                                update: i had three interior mods, i used them each separately but still ran into the problem, im trying without any interior mods. edit: im taking out all of my cp mods and adding them in one by one! good luck to me
                                edit 2: even without any mods installed (cp atleast) i still couldnt sleep! guess sleepless nights await my farmer lol
                                *i have updated my smapi also
                                 
                                  Last edited: Jan 18, 2019
                                • MouseyPounds

                                  MouseyPounds Phantasmal Quasar

                                  @hoetorii12345 : The issue Pathos was talking about would be from a mod that replaces the farmhouse map. If none of your Content Patcher mods appear to be causing it, you might have an XNB map mod installed; to remove that as a possibility, you'll need to reset your content files.
                                   

                                  Share This Page