Tool SMAPI: Stardew Modding API

Discussion in 'Mods' started by ClxS, Mar 6, 2016.

  1. Pathoschild

    Pathoschild Cosmos Killer

    The ring appears fine without changing the save you posted. Is that what you mean? Are you still having the issue?
    upload_2018-6-8_16-3-39.png

    Do the crashes still happen if you temporarily remove Advanced Location Loader, Animal Husbandry, Custom Farming Redux, Custom Furniture, Custom Furniture Anywhere, PyTK, SpaceCore, and Stack Everything?

    Unfortunately that error doesn't have much info. Does it still happen if you remove all your mods temporarily? If not, try putting them back one at a time to figure out which mod is causing it.
     
    • Hobro

      Hobro Void-Bound Voyager

      I am experiencing the following error: I crash the moment I exit my home and enter the farm.
      (Originally posted in the wrong thread, my mistake)

      https://log.smapi.io/Vniq48Mi


      I use the following mods:
      Better Junimos
      Item Spawner
      Joys of Efficiency
      Lookup Anything
      Loved Labels
      MTN
      No Fence Decay
      Scythe Harvesting
      Tractor Mod

      I installed CJB Cheats menu to try to teleport out of my house to see if the crash only happened at my doorstep. It happens upon entering my farm from any angle. I originally tried uninstalling all the mods and reinstalling them one at a time. The game continued to crash regardless (though I was not able to remove MTN since it defines the Farm Map, did not make sense to remove it).

      Edit: A side note, this issue sprang up in mid spring. Sometimes i can escape, sometimes i cant.

       
        Last edited: Jun 9, 2018
      • AssVictoriam

        AssVictoriam Aquatic Astronaut

        Hi there! Everything was working fine last night, did stardew valley beta have an update?

        https://log.smapi.io/2ypHrqm8

        It wont let me start up the game, and this usually happens when the game updates and my smapi version is no longer compatible. Other than that, I have no idea what it could be. I verified integrity of game files, and still nothing.

        Stardew Valley.exe works fine on it own, but it wont load with smapi.

        Thank you!

        EDIT : Okay, so I restarted my computer and that seemed to fix it.
        I didn't have a lot of CPU usage at the time, and not many widows open - so I didn't think that was my issue, but I guess it was!
         
          Last edited: Jun 9, 2018
        • Pathoschild

          Pathoschild Cosmos Killer

        • Pathoschild

          Pathoschild Cosmos Killer

          SMAPI 2.6 beta 16 is now available! (For Stardew Valley 1.3.17+ only.)

          Release notes:
          • For players:
            • Fixed installer not finding game path in some cases.
            • Fixed installer showing duplicate game paths in some cases.
            • Fixed installer not removing some SMAPI files.
            • Fixed Nexus mod update alerts not showing HTTPS links.
            • Fixed issue where a mod crashing in CanEdit or CanLoad could cause an abort-retry loop.
            • Fixed error when a mod loads an unpacked .tbin map that references custom seasonal tilesheets.
            • Updated compatibility list.
          • For the log parser:
            • Redesigned upload page to make it more intuitive for new players.
            • Changed filters to show DEBUG messages by default.
            • Fixed mangled crossplatform paths in some cases.
          • For modders:
            • Added input API for reading and suppressing keyboard, controller, and mouse input.
            • Added support for launching multiple instances transparently. This removes the former --log-path command-line argument.
            • Added Harmony DLL for internal use by SMAPI. (Mods should still include their own copy for backwards compatibility, and in case it's removed later. SMAPI will always load its own version though.)
            • Added the first SMAPI 3.0 events. These are much more powerful, consistent, and discoverable than the existing events. However they're preview-only, not officially documented, and may change without warning.
            • Added latest mod file version (including optional files) to Nexus API results.
            • Fixed assets not being cloned when transferred between content managers in some cases.
          • For SMAPI developers:
            • Added prototype SMAPI 3.0 events accessible via helper.Events.
            • Added prototype mod handler toolkit.
            • Added Harmony for SMAPI's internal use to patch game functions for events.
          Let me know if you run into any issues!
           
          • Truthkeeper

            Truthkeeper Big Damn Hero

            After updating, I ran into a crash to black screen when walking up to the train station, with a repeating error in the log.

            https://log.smapi.io/6uHz5JVK
             
            • Pathoschild

              Pathoschild Cosmos Killer

              @Truthkeeper Does the error happen reliably? If so, does it happen if you temporarily remove all mods (e.g. rename your Mods folder)?
               
              • CalCrazy

                CalCrazy Aquatic Astronaut

                Ever since I update this to .15, I've come across this odd glitch where if I tab out of the game to check something and come back into the game, I'll either start to constantly run and be unable to stop, or now with .16 It'll act like I'm constantly clicking on things and interacting with them even though I'm not. I keep having to exit the game entirely in order to make it stop D:


                As for additional mods, the only thing I have is CJB Cheats. Not sure if that helps?
                 
                • Truthkeeper

                  Truthkeeper Big Damn Hero

                  Haven't been able to replicate it at all so far. It happened while there was a train passing through, no idea if that's related, but next time one happens I'll see if it happens again.
                   
                  • Pathoschild

                    Pathoschild Cosmos Killer

                    If you reinstall SMAPI 2.6-beta.14 now (see archived downloads), does it still happen? There are some input changes in SMAPI 2.6, but none that should cause that.
                     
                    • Truthkeeper

                      Truthkeeper Big Damn Hero

                      Damn, managed to run into another freeze up, this one I can replicate. It's freezing when I go to bed, neither fading to black, loading the end of day profits screen or saving, but no errors are showing up in the log. It doesn't happen if I rename the mods folder, so I feel safe in assuming it's an issue with a mod going wrong but not reporting any errors. I don't suppose there's an easy way to isolate it short of removing mods one at a time?
                       
                      • Stinkerbell

                        Stinkerbell Space Hobo

                        I have an error that prevents me from launching the game while using SMAPI. This is the first time I've tried using it and followed the (user-friendly) instructions, but seem to be missing file(s)? I'm not sure if it's something with SMAPI, Steam, or my computer, but would definitely like to fix it. I have already tried the poor man's solutions of re-downloading and uninstalling/reinstalling with both SMAPI and the two mods I am currently trying to use. moderror.png
                         
                          Last edited: Jun 11, 2018
                        • Pathoschild

                          Pathoschild Cosmos Killer

                        • Truthkeeper

                          Truthkeeper Big Damn Hero

                          Turns out it was entirely me own fault for not noticing that one of my mods (SleepWorker) wasn't updated for 1.3 at all. It's mildly interesting to me that it didn't kick up any dust in the log, but I don't pretend to be familiar at all with the developer side of SMAPI to know if it should or not.

                          https://log.smapi.io/A577a6V0
                           
                          • CalCrazy

                            CalCrazy Aquatic Astronaut

                            If I uninstall and go back, will CJB Cheats still work?

                            What I'm trying to sort out is if this bug is stemming from Smapi, CJB, or the game itself D:
                             
                            • boocat

                              boocat Void-Bound Voyager

                              I'm sorry to bother you, but my game has been crashing for two days. I updated to the SMAPI 2.6-beta.15 installer and that worked fine for a day. Then I was sent a notice for another update, with .16 installer. I did that and the thing has never worked since I tried to install it.

                              I'm 64 and don't know computers very well. Any suggestions will be greatly appreciated! Thanks in advance.

                              [Sorry; I just now realized I had posted the wrong thing for the crash file. I didn't use the SMAPI log parser! Have it corrected now. Please excuse any inconvenience.]

                              https://log.smapi.io/mDy3rKHg
                               
                                Last edited: Jun 13, 2018
                              • forevergent777

                                forevergent777 Aquatic Astronaut

                                Is it me or is the Pelican Town music not working for some reason?
                                 
                                • simdebster

                                  simdebster Void-Bound Voyager

                                  I am playing game version 1.2.33. Will SMAPI 2.6 work with 1.2.33? I am not ready to move to game beta version 1.3. I am asking because SMAPI 2.5.5 will not load some mods because it says they need SMAPI 2.6, yet I tried to carefully only download mods that were not for the 1.3 beta.
                                   
                                  • Mizzion

                                    Mizzion Phantasmal Quasar

                                    Sorry 2.6 is for the 1.3 Beta. The latest and last update to SMAPI was 2.5.5 which is for Stardew Version 1.2.33
                                     
                                    • Pathoschild

                                      Pathoschild Cosmos Killer

                                      Yep, it works with beta 14 or later.

                                      You seem to be missing some SMAPI files. Can you try redownloading SMAPI and running the installer again? (There's no need to uninstall the old version first, it'll clean up automatically.)

                                      The music works fine for me. Does it work in other locations? What if you restart the game?
                                       

                                      Share This Page