Tool SMAPI: Stardew Modding API

Discussion in 'Mods' started by ClxS, Mar 6, 2016.

  1. subliminalintegrity

    subliminalintegrity Aquatic Astronaut

    those are definitely my crash logs (giangng9's were labelled as Giang_175260610.zip and mine are SMAPI-crash.txt). i uninstalled everything. installed stardew, ran it without any mods or smapi it was fine, updated smapi to 2.4 for the second time, it ran fine, and then i reinstalled all my mods (minus seasonal immersion) and everything is going fine. if it crashes again after i reinstall seasonal immerson ill post the crash log.
     
    • Kirara_lala

      Kirara_lala Aquatic Astronaut

      I have this error and im unsure what to do, i saw a similar error and you said something about audio. how do i fix??
       

        Attached Files:

        • this.jpg
          this.jpg
          File size:
          175.7 KB
          Views:
          10
      • Pathoschild

        Pathoschild Oxygen Tank

        Hi @Kirara_lala. Try these suggestions from the FAQs:
         
        • Ryuazai

          Ryuazai Space Spelunker

          I'm getting the same deal.

          [SMAPI] SMAPI 2.4 with Stardew Valley 1.2.33 on Microsoft Windows 10 Pro
          [SMAPI] Mods go here: C:\Program Files (x86)\Steam\steamapps\common\Stardew Valley\Mods
          [SMAPI] The game failed unexpectedly: System.InvalidOperationException: This resource could not be created.
          at Microsoft.Xna.Framework.Audio.AudioEngine..ctor(String settingsFile, TimeSpan lookAheadTime, String rendererId)
          at StardewValley.Game1.Initialize()
          at Microsoft.Xna.Framework.Game.RunGame(Boolean useBlockingRun)
          at Microsoft.Xna.Framework.Game.Run()
          at StardewModdingAPI.Program.RunInteractively() in C:\source\_Stardew\SMAPI\src\SMAPI\Program.cs:line 226
          [SMAPI] Game has ended. Press any key to exit.


          I plugged my audio in. Restarted my computer. Closed browsers and apps. I have no mods that change the game's audio.

          I have been playing this fine, yestarday.
           
          • Pathoschild

            Pathoschild Oxygen Tank

            @Ryuazai Did you connect or disconnect any hardware since yesterday (including monitor, controller, or audio peripheral)? Try checking your default audio device to make sure it's the correct one.
             
            • fatalbe4uty

              fatalbe4uty Yeah, You!

              My game has been crashing every time I go to bed without saving. I loaded an old backup save and it saves fine with all the same mods active. The only difference is since the old save I bought the cellar and construction should be finished the day after the crash. Are there any Maps or Tilesheets that are incompatible with the cellar? I've done a ton of retextures and I don't want to go through each one individually to check.

              here is the error text code:
               

                Attached Files:

              • Pathoschild

                Pathoschild Oxygen Tank

                Hi @fatalbe4uty That error isn't specific enough to know which mod is causing it, so we'll need to narrow it down. Does it still crash if you remove Advanced Location Loader, Entoarox Framework, Json Assets, Seasonal Immersion, SpaceCore, and XNB Loader?
                 
                • fatalbe4uty

                  fatalbe4uty Yeah, You!

                  Yes even the vanilla game crashes.. it has to be a retexture with the cellar. Do any farmhouse or farm tiles conflict with the cellar being built?
                   
                  • fatalbe4uty

                    fatalbe4uty Yeah, You!

                    I removed every mod individually. I removed all mods. It’s still doing it. The mods all worked fine until this. The only change is the cellar.
                     
                    • Pathoschild

                      Pathoschild Oxygen Tank

                    • fatalbe4uty

                      fatalbe4uty Yeah, You!

                      I tried to remove the extended farm retexture but the game wouldn’t load at all. Because it says fall_aceextras not found. Probably because I have buildings on the maps that don’t exist. But I removed the bathroom and other farm retextures and it’s still doing it.
                       
                      • fatalbe4uty

                        fatalbe4uty Yeah, You!

                        I’m playing my backup save I guess for now and won’t build the cellar. That’s the only thing that’s changed. It’s 7 days back and I guess I’ll wait and not build the cellar to see if it does the same thing that day to confirm whether or not it’s the cellar. But I would like a cellar one day. I don’t understand what could be the problem. The old save is saving no problem. Same mods all installed.
                         
                        • fatalbe4uty

                          fatalbe4uty Yeah, You!

                          Alright well it still happened on Fall 19 night going into Fall 20. So I will try restoring everything I guess. I don’t get what would happen that day
                           
                          • Pathoschild

                            Pathoschild Oxygen Tank

                            @fatalbe4uty If you attach a zip of your save files and your entire Mods folder, I'll take a look. Do you have any mods installed under Content, or is everything under Mods?
                             
                            • fatalbe4uty

                              fatalbe4uty Yeah, You!

                              I reset my game files and now nothing loads again. Ugh I don’t know what happened. What is it about that day?!
                               
                              • fatalbe4uty

                                fatalbe4uty Yeah, You!

                                It says this when the game crashes trying to load now I have to run out but will try to attach all the files later tonight. Thanks



                                [Console.Out] System.IndexOutOfRangeException: Index was outside the bounds of the array.
                                at StardewValley.Dialogue.parseDialogueString(String masterString)
                                at StardewValley.Dialogue..ctor(String masterDialogue, NPC speaker)
                                at StardewValley.NPC.tryToRetrieveDialogue(String preface, Int32 heartLevel, String appendToEnd)
                                at StardewValley.NPC.updateDialogue()
                                at StardewValley.NPC.reloadSprite()
                                at StardewValley.SaveGame.loadDataToLocations(List`1 gamelocations)
                                at StardewValley.SaveGame.<>c.<getLoadEnumerator>b__51_3()
                                at System.Threading.Tasks.Task.InnerInvoke()
                                at System.Threading.Tasks.Task.Execute()
                                 
                                • fatalbe4uty

                                  fatalbe4uty Yeah, You!

                                  I’ve retextured tons of stuff in Content folder. Some on my own some from nexus and such. It’s going to take forever to figure out what’s causing it but they’ve all worked for days
                                   
                                  • Pathoschild

                                    Pathoschild Oxygen Tank

                                    Texture changes shouldn't cause any errors like that. Do you have any map or data mods under Content?
                                     
                                    • Katorone

                                      Katorone Giant Laser Beams

                                      SMAPI/Stardew crashed, and I'm unsure which mod or combination of mods are responsible. Today was Shane's birthday. I went to Jojo to play him a song on the Harp of Yoba and gave him a beer. I then went to Marnies' to share some presents and a cutscene started with Shane passed out on the floor. Marnie asked for help, my character went over to him. Shane groaned and the game crashed.

                                      Reading the wiki https://stardewvalleywiki.com/Shane#Four_Hearts it says I'd use my watering can on him, but I only had my fishing pole on me and some gifts. I have a suspicion that the Empty Hands (https://www.nexusmods.com/stardewvalley/mods/1176 - I'm using EmptyHands 1.0.1-pathoschild-update.zip) mod plays a role in this. I'll remove it and play through the day again to see what happens.

                                      Edit: after removing Empty Hands the game didn't crash under the same circumstances. Since this is an unofficial update I don't really know where to file a bug report for it. I'll leave it uninstalled for now.
                                       

                                        Attached Files:

                                        Last edited: Jan 31, 2018
                                      • silverghost

                                        silverghost Intergalactic Tourist

                                      Share This Page