Tool SMAPI: Stardew Modding API

Discussion in 'Mods' started by ClxS, Mar 6, 2016.

  1. nirasa1957

    nirasa1957 Industrial Terraformer

  2. jasper855

    jasper855 Void-Bound Voyager

    Could someone help please, My game keeps crashing while trying to load. I've attached the crash report which seems to complain about AdvancedLocationLoader
     

      Attached Files:

    • Pathoschild

      Pathoschild Giant Laser Beams

    • 13akoors

      13akoors Big Damn Hero

      Alternatively, since the crash is caused by loading 1.1.0 of Tego's Stardew Expansion, perhaps try loading the latest 1.2.0 version and messaging on the forum for the mod. http://community.playstarbound.com/...xpansion-neos-home-for-abandoned-mods.135898/
       
        jasper855 likes this.
      • sc0rich

        sc0rich Intergalactic Tourist

        Every time I try to start a new game with my mods, the game crashes when it attempts to load the scene right after the intro.
        I took a look at the crash report, and I don't really know what the problem could be. I'm hoping it's not Omega's Happy Birthday mod - I was trying to load its content through XnbLoader but after some failures I caved and put its data in the data folder X(
        It's almost 3am and I'm bogged down with life stuff (can you believe I was attempting to do this to unwind), I need a fresh pair of eyes to look at this and see what I'm doing wrong. I feel like it's obvious, but I can't see it.
         

          Attached Files:

        • MayaTheBee

          MayaTheBee Intergalactic Tourist

          please help me my game keeps crashing on me is there any way i could stop that from happening?
           

            Attached Files:

          • MayaTheBee

            MayaTheBee Intergalactic Tourist

            The same thing is happening to me too
             
            • sc0rich

              sc0rich Intergalactic Tourist

              Maya, try attaching the SMAPI-crash text file, it'll point out the errors inside. :) the text should be in the same place as the SMAPI-latest text file.
               
              • Pathoschild

                Pathoschild Giant Laser Beams

                That looks like a known issue which will be fixed in the upcoming SMAPI 2.1. If I'm right, you can close the game and then load the new file and it'll work fine.
                 
                  sc0rich likes this.
                • sc0rich

                  sc0rich Intergalactic Tourist

                  huh. ok, neat, thank you. I honestly wasn't expecting a response from the mod author themselves, much less a new version of SMAPI.
                  ok, so I'm playing through the intro, and in the SMAPI window, it just keeps saying "[ChefsCloset] farmhouse:" over and over again. That leads me to a question - on the cooking skill mod, there's a hotfix that says to change the id of the mod to CookingSkill if you have the Chef's Closet mod to get both mods to work. Is...is that what's causing it. Just a general question to the public, I don't expect Pathoschild to answer my question - I'm awed that he took the time out to talk to me. Thank you again.
                  edit: okay it crashed again. It said it failed to load a few events.

                  edit 2: :facepalm: Ima try to load the new file like Pathos said to.
                  jeez - sorry guys, coffee JUST kicked in. OK, it went - the First thing that loaded was the birthday calendar, then it continued to play like a dream. In the SMAPI window, I'm still getting errors though, so I'll include it here. I think I messed up loading the Farm Expansion mod, but I don't know how.
                   

                    Attached Files:

                  • Pathoschild

                    Pathoschild Giant Laser Beams

                    @sc0rich
                    • The Entoarox Framework "file is already managed" warnings are safe to ignore. Those are a known issue with that mod and shouldn't impact your game.
                    • The Farm Expansion error looks like a bug. I suggest reporting it on the mod page (don't forget to include your SMAPI log and mention that it happens when loading an existing save).
                     
                    • sc0rich

                      sc0rich Intergalactic Tourist

                      Ok, Thanks for looking into it. :)
                      I'll let them know about the error.
                       
                      • jasper855

                        jasper855 Void-Bound Voyager

                      • Pathoschild

                        Pathoschild Giant Laser Beams

                        SMAPI 2.1 beta is now available! (download link)

                        SMAPI 2.1 mainly adds a log parser, improves the Steam instructions in the installer, renames the TrainerMod mod to ConsoleCommands to clarify its purpose, and improves the modding features added by SMAPI 2.0. See the release notes for more info.

                        [Edit: download removed. See the latest version instead.]
                         
                          Last edited: Nov 1, 2017
                          Digus likes this.
                        • Pathoschild

                          Pathoschild Giant Laser Beams

                        • Xuomi

                          Xuomi Zero Gravity Genie

                          @Pathoschild Uhh, running into a very bizarre issue.

                          On SMAPI 2.0, my map looked normal. Zero issues. Now with SMAPI 2.1, sometimes my map textures do not seem to load properly.

                          a.png

                          I end up with something like this, or worse. I managed to get it to load in properly once though through just restarting the game constantly. I'm not sure what the problem is.
                           

                            Attached Files:

                          • Pathoschild

                            Pathoschild Giant Laser Beams

                            @Xuomi Can you post a zip of your entire Mods folder?
                             
                            • Xuomi

                              Xuomi Zero Gravity Genie

                              @Pathoschild I uploaded it to MediaFire (link) because the file size seemed a little large for the forums. Well, it was taking a while to upload at least. Let me know if that doesn't work for you.

                              Really hope it's not something obvious that I borked up. :laugh:
                               
                              • Pathoschild

                                Pathoschild Giant Laser Beams

                                @Xuomi I don't have the same issue with those mods. Do you have any XNB mods that aren't installed through XNB Loader?
                                 
                                • Xuomi

                                  Xuomi Zero Gravity Genie

                                  @Pathoschild The only ones I have are from Immersive Farm 2. I even tried moving the XNBs to XNB Loader instead of the regular Content folder and the graphic error still occurs. So it's probably them.

                                  Okay, I went through my Content folder and found some old XNBs for another map I was using and I got rid of everything I could. The texture issue is still there, but it seems to be focused around only a few objects now (hopefully I wasn't just on a lucky streak). It's also isolated to only the farm, so it has to be something in the tilesheets from IF2. I'll see if I can fix it. :p

                                  Yep, looks like somehow they got shifted a tile. Which is weird because they all appear perfectly fine in SMAPI 2.0 in-game. :/
                                   
                                    Last edited: Nov 2, 2017

                                  Share This Page