RELEASED [SMAPI] Entoarox Framework 2.4.0

Makes stardew modding easier!

  1. Pathoschild

    Pathoschild Cosmos Killer

    Here's More Animals 2.0.5-beta.2, which rewrites the mod so it works more intuitively and readds XNB support (so your existing skins will still work). Let me know if you notice any issues, or if animals you had with a previous version of this mod changed skin. :)
     

      Attached Files:

      Mel Noelle and Coolwyngs like this.
    • Pathoschild

      Pathoschild Cosmos Killer

      Entoarox Framework 2.4.1 is now available! (For Stardew Valley 1.3.30+ only.)

      Release notes:
      • Updated for Stardew Valley 1.3.
      • Fixed Linux/Mac compatibility.
      • Fixed compatibility with other mods which change player speed. These will now work so long as you don't also install a mod which changes player speed through the Entoarox Framework API.
      • Removed custom update checks; replaced by standard SMAPI update alerts.
      • Refactored internally.
      (It's only on Nexus since I don't have access to update the Chucklefish mod page, but Entoarox is welcome to upload it here too.)
       
        Mel Noelle likes this.
      • Pookachu_

        Pookachu_ Void-Bound Voyager

        September 2018: Mod needs updating please! With the release of the current patch this mod no longer works :(
         
        • Pathoschild

          Pathoschild Cosmos Killer

        • Inalleon

          Inalleon Subatomic Cosmonaut

        • 13akoors

          13akoors Scruffy Nerf-Herder

          You currently have 2 mods that claim they have updates. Can you update those, then try again and see if the issue continues?

          Secondly, do you have any XNB mods? If so, can you try removing all those by resetting your content files, and seeing if that fixes anything?

          In addition, (while I'm not that good at reading log files), it appears the crash from EntoFramework is due to the fact that you've also installed Bush Reset. It appears EntoFramework is also trying to add that command, and the error is due to the two mods conflicting. I'd additionally try removing the Bush Reset mod to see if EntoFramework stops giving an error, and if it does but the crash continues, it's not a Framework issue, and probably should be posted on the SMAPI page.
           
            Last edited: Dec 21, 2018
          • l11ne

            l11ne Space Hobo

            It says that it wont load? I'm new to mods, so sorry if this is a dumb question, but do you know how to make it so it loads when I launch the game?
             
            • l11ne

              l11ne Space Hobo

              nevermind, i just reinstalled it and it worked!
               
              • NaanoDesuu

                NaanoDesuu Big Damn Hero

                Hello, I have small problem that most likely is caused by this mod. I have downloaded and installed Huge Sheds Redux mod, and I want to use it as default, so I want to have this shed design only. However it doesn't seem to load properly, because for some reason I have basic shead interior with trapdor down. When clicking on the trapdor loading screen shows up and... game crashes. I'm also playing on community farm if that have anything to do with it. In the log file it have showed me that this Entoarox is causing trouble. I can't find solution myself so I ask for help! Here is the log:
                https://log.smapi.io/6fngGx9D
                 
                • 13akoors

                  13akoors Scruffy Nerf-Herder

                  Similarly to the previous person, you also have 5 mods that need updating. Please update those and see if the error continues.

                  Secondly, do you have any XNB mds. If so, can you reset your content files and see if the error continues.

                  Thirdly, as you are now the second person with an error where both EntoFramework and MTN installed, I have a suspicion that these mods are not working together correctly (though this may be coincidence). If so, try removing all mods except EntoFramework and MTN (and necessary additional mods) and see if the error still continues
                   
                  • NaanoDesuu

                    NaanoDesuu Big Damn Hero

                    Umm not sure what those XNB mds files are. Are they those files in content folder? is it safe to remove them? should I backup them? :p

                    https://puu.sh/ClMTa/35623b4ab4.png
                     
                    • 13akoors

                      13akoors Scruffy Nerf-Herder

                      XNB mods are any mods you don't use SMAPI to install, ones where you directly overwrite base files (Content Patcher mods before Content Patcher).

                      If you've altered any of the game files directly, that can cause errors, so when testing errors you need a 100% fresh install, with none of those XNB mods installed. Backing up files is recommended before doing this.

                      If you are unsure about doing any of this without help, feel free to post this in the SMAPI page, or on the Stardew valley modding Discord, where people can help out more effectively than me
                       
                      • NaanoDesuu

                        NaanoDesuu Big Damn Hero

                        Thank you for your help, I will remove all mods I've installed without smapi and ask people on discord for help if needed. Appriciate it that you responded so quickly :)
                         
                        • Pathoschild

                          Pathoschild Cosmos Killer

                          Entoarox Framework 2.4.2 is now available!

                          Release notes:
                          • Updated for the upcoming SMAPI 3.0.
                          • Removed unused SkipCredits feature (see Skip Intro instead).
                          • Fixed EF event marked obsolete when EF itself still uses it.
                          • Fixed error when warping in multiplayer.
                           
                          • RoseEtain

                            RoseEtain Space Hobo

                            Hi guys! Can't seem to get my world_bushreset command to work. When I enter it, the program doesn't respond in any way, but if I enter 'help world_bushreset' it responds with a description. How do I fix this?

                            (SMAPI copy)
                            upload_2019-7-4_0-28-30.png
                             
                            • Entoarox

                              Entoarox Oxygen Tank

                              Your https://log.smapi.io please, a screenshot is pointless.
                               
                              • HectikGamez

                                HectikGamez Space Spelunker

                                Hello... I need some help. I keep getting error messages that i don't have Entoarox Framework installed even if I do. I'm not sure if I'm doing something wrong lul. https://log.smapi.io/pxe69Y1v
                                 
                                • Entoarox

                                  Entoarox Oxygen Tank

                                  Your log clearly shows that Entoarox Framework is not installed, please re-download and re-install, as you likely made a mistake while installing it.
                                   
                                  • ryu3025

                                    ryu3025 Aquatic Astronaut

                                    Entoarox, I was having this same problem and after reading your reply, I noticed mine was missing from my mods, even though it's installed with Vortex. HectikGamez, did you install it with Vortex, because for some reason it's not installing this mod correctly, (even though the folder structure is set up just like the other mods I've installed with it). With this mod, your going to have to manually drag and drop the contents into the mods folder.
                                     
                                    • minervamaga

                                      minervamaga Pangalactic Porcupine

                                      I saw Pickysaurus say something about this in the SDV discord, I believe it's due to the way they are handling users downloading XNB mods. Because EF uses a 'content' folder inside of the main mod, Vortex thinks it's an XNB mod and installs accordingly.
                                       

                                      Share This Page