RELEASED [SMAPI 1.8] Smart Mod

Discussion in 'User Interface' started by KuroBear, Mar 5, 2016.

  1. Borodin

    Borodin Master Astronaut

    Thanks for checking on that compatibility issue, KuroBear. Much enjoying the mod.
     
    • KuroBear

      KuroBear Subatomic Cosmonaut

      what errors? i means mod will not update immediately just for revise some words, but will accompany in next update for fixing bug/issues or new feature
       
      • LinJean57

        LinJean57 Void-Bound Voyager

        Getting this error with version 1.22 of this mod and smapi version 0.40.0. Crash to desktop whenever I press 'ESC' key:
        [01:41:38.890 PM] [ERROR] An error occured in the overridden draw loop: System.ArgumentNullException: This method does not accept null for this parameter.
        Parameter name: texture
        at Microsoft.Xna.Framework.Graphics.SpriteBatch.InternalDraw(Texture2D texture, Vector4& destination, Boolean scaleDestination, Nullable`1& sourceRectangle, Color color, Single rotation, Vector2& origin, SpriteEffects effects, Single depth)
        at Microsoft.Xna.Framework.Graphics.SpriteBatch.Draw(Texture2D texture, Rectangle destinationRectangle, Nullable`1 sourceRectangle, Color color)
        at SmartMod.Menus.Controls.LinkButton.draw(SpriteBatch b, Int32 slotX, Int32 slotY)
        at SmartMod.Menus.SettingPage.draw(SpriteBatch b)
        at SmartMod.Menus.SmartModMenu.draw(SpriteBatch b)
        at StardewModdingAPI.Inheritance.SGame.Draw(GameTime gameTime)​

        Other info: Using quite a few mods (AllProfessions, AnimalPetStatusMod, AutomatedDoors, CalendarAnywhere, DailyFriendshipIncreaser, DurableFences, FarmAutomation.ItemCollector, FarmExtensionSMAPI, FishingMod, GateOpener, GiftTasteHelper, grassMod, HorseWhistle, IgoriousNewMachinesMod, InstantGeode, Jiggly Junimo Bundles , NPCMapLocations, More Crops, RegenMod, SimpleCropLabel, SkullCaveSaver, SMAPIChestLabelSystem, SMAPIHealthBarMod, SMAPISprinklerMod, SocialMenuEditor, StardewCJB, TimeSpeed, TrainerMod, TreeOverhaul, WaitAround), zoomed out all the way.
         
          Last edited: Apr 18, 2016
        • Borodin

          Borodin Master Astronaut

          Speaking as a modder in another game (Oblivion), always posting other mods in use when encountering problems is important.
           
            Last edited: Apr 19, 2016
          • KuroBear

            KuroBear Subatomic Cosmonaut

            So many mods -_,-
            May change keybind for trigger ? If cursh again please tell me.
             
            • bugmenever

              bugmenever Phantasmal Quasar

              Sometimes, after Alt-Tabbing and passing some time, the game crashes with this message:

              [07 : 38 : 11.461] [ERROR] An error occured in the overridden draw loop: System.ArgumentException:
              Offset and length exceeded the bounds of the array or count is greater than the number of elements from index to the end of the source collection.
              in System.ThrowHelper.ThrowArgumentException(ExceptionResource resource)
              in System.Collections.Generic.List`1.GetRange(Int32 index, Int32 count)
              in SmartMod.SmartMod.QuikeSwitchSlot_Move2()
              in SmartMod.SmartMod.OperateButton_Click(ClickableButton button)
              in SmartMod.SmartMod.OperateButton_Draw(SpriteBatch s:cool:
              in SmartMod.SmartMod.Events_PostRender()
              in SmartMod.SmartMod.GraphicsEvents_OnPostRenderEvent(Object sender, EventArgs e)
              in System.EventHandler.Invoke(Object sender, EventArgs e)
              in StardewModdingAPI.Events.GraphicsEvents.InvokeOnPostRenderEvent(Object sender, EventArgs e)
              in StardewModdingAPI.Inheritance.SGame.Draw(GameTime gameTime)
               
              • KuroBear

                KuroBear Subatomic Cosmonaut

                Which other mod you are using?
                 
                • bugmenever

                  bugmenever Phantasmal Quasar

                  I actually use a lot of mods, 32 in total. The crash happened only 2 times (so i shouldn't have used word "sometimes") and i couldn't reproduce it. I believe the game crashed due to lack of memory, but the error message confused me.
                   
                  • KuroBear

                    KuroBear Subatomic Cosmonaut

                    OK, I have received
                     
                    • Anag

                      Anag Space Spelunker

                      Is it possible to get this to work with access chest everywhere mod?
                       
                      • Borodin

                        Borodin Master Astronaut

                        I use both all the time without issue. Kurobear went out of his way in fact to make sure there was compatibility.
                         
                        • DungeonRyu

                          DungeonRyu Phantasmal Quasar

                          One can produce a very strange glitch using this mod.

                          If you start using fishing pole, or milk pail and switch to another panel before the end of the animation, you'll get stuck. If you are using fishing pole, you can not move or do anything even open the menus(I guess the game thinks that you are fishing), same goes with Milk Pail, you can walk, but you can not interract, open doors or chests.

                          I tried other tools but they are fine.
                           
                          • cathyonk

                            cathyonk Seal Broken

                            I don't understand..I used v 1.23, when I want to place storage item to my inventory, it's work..but after I pressed ctrl+tab, the item missing after I repeated press. Please fixed it..my dinosaurs egg, missing T_T
                             
                            • KuroBear

                              KuroBear Subatomic Cosmonaut

                              Sorry about that, ctrl+tab is using for storage item into chest, can you tell me witch menu is active when you pressing ctrl+tab?
                               
                              • cathyonk

                                cathyonk Seal Broken

                                Well, I used ctrl shift tab, to make item in the storage move to my inventory, when I want to back the item to the storage, my storage full, only 2 slots empty..after tha, my dinosaur egg disappear..and then I realize, that if your storage almost full, must careful to move the item from inventory to the chest..cause it's like the item always move in the back til disappear..just try it, like ctrl shift tab, then ctrl tab repeatedly..and then items disappear T__T

                                How to get my dinosaurs egg back? >_< thanks anyway ^^

                                ------

                                No update and no fixed for this mod? I really loved this mod..really useful T_T..
                                Anyway if slot in the storage full, then I right click mouse, the item missing too, when combined with 'access chest anywhere mod' :'(
                                 
                                  Last edited: May 9, 2016
                                  MayaMayhem and shamien7 like this.
                                • MayaMayhem

                                  MayaMayhem Master Chief

                                  This is still giving me issues similar to many mentioned earlier in the thread, with various combinations of hotkeys glitching out causing entire rows of items to disappear.

                                  I really liked having the top row lock/switch & auto sort, but its clearly not worth the hassle at all with item-erasing bugs. I tried to instead set it up minimally, so I could just use certain features, but the config resets with each in-game day and even when configured correctly, I can still reproduce the 'row of items vanishing' glitch just with the stack up/down buttons..
                                   
                                  • Blubba

                                    Blubba Void-Bound Voyager

                                    I was wondering if there was a way to just get the display detail one?
                                     
                                    • Borodin

                                      Borodin Master Astronaut

                                      KuroBear, will you be preparing a version that works with 1.1? I tried using SmartMod again with the latest SMAPI and 1.1, but it only partially works. Hitting F1 with SmartMod installed causes a crash.
                                       
                                      • iceburg 333

                                        iceburg 333 Void-Bound Voyager

                                        Hitting F1 crashed the game for me as well.
                                         
                                        • Borodin

                                          Borodin Master Astronaut

                                          I've sent a PM to KuroBear about this, though it doesn't look good. He hasn't been in the forums since the end of August.
                                           

                                          Share This Page