1. Please be advised of a few specific rules and guidelines for this section.

RELEASED Shipstructor (WIP) [Deleted]

Discussion in 'Ships' started by Team_MTSSM, Dec 12, 2013.

Thread Status:
Not open for further replies.
  1. Mood

    Mood Big Damn Hero

    You're awesome guys! I can't play without this mod either. Waiting with my fingers crossed! :geek:
     
  2. madtulip

    madtulip Phantasmal Quasar

    is it that badly broken/hard to fix? ill take a look later.
     
  3. thesidofevil

    thesidofevil Void-Bound Voyager

    we really can't fix lot of it, it is so broken some tiles and objects work but the rest is almost non-functional

    EDIT: also my PC is breaking down so i can't work on anything without black screening or having a graphics card crash so i will be mostly idle on mods until i can get this fixed
     
  4. madtulip

    madtulip Phantasmal Quasar

    Mood and Sparksol like this.
  5. DarthTrethon

    DarthTrethon Spaceman Spiff

    Does this work with the new stable now?
     
  6. Eskaldra

    Eskaldra Void-Bound Voyager

    When I started a new ship file on an existing character, the command list for SAIL was empty, so no "reboot" option available to get him started. It works fine with a new player file though.
     
  7. outofwhack

    outofwhack Scruffy Nerf-Herder

    Started building a ship, but found that new sections I added can not be removed or have crafting items placed on the. Blocks are highlighted as if protected by a shield when I try to remove them. I added a ship shield generator and toggled it a few times. Original section was affected by the generator, but the blocks I place are not.
     
  8. Flarezerker

    Flarezerker Scruffy Nerf-Herder

    No way to enable matter manipulator on human character. Very irritating, impossible to progress without cheating.
     
  9. Adarkchylde

    Adarkchylde Void-Bound Voyager

    crashes when you have the avikan race installed :( - avikandarkgroundpanel.material causes a fatal exception error due to there being a duplicate - really sucks cause thats the race i wanted to use
     
  10. madtulip

    madtulip Phantasmal Quasar

    On the main page (http://community.playstarbound.com/resources/madtulip-s-spaceship-mod.59/) is a section about "Race Mods".[DOUBLEPOST=1442770303][/DOUBLEPOST]
    counldnt reproduce.
    - created human
    - interact with S.A.I.L
    - "reboot ship AI"
    - "enable matter manipulator"[DOUBLEPOST=1442770569][/DOUBLEPOST]
    couldnt reproduce. didnt use the shield generator item though.

    the shield generator is meant to protet the ship from griefing and was developed by huggable creap. Hes, as far as i know, currently reworking it to function as a "on"/"off" toggleable state using an "on"->"off"->"on" quest series over the ship AI as the AI is accessible only be the owner.
     
    Last edited: Sep 20, 2015
  11. xWither

    xWither Void-Bound Voyager

    Thanks to Madtulip for helping me with my issue regarding a "duplicate item ID."

    "Looks like a really awesome mod.
    Only problem is, I keep getting error messages when I load up Starbound.
    I'm leaving the log here for you to review.
    Please get back to me ASAP so I can play with this thing!
    A link was here"

    Author's Response "Duplicate material id 30010 found for material madtulip_TS_glitch_1" -> some other mod created a "material" using the same ID as we do here. Those ID are unique, but not uniquely assigned by the game so incompatibilities like this will occure at some point. The ID doesnt have any meaning apart from beeing unique so you can just change the "materialId" value in "madtulip_TS_glitch_1.material" AND "madtulip_TS_glitch_1.matitem" IN "madtulip\materials\tilesets\glitch_1" OR you can change the respective materialIDs in the other mod that is colliding."

    I can't thank you enough for helping me! :3
     
  12. iMisterX

    iMisterX Big Damn Hero

    I used a shield generetor and connected it to the life support vent ( ok it is stupid, i was just curious...), it was on when i connected it and now i cant remove or turn it off and cant change stuff on my ship, is there anything i can do about that?
     
  13. Mood

    Mood Big Damn Hero

    What happens if you upgrade the sparrow class license for your custom ship?
     
  14. Scynix

    Scynix Big Damn Hero

    This is what I had happen. Can't figure out how to fix it. x_X
     
  15. iMisterX

    iMisterX Big Damn Hero

    I crafted a research station but when i try to use it, the game crashes. (my ship is still tier 4 so maybe thats the problem?)

    EDIT: Tried upgrading the ship to tier 5, but still crashing.
     
    Last edited: Sep 22, 2015
  16. SingABrightSong

    SingABrightSong Scruffy Nerf-Herder

    Ah, I had this error with the "Breakable ship parts" mod. It's throwing an error when it tried to parse "interface/windowconfig/researchstation.config", which has likely changed with the new update. Yep, having unpacked the Starbound assets, the new format for the research station is
    Code:
    "interactData" : {
        "config" : "/interface/windowconfig/craftingnocategories.config",
        "paneLayoutOverride" : {
          "windowtitle" : {
            "title" : "  RESEARCH STATION",
            "subtitle" : "  Develop specialized technologies!",
            "icon" : {
              "file" : "/interface/crafting/researchstation.png"
            }
          }
        },
        "requiresBlueprint" : false,
        "filter" : [ "researchstation" ]
      },
     
    Zlyvr likes this.
  17. The_Turret_Boy

    The_Turret_Boy Subatomic Cosmonaut

    the "oxygen systems" are not quite working (for me) If i destroy the wall i should die? thats how its suposed to be, right? if so. not working for me (still a great mod :D )
     
  18. sigmix0101

    sigmix0101 Space Spelunker

    Is this for Pleased Giraffe?
     
  19. Karalina

    Karalina Void-Bound Voyager

    When I started a new ship file on an existing character. I cant reboot Sail. The command list has no reboot button. With a new char it works fine but i dont want to start again. Any Help ??
     
  20. Pohany

    Pohany Spaceman Spiff

    /clearaimessages
     
Thread Status:
Not open for further replies.

Share This Page