1. Hey Guest! Our new game Wargroove has released! Check out the forums or wiki for more information!
    Dismiss Notice

Modding Help Ship Loading Times

Discussion in 'Starbound Modding' started by noxem, Feb 19, 2019.

  1. noxem

    noxem Yeah, You!

    First off, I apologize if this is a duplicate/wrong threaded post. This is my first one, so please go easy on me.

    Alright, so I have a fairly large ship, crated on BYOS. Ever since I installed the second FTL drive, more than half of my ship takes over five minutes to load in. My computer is fine, it wasn't doing this beforehand. I've installed these mods:
    Backflip/Frontflip Tech
    https://steamcommunity.com/sharedfiles/filedetails/?id=1275140090
    b3k3's More Powerful Techs
    https://steamcommunity.com/sharedfiles/filedetails/?id=772812959
    Phase Shift Module For 1.3
    https://steamcommunity.com/sharedfiles/filedetails/?id=951324877
    Frackin' Universe - Melee Aiming
    https://steamcommunity.com/sharedfiles/filedetails/?id=1593802400
    Optimizebound (Performance Improvement)
    https://steamcommunity.com/sharedfiles/filedetails/?id=902555153
    Parallax Compression (FPS Improvement)
    https://steamcommunity.com/sharedfiles/filedetails/?id=885877773
    Xbawks Character Extender
    https://steamcommunity.com/sharedfiles/filedetails/?id=729426722
    And of course, Frackin' Universe. It seems to be taken down on steam at the moment, but I've subbed from there.
    I don't know what the problem could be, as none of the mods I'm subbed to could cause such an issue. It's such a strange issue as well. Does the chunk loading of the ship slow down after you place a certain number of tiles?

    As it took me 20+ minutes to write this, getting all of my mods and making my account, the hull panel I broke 20 minutes ago *just* now broke. I wish I could make this up. I can move freely, it's not a frame issue but a loading time one. I even tried yanking out the FTL drive, but that didn't help with the fact that it took fifteen minutes to drop. The game crashes when I try to save and quit and takes quite a while to load up as well.

    If it helps, my ship is made of mostly hull panel blocks with pockets of erchius crystals as like pseudo fuel tanks. I have three ship thrusters, two hylotyl and one human on the back of my ship. The front is glass, but other than that the crew bunks are the only other outstanding design.

    This problem makes it impossible to beam anywhere, impossible to navigate to a planet so I can test if it's just the ship or if it's my whole game, as the menu won't open up. Again, my computer can handle starbound easily normally. Has anyone else had this kind of issue before?
     
  2. lazarus78

    lazarus78 The Waste of Time

    Check your taskmanager and see if the game is eating up CPU time, memory, or how much it is using accessing the hard drive.
     
  3. noxem

    noxem Yeah, You!

    The game takes up about thirty percent of my CPU, and about 80% of my memory. It doesn't seem to be that the game is taxing on my computer.
     
  4. noxem

    noxem Yeah, You!

    So after gruelingly tearing apart the ship, it seems that having a ship too large will slow your game down much more. Hopefully nobody has this problem again.
     

Share This Page