1. When making a thread, please tag your thread accordingly using the menu to the left of the textfield where you name your thread where applicable. Server Advertisements and Mod Releases should be contained to their respective subforums.

Server Help Server overwriting .config on boot

Discussion in 'Multiplayer' started by geokhentix, Jul 31, 2016.

  1. geokhentix

    geokhentix Void-Bound Voyager

    So I just got a server going with 1.0, which took forever since ubuntu sucks, and...
    When I change the starbound_server.config, and then boot the server via ./starbound_server, it overwrites my config:

    Code:
    [Info] Root: Writing runtime configuration to '../storage/starbound_server.confg'
    
    making it impossible for me to set a password. Halp?
     
  2. ruskerdax

    ruskerdax Tentacle Wrangler

    I am having the same issue. I see the same line in the server window, and when I open the starbound_server.config file, it has indeed been overwritten. I saw someone else post that they got it to work by shutting down the server first, editing the file and saving, then relaunching the server (as opposed to editing it while the server was open, saving, then rebooting the server) so I tried that, but it did not make a difference.

    I have double- and triple-checked that the syntax is correct. I'm not sure why it's overwriting the file, and would appreciate some assistance as well.

    Edit: It may be worth noting that I am not running the server on Ubuntu, I am running the x64 dedicated server binary located in the Starbound\win64 folder of my Windows 10 PC. If this is a bug, it appears to not be isolated to one OS.
     
    Last edited: Aug 1, 2016
  3. Dunto

    Dunto Guest

    Please post a copy of the config that's being overwritten (use the spoiler tags).
     
    Last edited by a moderator: Aug 4, 2016
  4. ruskerdax

    ruskerdax Tentacle Wrangler

    I didn't think it would make a difference considering the server doesn't write to the config file during shut down, but I did it both ways. It appeared to make no difference.


    {
    "allowAdminCommands" : true,
    "allowAdminCommandsFromAnyone" : false,
    "allowAnonymousConnections" : true,
    "allowAssetsMismatch" : true,
    "anonymousConnectionsAreAdmin" : false,
    "bannedIPs" : [],
    "bannedUuids" : [],
    "checkAssetsDigest" : false,
    "clearPlayerFiles" : false,
    "clearUniverseFiles" : false,
    "clientIPJoinable" : false,
    "clientP2PJoinable" : true,
    "configurationVersion" : {
    "basic" : 1,
    "server" : 4
    },
    "crafting" : {
    "filterHaveMaterials" : false
    },
    "gameServerBind" : "*",
    "gameServerPort" : 21025,
    "interactiveHighlight" : true,
    "inventory" : {
    "pickupToActionBar" : true
    },
    "maxPlayers" : 8,
    "maxTeamSize" : 4,
    "playerBackupFileCount" : 3,
    "queryServerBind" : "*",
    "queryServerPort" : 21025,
    "rconServerBind" : "*",
    "rconServerPassword" : "",
    "rconServerPort" : 21026,
    "rconServerTimeout" : 1000,
    "runQueryServer" : false,
    "runRconServer" : false,
    "safeScripts" : true,
    "scriptInstructionLimit" : 10000000,
    "scriptInstructionMeasureInterval" : 10000,
    "scriptProfilingEnabled" : false,
    "scriptRecursionLimit" : 100,
    "serverFidelity" : "automatic",
    "serverName" : "A Starbound Server",
    "serverOverrideAssetsDigest" : null,
    "serverUsers" : {
    "ruskerdax" : {
    "admin" : true,
    "password" : "letmein"
    },
    },
    "tutorialMessages" : true
    }


    I am pretty familiar with JSON syntax; I don't think that's the problem. I would note, though, that if it were, there is absolutely zero indication in logs that there is a parsing error, nor is a particular reason given for overwriting the file.

    Mod edit: removed deleted quote
     
    Last edited by a moderator: Aug 4, 2016
  5. Dunto

    Dunto Guest

    Yup, you've got an error in your config. Check line 50, in the serverUsers section: the last element at each nesting level should NOT have a comma after it. You can verify your changes using a JSON validator like http://jsonlint.com/
     
    Last edited by a moderator: Aug 4, 2016
    ruskerdax likes this.
  6. ruskerdax

    ruskerdax Tentacle Wrangler

    Aha, so there is! I don't know why I didn't think to validate it myself before coming to the forum, except that I was expecting the problem to be a result of something else. Throwing an error might have helped, but looks like it was my own fault.

    Looks like it's working fine now, thanks for the help. :)

    Mod edit: removed deleted quote
     
    Last edited by a moderator: Aug 4, 2016
    Dunto likes this.
  7. RayZ

    RayZ Void-Bound Voyager

    I don't know what to do. Please. Help. Just give me a config to copy paste or something- for the love of god, I've been scouring the internet for hours to figure out what's wrong. I don't want to learn programming just to spawn in 10000 pixels.
     
  8. Firestorm258

    Firestorm258 Master Astronaut

    I don't want to sound like a know-it-all, but have you tried setting your config file to read-only?

    Worst case scenario you can give yourself those pixels in single player. Admin commands still work there.

    edit: I only just noticed the timestamp on the first post says 2016.
    Sorry, mods. I didn't notice this was a necropost.
     

Share This Page