1. Welcome to the Starbound support forums. Please check the support FAQs before posting: http://playstarbound.com/support

Bug/Issue (Server) Fatal Exception Caught upon loading a png asset

Discussion in 'Starbound Support' started by Geethebluesky, Nov 25, 2017.

  1. Geethebluesky

    Geethebluesky Void-Bound Voyager

    I'm submitting a bug regarding a server I'm trying to load with multiple mods. Asked the author and he's not sure of what might be going on.

    This doesn't cause a crash on clientside (I played yesterday with my husband via Steam multiplayer, and all of the game plus the same mods loaded fine, no crashes; granted neither of us chose Avali as the starting race but we're undecided on which race to play this time around.)

    The bug occurred after I copied all of the Workshop .pak files to the \mods folder and tried running the server.
    (Note: We need to setup the server on a separate machine accessible outside of Steam, our work schedules don't always sync up and we still want to play when the other one isn't around :)

    The bug is repeatable, it crashes every time I load the server.

    Full server log is here.

    The error is
    [14:51:14.588] [Error] Exception caught loading asset: /objects/avaligeneric/containerscolor/avalicontainer1yellow.png:default, (AssetException) No associated frames file found for image '/objects/avaligeneric/containerscolor/avalicontainer1yellow.png' while resolving image frame '/objects/avaligeneric/containerscolor/avalicontainer1yellow.png:default'


    ... followed by what looks to be a stack trace, then again later:

    [14:51:14.695] [Info] Root: Shutting down Root
    [14:51:15.204] [Error] Fatal Exception caught: (ObjectException) Error loading object '/objects/avaligeneric/containerscolor/avalicontainer1yellow2.object': (AssetException) Error loading asset /objects/avaligeneric/containerscolor/avalicontainer1yellow.png:default


    Edit to be clear: The .pak file DOES contain proper .frames and .objects files for all pngs
    avalicontainer1yellow.png
    avalicontainer1yellow2.frames
    avalicontainer1yellow2.object
    avalicontainer1yellow2.recipe


    Running on Windows 7 x64.

    I'm trying to run the server with 97 mods currently; all listed in the log. Basically Frackin' Universe plus the Felin and Avali races and their submods for completeness and "all the stuff".

    The mod that crashes is this one. As mentioned above I contacted the author but he's not sure.

    RELEVANT TO ABOVE: I have tried the following to identify the problem:
    • I compared the .frame files between the white and yellow containers... no difference there.
    • Compared the .objects files and they're identical except yellow is substituted where white is. No other colors crash, only yellow.
    • The .png files look the same to me as well... same DPI, same dimensions (120x120), but I can't tell if they were compressed using different settings, maybe (like different compression ratios)? That trips up other games like Minecraft...
    • I don't know how to tell if yellow is just getting loaded first, or if it's the only one that crashes.The PNGs do have different color depth (256 bits for yellow, 16.7 mil for white). Other containers also have some files at 256 and others at 16.7, but they didn't crash (see above though).
    • I also checked if maybe the mod loader was tripping up due to filename+path length and it doesn't seem like that's the case either.
    I don't know what else to try or to suggest.

    Thanks for any pointers or ideas?
     
    Last edited: Nov 25, 2017
  2. jonaswashe

    jonaswashe Big Damn Hero

    When I got this error, I was missing the Avali colored Items mod which is a dependency of Avali Colored Items Addon:
    https://steamcommunity.com/workshop/filedetails/?id=819145737

    You might want to make sure you have that mod and that it is in the correct location if you are manually installing the mod.
     
    Last edited: Dec 20, 2017

Share This Page