1. This forum is primarily for mobile related issues - for support for PC/Console visit the support section of forums.stardewvalley.net

Save file wont load, loops back to main menu endlessly.

Discussion in 'Support' started by Anvical, Dec 12, 2018.

  1. Anvical

    Anvical Void-Bound Voyager

    As the title says I have an issue with my file, and that issue is that it doesn't load properly and loops endlessly back to the main menu. The file was almost dawning its third year in the game and i would like to resurrect it and continue playing again. This save was from the summer I believe, and I think I might have played it with the beta for the multiplayer update (sorry for being vague, not entirely sure). I have updated all or most of my mods to the proper new version as well as my game, and I have also tried making a new save to which it worked as intended. I've tried for over 2 hours poking around the internet at fixes (_old files, replacing the SaveGameInfo files, loading with no mods at all). I use SMAPI for my mods as everyone probably does and I can't determine if its the root issue or not so I've turned to help from the community. My error logs are attached and idk if its necessary or not but ill attach my save file as well. Any help would be greatly appreciated as I cannot simply do this myself. Thank you for reading.

    EDIT : I dont know anything about code or files and such but i did see something in the crash log, and it stood out to me as being an indicator. This is taken from the log file attached.
    [23:11:36 ERROR game] Exception occured trying to access file 'C:\Users\ChrisJAnstey\AppData\Roaming\StardewValley\Saves\Anvi_185487891\SaveGameInfo'
    [23:11:36 ERROR game] System.IO.FileNotFoundException: Could not find file 'C:\Users\ChrisJAnstey\AppData\Roaming\StardewValley\Saves\Anvi_185487891\SaveGameInfo'.
    File name: 'C:\Users\ChrisJAnstey\AppData\Roaming\StardewValley\Saves\Anvi_185487891\SaveGameInfo'
    at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
    at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
    at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share)
    at StardewValley.Menus.LoadGameMenu.FindSaveGames() in C:\Users\gitlab-runner\gitlab-runner\builds\5c0f9387\0\chucklefish\stardewvalley\Farmer\Farmer\Menus\LoadGameMenu.cs:line 480
     

      Attached Files:

    • Pathoschild

      Pathoschild Tiy's Beard

      The good news is the save itself is fine, since it loads for me. Can you post a screenshot of the C:\Users\ChrisJAnstey\AppData\Roaming\StardewValley\Saves\Anvi_185487891 folder, including the full window?
       
      • Anvical

        Anvical Void-Bound Voyager

        Thank you for the help PathosChild. I noticed that the file itself gets renamed to Anvi_185487892 instead of 91, which I tossed aside as something dumb, and for some reason didn't credit it. Since the file gets renamed to 92 a 91 file appears with save data corresponding to a multiplayer file. Below I've uploaded multiple photos to which I will name to what they mean in case what I found is the root. The only one that is a picture of the file names is "RequestedSaveImage", in this one i deleted the reapearing 91MP file and renamed the 92 to 91. Again, much thanks for the help. I hope all the pictures posted are enough, but will obviously work on getting better ones if required. Thank you.
         

          Attached Files:

        • Anvical

          Anvical Void-Bound Voyager

          Oh man. After fumbling around editing save files with what I saw on google, I finally found the issue. I determined somewhat idiotically that the files reappearing wasn't a coding glitch, but a problem with my steam cloud. I moved all my save files into a separate folder on my desktop, minus the one good save I wanted and then I disabled my steam cloud in steam and launched the save, to which it froze and actually loaded in finally. The only logical explanation is some lingering bug that was from the Beta in the summertime? that for some reason afflicted my game. Im, sure it is very niche. Nonetheless, thank you Pathos for the support, it's amazing to see the community still helping each other out. Many Thanks.

          IF ANYONE IS READING THIS FROM THE SAME ISSUE MOVE ALL SAVES OUT EXCEPT THE ONE THAT IS TRYING TO BE FIXED AND DISABLE STEAM CLOUD SYNC. LAUNCH THE GAME AND IT SHOULD WORK. <3
           
          • Etherspinner

            Etherspinner Space Hobo

            One problem, it's my daughter's save file on iPad Mini 4 that is doing exactly this ( begins to say loading then loops to title screen, updated to latest version this morning but was only one revision behind anyway)

            :)
             
            • Pathoschild

              Pathoschild Tiy's Beard

            • Etherspinner

              Etherspinner Space Hobo

              Thanks so much - I'll refresh my memory about iOS devices and computer interface and do just that, your help is very much appreciated as my daughter is very proud of her work and we love this game !
               
              • Etherspinner

                Etherspinner Space Hobo

                Ok i copied the saves from iPad to mac and imported to the Mac game and there were 3 files in the save directory on the device playername_201685900 and playername_201685900_SVEMERG ( I noticed a google search for that "svemerg" bit gets no results to do with stardew) along with SaveGameInfo.

                I tried using the SVEMERG file by deleting the other save without that suffix bit and the save showed up in the list on the Mac game but really borked! the character looked vaguely right but with hair missing and some different colours i think, no money there - this one didn't work with or without the SaveGameInfo file.
                next I tried deleting the file ending in SVEMERG and loading the playername_201685900 file but that resulted in this game not showing up in the saves list, just a very old save files from another family member and thats with or without the SaveGameInfo there.

                I've zipped the contents and popped them here, I presume that without any knowledge of fixes on my part (to the text contents of the save files) there is no point yet meddling with whats actually on the iPad ?

                any pointers very much appreciated and again, grateful for the comprehensive tips thus far ;)
                 

                  Attached Files:

                • Pathoschild

                  Pathoschild Tiy's Beard

                  Unfortunately that save isn't recoverable, so far as I can tell. Sorry about that! If you keep occasional backups of the save (just transfer a copy to PC), you'll have a last resort in case that happens again.
                   

                  Share This Page