1. Please be advised of a few specific rules and guidelines for this section.

RELEASED Resource Extractor 1.3

Destroy unwanted natural blocks to harvest useful crafting items.

  1. I Said No

    I Said No Cosmic Narwhal

    I Said No submitted a new mod:

    Resource Extractor - Destroy unwanted natural blocks to harvest useful crafting items.

    Read more about this mod...
     
  2. I Said No

    I Said No Cosmic Narwhal

  3. I Said No

    I Said No Cosmic Narwhal

  4. amirmiked12

    amirmiked12 Spaceman Spiff

    can u add more blocks and FU blocks?
     
  5. slowcold

    slowcold Scruffy Nerf-Herder

    Liking it so far, it has really altered my early game.

    Had to edit the files though - dirt (dirtmaterial) and cobblestone (cobblestonematerial) were both misnamed and not extracting.
     
  6. jje64

    jje64 Subatomic Cosmonaut

    Where did you make these changes? What file or files did you fix?

    UPDATE: I went poking around in the mod files and changed dirt and cobblestone to dirtmaterial and cobblestonematerial in 2 places in isn_resource_extractor_droptable.config - made no difference, machine still refuses to eat dirt or cobblestone. What did I miss?

    Thanks!
     
    Last edited: Jul 17, 2017
  7. slowcold

    slowcold Scruffy Nerf-Herder


    I had the same problem at first. You need to destroy your extractor, then reload all assets (/admin, /reload in chat) and make a new one. Or just make a new character - that usually works.
    Oh - edit corruptdirtmaterial too - that doesn't function as is.

    Must admit, I've been messing around with it quite a lot. Adding some Frackin Universe outputs. Playing with the extract ratios. It's rather fun but is easy to make it extremely overpowered.
     
    jje64 likes this.
  8. jje64

    jje64 Subatomic Cosmonaut

    Thanks! I got it working, but here's the weirdness - I did all the steps you describe, but nothing worked. Tried removing the mod altogether and then playing without it and reinstalling it with the fixed config - nada. Here's the kicker... I'm on a mac. So I copied the file over to a PC and made the changes with Notepad++ and now it works fine. Something about text editing on a mac that the game just didn't like. I made the changes in TextEdit, and whatever I edited the game promptly ignored, and then I tried it in a different program called TextWrangler and the game ignored the entire file from that point forward. Something about the way MacOS writes text files I guess. Gonna have to try to find a text editor that plays nice with SB.

    Thanks again for your help!
     
  9. slowcold

    slowcold Scruffy Nerf-Herder

    My pleasure!
     
    jje64 likes this.
  10. jje64

    jje64 Subatomic Cosmonaut

    So, this was working fine, and then all of the sudden it stopped and it's throwing this in the log:

    [15:04:56.536] [Info] Root: Detected asset source named 'Resource Extractor' at '../mods/isn_resource_extractor'
    [15:04:57.127] [Info] Loading assets from: '../mods/isn_resource_extractor'
    [15:05:12.810] [Error] Exception caught loading asset: /objects/isn_resource_extractor/isn_resource_extractor_droptable.config, (AssetException) Could not read JSON asset /objects/isn_resource_extractor/isn_resource_extractor_droptable.config
    Caused by: (JsonParsingException) Cannot parse json file: /objects/isn_resource_extractor/isn_resource_extractor_droptable.config
    [15:05:12.819] [Error] Exception while calling script init: (LuaException) Error code 2, [string "/objects/isn_resource_extractor/isn_resource_..."]:4: (AssetException) Error loading asset /objects/isn_resource_extractor/isn_resource_extractor_droptable.config
    [string "/objects/isn_resource_extractor/isn_resource_..."]:4: in function <[string "/objects/isn_resource_extractor/isn_resource_..."]:1>

    The only things that have changed recently are StarTech and ISE4, and I would have sworn it was working after I upgraded, but maybe I'm wrong. Any ideas?
     
  11. OmniGeoff

    OmniGeoff Weight of the Sky

    Perhaps this has been asked (several times) before, but are there any plans on including FU blocks and extractable items (in a standalone patch)?
    If not, I could take some time and add some in myself -- with your permission.
     
  12. I Said No

    I Said No Cosmic Narwhal

    I Said No updated Resource Extractor with a new update entry:

    UI Update

    Read the rest of this update entry...
     
  13. jje64

    jje64 Subatomic Cosmonaut

    Sooo... I have an automatic extractor facility using smart tubes that feeds materials into these and then extracts the products for storage or smelting. If I understand what you’re saying, these things will no longer automatically process whatever gets dropped into slot 1?
     

Share This Page