1. Welcome to the Starbound support forums. Please check the support FAQs before posting: http://playstarbound.com/support

Closed (RESOLVED I THINK) Removing Broken Deeds via LUA?

Discussion in 'Starbound Support' started by ChocoHearts, Feb 7, 2016.

Thread Status:
Not open for further replies.
  1. ChocoHearts

    ChocoHearts Orbital Explorer

    So a lot of us are in a boat together: we've managed to get broken Deeds which hang the game. This is usually done by having a tenant already spawned for a particular deed, and then damaging the outside of their house. This seems to cause the Deed to rescan the house, but since it's not a complete house, it tries to scan the whole blippin' planet. This hangs all interactivity with the world; you can move your player around, and your player thinks it's placing blocks, destroying blocks, and opening chests, but the world's not having any of that, thank you very much, so you can't get RID of the problem Deed.

    I have a hunch that there's a solution, BUT I'm not enough of a programmer to figure this out, so I'm asking for help.

    We have commands that we can use from chat, right? And I know that LUA is really powerful, and that we can somehow use that through chat as well. So I've got some pseudocode here:


    And that's it. I just want a LUA command that will search my locality (I guess whatever parts of the planet are loaded right now) for Colony Deeds and remove them. I'd prefer for them to drop as pickups, but I can spare several thousand pixels if I'm able to patch the hole in my tenant's house and get to all my items that are stored in a billion lockers right next door.

    I hope there's someone out there who can help... there are a bunch of us who will benefit!


    EDIT! I think I've figured it out!

    I unpacked the files and everything, and started poking around in the LUA of deeds themselves. I copied colonydeed.object into ~\SteamApps\common\Starbound\assets\user\objects\colony\colonydeed, opened it in Notepad++, and changed line 58

    "maxPerimeter" : 500, //scan limit
    to 500 from 5. Save, load up Starbound, and load character.

    Yes, this makes all of my tenants yell about their houses being broken, BUT it let me interact with the world, so I could patch the hole in the wall and regain control of my life (or at least this planet).

    As soon as the wall was patched, I saved and quit, and it worked (as opposed to hanging the game and having to kill the program). Changed the line back, and et viola, problem is solved!
    Last edited: Feb 8, 2016
  2. Aerinea

    Aerinea Space Spelunker

    I'm going to have to try that tomorrow when I have all day because if I can fix it I'll probably start playing again.

    Of course, knowing what to unpack & where to find it would be incredibly useful.
    Last edited: Feb 12, 2016
  3. ChocoHearts

    ChocoHearts Orbital Explorer

    Ok, assuming you're running Windows:
    In ~\SteamApps\common\Starbound\win64 (or win32, depending on your PC), you should have a program named asset_unpacker.exe. In this same folder, create a new text document, and paste this into it:

    @Echo off
    echo Unpacking ..\assets\packed.pak into ..\assets\unpacked\
    echo This may take a long time.
    start /wait /min .\asset_unpacker.exe ..\assets\packed.pak ..\assets\unpacked
    echo Done.

    Save it as unpack_assets.bat, and make sure you're saving as a .bat and not a .txt! Run it, and it'll pop up a window.

    Wait. It took my computer about ten minutes to actually do the whole thing, and it doesn't give you any indication that it's working until it's done, so just get a Coke or something and hang out. When it's done, it'll say "Done.", and you can close that window.

    Now you'll have a new folder, ~\SteamApps\common\Starbound\assets\unpacked, that has ALL the assets for the game. Drop down a couple of directories, to unpacked/objects/colony/colonydeed, and open colonydeed.object, and have fun!

    BAM. Once I found where everything was, I was pleasantly surprised at how easy it was.

    Good luck!
  4. Aerinea

    Aerinea Space Spelunker

    Phooey, it didn't work for me. But I was able to actually see where the damage was. I still couldn't fix it and it crashed out on me again.
  5. Aerinea

    Aerinea Space Spelunker

    Maybe I need to play with the values a bit more.
Thread Status:
Not open for further replies.

Share This Page