Tutorial Read this if you're having problems updating your mods through the repo.

Discussion in 'Starbound Modding' started by LowestFormOfWit, Feb 25, 2014.

  1. LowestFormOfWit

    LowestFormOfWit Pangalactic Porcupine

    A lot of people (myself included) were/are having tons of trouble with the mod repository taking updates, going from Furious to Enraged.

    I tried probably 30-some times to no avail to get Tabula Rasa to update properly, and finally found a method that worked for me:

    1) Go to your mod page and hit "Post Resource Update".
    2) Upload the mod file to the Repo OR Choose an External download URL.
    3) Choose a new version string (as always this MUST be a different value from the current version.
    4) SKIP IMMEDIATELY TO "Save Update".

    At this point, while it may not appear anything updated (because your "Updates" tab won't show any change), your new download SHOULD have uploaded and replaced the current download. Click your mod's own "Download Now" button at the top to test, and double check your mod's "Version History" page. This should show your current download at the top, with previous versions beneath it.

    Now that your file is actually uploaded, we need to go back and make an actual update that notifies your userbase:

    1) Go to your mod page and hit "Post Resource Update".
    2) SKIP IMMEDIATELY TO "Update Title", and enter a title for your mod update.
    3) Enter a message for your update, noting any changes as normal (optional).
    4) Go to "Save Update".

    Again, I tried the normal method of uploading, entering version string, update post, etc all at once as I always have, and no matter how many times/ways it would not take. For "UNEXPLAINABLE REASONS" the mod repository is only letting proper updates go through if the FILE/VERSION parts and UPDATE/MESSAGE parts are done separately as detailed above.

    If this works for you and is awesome, like it, and leave me a kind message!

    If it doesn't work, flood me with hatemail!

    sρooκs likes this.
  2. Hey! I never had any problems with doing it normally. What I would do is post the resource update as usual, but the only difference is I had an additional tab open set to the updates page. The second I clicked the button to commit the update, I would go to my other page and spam the refresh button. The original page NEVER completes, but after about 10 seconds or so, I do in-fact see the resource update go through in my second tab. I then proceed to close the "Post Resource Update" window. If I don't spam the refresh button on the Mod Updates page it does not work.
  3. telles0808

    telles0808 Cosmic Narwhal

    I had a lot of issues in the last 4 updates. I don't know why the hell, but the system was maintaining an older version of my mod file (broken one).
  4. LowestFormOfWit

    LowestFormOfWit Pangalactic Porcupine

    The repo has kind of always been a mess. The heavy traffic after each patch kind of grinds it to a halt.

Share This Page