Modding Help Problems with the kitchen object data on the farmhouse map

Discussion in 'Mods' started by Ahrnie, Apr 25, 2018.

  1. Ahrnie

    Ahrnie Void-Bound Voyager

    Hi again!
    I'm having trouble editing the farmhouse map. Especially with getting the fridge and kitchen to work in game.
    I have edited the image for the tile sheets, and when I replace the tiles for the stove and fridge one of these things happen:
    1. Both stove and fridge doesn't work at all.
    2. only the stove action work as it should, ie. displaying the cooking recipes.
    3. the stove works, and so does the fridge, but it has turned into a stove, displaying the recipes instead of being a fridge.

    On and when I look at the vanilla files the object data for both fridge and stove is labelled "kitchen". This confuses me, but I have come to accept it. However it confuses me more when it doesn't work.

    I use Tiled with the .tbin plug-in for map editing and graphicsGale for the .png tile sheet editing.
    I use XNB Loader for replacing the vanilla files.
    I tripled checked the layer on which the object data is placed and I've also tried to put both the object data-tiles and the image-tiles on different layers, and nothing works as it should.
    I use SMAPI but the log doesn't report any errors so I have nothing to go on there.

    However I do have some other mods in play, could it be that one of those interact with this and thus doesn't make it work? I wonder if certain images in the tile sheets are connected with specific object information, but that sound kind of unlikely.... maybe the object information is connected to certain tile sheets? Again sounds unlikely but...

    I tried searching in this forum for a post that had a solution to this problem... but there are quite a few posts in here and after 40 pages I came up empty handed, so I'm making a new one.

    Does anyone know what the problem is and how to solve this?
    Tanks in advance! :)
    • FieryChaos

      FieryChaos Cosmic Narwhal

      There are no object action properties on any layer of the fridge (on the map or in the tilesheet) in the vanilla files. The kitchen action only opens up the cooking menu. I believe the fridge is called within the game code itself (there is no tile property to call it), and you'd likely need a SMAPI mod to call it in different locations.

      I've also run into the problem of the fridge not working when just changing it's texture (or perhaps changing or replacing the tile itself in the map .tbin caused it to not work?); this was so long ago I don't remember how I fixed it, if I did anything at all different to fix it or if it was indeed what happened in my last statement in parentheses, so...

      Share This Page