Problem with Coop and SMAPI with some mods

Discussion in 'Mods' started by Rumba, Mar 27, 2020.

  1. Rumba

    Rumba Space Hobo

    Hi everbody, new here

    Just bought this awesome game (a friend wanted to play coop).

    What have i done:
    Installed from Steam SV 1.4.5
    Installed SMAPI 3.4.1
    Drag to Mod folder, SV Expanded with immersive farms and all its dependencies.

    What is the issue:
    I am getting stuck 99% of the time in the loading screen

    When successfully i got this log:
    https://smapi.io/log/5ebebe0f32f84f979d9b71321d93dc45
    Otherwise:
    https://smapi.io/log/df57867499fb4a5ab041687298f6ff80

    Additional tests i have done:
    -Without SMAPI or mods it always connect, yet we see different maps.
    -If I remove SV Expanded, immersive farms and TMXLoader it also works.

    I have no idea of what is going on, so if anyone could help or guide me on what to do it would be really appreciated.

    Thanks for reading

    Rumba
     
    • Wingyl

      Wingyl Void-Bound Voyager

      Do you both have the same modlist? Modded multiplayer requires most mods to be the same across all players; purely cosmetic mods, cheat menu, item spawner, and mods that specify it is OK if only some players have them are the exceptions.
       
      • Rumba

        Rumba Space Hobo

        Originally yes, but now my friend has 3 more mods. Still another friend with my same mods can connect fine to the hosr, but not me.
         

        Share This Page