1. Note: Nightly builds are not officially supported and things that appear broken might actually just be broken with no way of fixing it, but community members may still be willing to assist you with common problems.

Closed None of the chakrams throw. At all.

Discussion in 'Nightly Builds Support' started by Jorvalt, Jan 4, 2016.

Thread Status:
Not open for further replies.
  1. Jorvalt

    Jorvalt Void-Bound Voyager

    So, I first discovered this bug when I found my first chakram. I decided I'd try it out, because why not. However, all my character did was just raise the chakram in the air, and nothing happened. My character continues to hold it in the air and face whatever direction I was facing until I switch weapons, even if the chakram is not in one of the L/R slots. I spawned in the other 3 types of chakrams, and the bug also applies to them as well.
  2. Xylia

    Xylia Tiy's Beard

    Where was your mouse cursor? I think it attempts to fly towards your cursor (if it isn't out of range) and then return to you, but if your cursor is too close, then you won't throw it at all.

    And are you using any mods? Could be a mod thing. I can personally say that I've used Chakrams and they work.
  3. Jorvalt

    Jorvalt Void-Bound Voyager

    Update: I later noticed that none of the boomerangs except the default one actually work, either. Literally the only boomerang that works is the plain one.[DOUBLEPOST=1451870235][/DOUBLEPOST]
    Doesn't matter where my mouse cursor is. If it's right next to my character or literally as far away as it can possibly be, the same thing happens. The character raises the chakram/boomerang in the air, and just freezes like that until I switch weapons. I am also unable to change the direction I'm facing until I do so. The only boomerang/chakram that actually works is the regular boomerang, and that will always throw regardless of where my cursor is. I am not using any mods.
  4. Xylia

    Xylia Tiy's Beard

    Huh, that's weird. It worked fine for me... I'll have to boot the game up and see, because I've got some boomerangs/chakrams on a couple characters.

    EDIT: Working fine for me:


    EDIT2: Try opening the game, attempt to throw a chakram, then save&exit, then post starbound.log? Maybe it's generating an error like missing asset files or something.
  5. Jorvalt

    Jorvalt Void-Bound Voyager

    Well, I did that and there's really not much to talk about here. From what I can see, there aren't any errors happening that would cause this. What I did was I opened the game, spawned in a chakram, tried to throw it, then disconnected. Here's the log.

    Attached Files:

  6. lazarus78

    lazarus78 The Waste of Time

    I have the same issue. Not sure what causing it.
  7. Xylia

    Xylia Tiy's Beard

    I do see this:

    Error: Error loading player file, ignoring! .\..\giraffe_storage\player\bec93793c003c7600dea6c3e4d138940.player : (VersioningDatabaseException) Could not bring versionedJson with identifier 'PlayerEntity' and version 11 forward to current version of Just (14)
    Caused by: (LuaException) Error code 2, [string "/versioning/playerentity_11_12.lua"]:26: bad argument #1 to 'pairs' (table expected, got nil)

    What's that about, do you know?

    EDIT: Whoops, quoted wrong person. Sorry about htat. I meant to reply to the other guy who posted his logfile.
Thread Status:
Not open for further replies.

Share This Page