1. Thanks for visiting! These forums are for the original Risk of Rain, if you're interested in discussing the newly released Risk of Rain 2 head over to that game's steam discussion forum
    Dismiss Notice

No Sound..

Discussion in 'General Discussion' started by Palazar, Nov 9, 2013.

  1. Palazar

    Palazar Space Hobo

    OK after the wierd install that some of u forum fellas helped me with.. Now I have no sound.. Any help there?
    • warlocked200

      warlocked200 Starship Captain

      I have the same problem with the steam version.
      I tried deleting and downloading the game again but there still isn't any sound. The game just starts and there is an error message at the top left of the screen. I would appreciate any help in this regard.
      • hopoo

        hopoo Risk of Rain Developer Developer

        -Uninstall and reinstall Visual C++, included in the 'redist' folder or can be downloaded again at (http://www.microsoft.com/en-us/download/details.aspx?id=30679)
        -Restart your computer
        -If running Windows 8, run the game in compatibility mode for Windows 7 (right click -> Properties > Compatibility)
        • Felonious

          Felonious Existential Complex

          It seems none of these fixes has helped with the issue, for myself at least. I'm not sure if it's because of Steam, or some other issue, but after the first playthrough, sound has stopped at all. Which makes me sad, as this game has a fantastic soundtrack. Though, I didn't have this issue with the Beta.
            Model QT-377665 likes this.
          • mirick

            mirick Space Hobo

            I have this issue as well and none of the fixes above are working.
            • Felonious

              Felonious Existential Complex

              Fixed with 1.0.1 for me. Thanks.
              • Narkohn

                Narkohn Void-Bound Voyager

                I had to deactivate my secondary sound device.
                Now I have sound without reinstalling vcredist or running in compat mode.

                OS: Windows 8.1 x64
                GPU: AMD Radeon HD 7950
                Sound: Logitech G35
                • dapertapir

                  dapertapir Space Hobo

                  Hi, my sound is still broken.

                  I have tried Hopoo's suggested fix. I've tried updating my audio drivers. I've tried uninstalling and reinstalling my audio drivers, running the it iin window mode, run as administrator. I continue to get this error message in the error text file:
                  > ERROR in
                  > action number 5
                  > of Create Event
                  > for object oInit:
                  > Error defining an external function.

                  OS: Windows Vista Home Premium x64
                  CPU: Intel Core2 Quad CPU Q8200
                  Risk Of Rain: v1.0.1 - I am using the humble bundle DRM free version of the game (not steam).

                  Strangely, when I play the Risk of Rain demo, the sound works just fine (and is awesome!). I hope that helps you find whatever is causing this.
                    Last edited: Dec 2, 2013
                  • Soup

                    Soup Giant Laser Beams

                    I'll have to add my name to the list of people getting this sound error. I was able to fix it a couple days ago by shutting down Firefox and Winamp but nothing seems to be doing the trick today.
                    • dapertapir

                      dapertapir Space Hobo

                      @Soup: Have you got sound when you play the Risk of Rain 1.0.1 Demo?
                      • Soup

                        Soup Giant Laser Beams

                        Yes, but the demo is using an entirely different audio library for some reason so I'm not surprised it works. The regular game's audio seems to be working today though so hopefully that keeps up.
                        • RogerPodacter

                          RogerPodacter Space Hobo

                          hey all.
                          i also had this problem today. i installed the latest vc++ 2012 redist as specified, but that was no help.
                          i was able to fix it by going into the device manager and disabling my sound adapter (shows up as "Realtek High Definition Audio" for me) and then re-enabling it. it complains that you should restart the computer, but i just clicked no to restart later. now it works!
                          : )
                          • Soup

                            Soup Giant Laser Beams

                            Mine's been working for the last couple days, I'm not really sure why. Hopefully that error doesn't pop up again because I'm really enjoying the game.
                            • stephnag

                              stephnag Space Spelunker

                              Hi all,
                              I was having awful trouble getting sound to work properly, even after following all the suggested advice, FAQs etc.
                              For what it's worth, I fix it by turning Spotify off from my taskbar and it works every time. Maybe some kind of conflict with other background processes?
                              Anyway might be worth trying to exit a few taskbar programs, hope it helps
                              • SynVisions

                                SynVisions Space Hobo

                                Any progress on getting a reliable fix for this?
                                • Etrockie

                                  Etrockie Void-Bound Voyager

                                  hi i had a problem with sound so what i did to fix it was if you got to
                                  C:\Program Files (x86)\Steam\SteamApps\common\Risk of Rain\_CommonRedist\vcredist\2012
                                  and click on vcredist_68 or 86 you will get a pop up click repair and let it reinstall then sound should be back i hop it works for you to

                                  Share This Page