Modding Help My mod works if in Mods folder but not if installed from Steam Workshop.

Discussion in 'Starbound Modding' started by DarkMesa, Jan 13, 2018.

  1. DarkMesa

    DarkMesa Orbital Explorer

    I recently got a comment saying that my mod was not working. I was surprised since it always worked for me.
    I tried to remove it from Mods folder and install it from the Steam workshop and surprisingly, it does actually not show up at all, but the game loads normally without it.

    Note: it shows to be in the Mods menu, but I can not Spawn the Items in-game or craft them. It works as all other mods do, recipe files and assets are in the contents.pak.
  2. bk3k

    bk3k Oxygen Tank

    Try unpacking the Steam version to see that it matches what you have.

    Now a question - did you try to upload an already packed file? Assuming here that you are using the uploader instead of other methods, the uploader packs your files for you before uploading them. So you'd just browse to the unpacked base folder for your mod.

    Somehow I could see it going and trying to put a .pak file within another .pak file. I've never tried that, but I'm fairly sure that won't work.
    The | Suit likes this.
  3. The | Suit

    The | Suit Agent S. Forum Moderator

    The from steam does not download to your "Starbound \ mod"
    It will download to Steam \ Workshop folder instead.

    That part is not the issue at all.

    18 minutes 19 seconds - on how to upload properly.

Share This Page