1. When making a thread, please tag your thread accordingly using the menu to the left of the textfield where you name your thread where applicable. Server Advertisements and Mod Releases should be contained to their respective subforums.

Server Help my config file isn't changing anything

Discussion in 'Multiplayer' started by Lanku, Feb 3, 2017.

  1. Lanku

    Lanku Void-Bound Voyager

    sorry if this is a question that's been solved, but i cannot find it anywhere no matter how much searching i do.

    i'm trying to set up a server, and nothing i change in the .config file is working. this goes for even the "set admin for everyone" prompt, which i've set to true/false and i can't make myself admin either which way.

    i need to make the server private, but when i set the config to disallow anonymous connections, i can still connect to it without being blocked.

    i'm editing the config in notepad++, but i was using wordpad at first. i literally just installed the main/stable starbound version an hour ago when i began to set up the server so it's all fresh, and i don't think reinstalling will solve it?

    the config file also does not revert itself when i close/open it, etc which seems to be the more common issue with this.

    can anyone help me figure out what the problem is?
  2. techjedi

    techjedi Space Hobo

    I recommend looking at the starbound_server.log

    When you make a typo in the config and it cannot be parsed or has an invalid option, the server will replace the config with the default config file.

    Here is an example when I made a typo in the users json:

    [22:55:07.363] [Warn] Root: Failed to load user configuration file ..\storage\starbound_server.config, resetting user config: (JsonParsingException) Error parsing json: bad string, should be '"' at 47:7
  3. Lanku

    Lanku Void-Bound Voyager

    there are no errors in the log. the only thing i'm changing is setting the anonymous connections from true to false, so not a lot should really be going wrong there. :/

    i also noticed my config reverted itself since i shut my computer off earlier. other people said theirs reverts just by closing the file & restarting starbound, but mine doesn't do that, it's only when i shut the whole computer off apparently. not sure if that can help with finding a solution, but who knows.
  4. Sprvrn

    Sprvrn Industrial Terraformer

    The file reverts to its original state even if starbound_server is not running? That's pretty weird.
    What's your OS? Do you have full admin right on your computer?
  5. Lanku

    Lanku Void-Bound Voyager

    i'm running windows 8, and i do have full admin rights. :S
  6. Hel

    Hel Music Mistress Forum Moderator

    Have you tried making your changes, saving it agter and then making your config read only?

    Do that when Starbound is closed and maybe that will stop your game changing everything back to default
  7. Fearne

    Fearne Void-Bound Voyager

    I've been trying this too and it's not budging. It keeps making a NEW config file and when I made it Read-Only, it barks at me and shuts down.
  8. Volkove

    Volkove Space Hobo

    I am having the same problem, I am trying to create an admin account and set a password. When I start the server it creates a new starbound_server.config file and renames the one I changed to starbound_server.config.old. The server starts with default settings.
  9. Volkove

    Volkove Space Hobo

    So after more poking around it turned out there was a syntax issue in the config I was setting up, but nothing in the log said that. Once I got that fixed, which Im not even sure what I had wrong, it worked fine.

Share This Page