Tool MultiBound - Starbound Profile Launcher a la MultiMC

Discussion in 'Starbound Modding' started by zetaPRIME, Sep 14, 2016.

  1. kageboushi

    kageboushi Aquatic Astronaut

    Gotcha. Thanks.
     
  2. UC101

    UC101 Void-Bound Voyager

    I'm getting this error;
    Code:
    Invalid character 'S' in input string
    My steamapps folder is stored on another drive so I'll give you the path to that as well, in case that's the problem.
    Code:
    D:\SteamApps\steamapps\common\Starbound\win64\starbound.exe
     
  3. UC101

    UC101 Void-Bound Voyager

    nevermind, fixed it on my own.
    Make sure that you use double slashes to denote the path.
    Stupid windows making an escape character the same as a path character. :p
     
  4. dualinfinities

    dualinfinities Big Damn Hero

    hey, this doesn't seem to work with steam overlay at first glance. is there a way to enable it? I sorta wanted this so I could play with people who have a different modlist than me, but that kinda requires being able to connect to them.
     
  5. CatofRiddles

    CatofRiddles Astral Cartographer

    The programming is confusing... I think i understand how to put in Steam Mods, but... Does this work with non-steam mods? If so, where and how do i input it in the file? or is there an easier way?
     
  6. missHPfan2

    missHPfan2 Starship Captain

    Is there a way I could change where the program looks for Workshop mods? I know that the 1.3 update will break nearly all my mods, and then they won't all update at once. A few will, then a few more, then a few more and so on, and if I have a mix of 1.2 and 1.3 mods on 1.2, it won't really work. What I want to do is have a copy of all my mods and SB (I already know how to change where it looks for the game itself), all on SB 1.2, until all the mods that need to do so update to 1.3.
     
  7. zetaPRIME

    zetaPRIME Big Damn Hero

    Not built in, that I remember anyway; you'd have to pull down the source and compile a copy yourself, but it's a pretty simple substitution.
     
  8. Kaireo

    Kaireo Void-Bound Voyager

    Where do you exactly "just paste in the link"?
     
  9. MeleeAyy

    MeleeAyy Intergalactic Tourist

    yeah same question I don't get where I have to paste in the link its not as obvious as it seems I guess. Can someone maybe show like a screenshot or a short video tutorial?
     
  10. zetaPRIME

    zetaPRIME Big Damn Hero

  11. Joe The Eskimo

    Joe The Eskimo Intergalactic Tourist

    As with Kaireo and MeleeAyy, I don't know where to paste the modpack. Where do I paste the link?
     
  12. zetaPRIME

    zetaPRIME Big Damn Hero

    ...into the main window?
     
  13. CrioChamber

    CrioChamber Space Hobo

    Was working with Multibound, and it will not let me in to any server that does not allow asset mismatches. Looked at the logs, and it's detecting an unnamed asset from .autopatch, which only is there during runtime. I can join any server that does allow asset mismatching, however.

    Log from Multibound: https://pastebin.com/374fJDw3
    Starbound root log: https://pastebin.com/xywpudae

    ALSO! While here, any chance to allow us to make instances use a custom directory? Such as if we have a game folder on the desktop for whatever reason, and not in the normal root folder or in Multibound's folders, in an instance folder we can tell Multibound in the instance.json to reroute to that custom directory.
     
  14. zetaPRIME

    zetaPRIME Big Damn Hero

    That asset is just a patch for the window title...

    As for directories, you can just replace the "inst:/whatever" with a normal filesystem path.
     
  15. CrioChamber

    CrioChamber Space Hobo

    I tried to do the normal filesystem path.... It didn't like it. Gave me a "U" error or something like that because of the json instance file. I mean, unless there's something I'm messing up, it didn't like the custom file path I gave it.
    EDIT: Re-running it with the custom directory, here's the error:

    Caught JsonException:

    Invalid character 'U' in input string

    EDIT2: The current instance.json: https://pastebin.com/C1ZhFbA3
    The "user" part is renamed for privacy purposes.
     
    Last edited: Jun 29, 2017
  16. zetaPRIME

    zetaPRIME Big Damn Hero

    That's reading it as an escape code. You need to either use / or \\ as the directory separator.
     
  17. CrioChamber

    CrioChamber Space Hobo

    I see now. Thank you.
    EDIT: So I used the custom directory to compare. Launching the client via normal executables allowed me to connect in to the server that does not allow mismatched assets. However, launching the same directories from Multibound does not with it complaining about mismatched assets.
    EDIT2: After closing Starbound launched from MB, now it won't start from MB. Error log attached. I have not changed anything since I first launched the client with MB.
     

    Attached Files:

    Last edited: Jun 29, 2017
  18. Melendroach

    Melendroach Space Penguin Leader

    Wow that makes my life a lot easier! Thanks!
     
  19. zetaPRIME

    zetaPRIME Big Damn Hero

    ...looks like it can't make a directory inside wherever you have it; launched as the wrong user, perhaps?

    As for the asset mismatch thing... setting the window title in instance.json to "Starbound" should result in no actual change in asset digest.
     
  20. CrioChamber

    CrioChamber Space Hobo

    That's the thing. I checked and rechecked. Even recopied the directory and pasting it, and changing the \ to / and it still doesn't like it.
    Screenshots of error log, folder trying to direct to, and https://pastebin.com/jqJQ6ZG1 for the instance.json.

    Edit: Launching the modpack from internal (instance) folders with the window title as "Starbound" still prevented me from getting into the desired server. Tried it with the launch name as Starbound as well, same thing.
     

    Attached Files:

    Last edited: Jun 29, 2017

Share This Page