Mods Not Working?

Discussion in 'Mods' started by daikiraikimi, Mar 7, 2016.

  1. daikiraikimi

    daikiraikimi Astral Cartographer

    Hello! I was trying to add the TimeSpeed mod to my game and was unable to get it to work. Later, I tried a few other mods, and it seems that no mods using SMAPI are working for me. I saw on the Steam forums that there is at least one other user having this same problem.

    I installed SMAPI, put it in C:\Program Files (x86)\Steam\steamapps\common\Stardew Valley next to the regular .exe file, and tried placing my mods in the Mod folder in the same location which did not work. After some digging around, I also tried placing the mods in C:\Users\UserName\AppData\Roaming\StardewValley\Mods but no change.

    Any advice would be greatly appreciated! Here is my original post regarding the TimeSpeed mod, which includes screenshots:

    Here is the link to a steam discussion, where another member had the same problem:

    I'm on a Windows 10 machine, and am launching the game through the StardewModdingAPI application file. Thank you!
    • Zien

      Zien Space Hobo

      It probably needs an update since the new release of SMAPI v0.37 needs old mods to update for it to work. Contact the modder and tell him/her to update it.
        HollandVG likes this.
      • daikiraikimi

        daikiraikimi Astral Cartographer

        Thank you, I'd thought the mods I was using were fully updated but it looks like they might not be. (Threads say 3.6) I will ask them about updating, and see if installing an older version of SMAPI fixes the problem in the meantime.

        [Edit] Hm, just tried again using 3.6 and nothing has changed. Can't find a download link to 3.5. Guess I'll wait for updates and see where that leads.
          Last edited: Mar 7, 2016

        Share This Page