Missing/Corrupt Save File Troubleshooting Guide

Discussion in 'Support' started by ConcernedApe, Apr 7, 2016.

  1. Spaz4fun

    Spaz4fun Space Hobo

    Please can someone check my save? I changed game version to newest steam version and when i load my old save my game i crash..
     

      Attached Files:

    • saturnreed

      saturnreed Space Hobo

      Hi, my game file has 208 hours on it and today when I tried to play the character looks off and when I try to open it it crashes the game.
      I'd greatly appreciate the help because nothing I've tried has worked
       

        Attached Files:

      • saturnreed

        saturnreed Space Hobo


        EDIT: I was able to finally make it work, apparently steam updated and it removed the 1.3 beta from my game so my game file that had items from this update wouldnt work. I installed the 1.3 beta again and it's running smoothly now.
         
        • leonardodadoge

          leonardodadoge Space Hobo

          im using beta ver and i forgot to backup files when i switched into beta. So will beta version gets update and when the alpha stage on, my data on beta ver still there ? Help me, im so confuse
           
          • Blorp

            Blorp Big Damn Hero

            When beta ends, you'll be able to use your current save(s) with the released version of 1.3.
            What you won't be able to do now is go back to 1.2.
             
              leonardodadoge likes this.
            • leonardodadoge

              leonardodadoge Space Hobo

            • BinJabreel

              BinJabreel Space Hobo

              My game suddenly started freezing when i open the load screen or it tries to save a new game.

              I tried opening it with root access, i tried deleting all my saves, i tried deleting the whole game and reinstalling, i tried opening the permissions on my user library where the saves get put, i tried plugging in headphones, i tried disabling the steam cloud, i don't have any antivirus, i've never installed mods, i'm not using a beta, the game is fully updated. Absolutely nothing has worked. I'm playing it through steam on a Mac.

              WHAT THE HECK.
               
              • Phantom _Koala28

                Phantom _Koala28 Space Hobo

                What about if my save progress on my ps4 is lost when i saved last night and its gone now?
                 
                • JolteonGirl

                  JolteonGirl Space Hobo

                  I have a similar problem. This has happened to both my saves now. I looked in notepad, and both saves are missing completely. At first I thought "huh, maybe it's because of the mods I downloaded." before I remembered that the first time it happened, I didn't even know that there were mods, so that couldn't have been the reason. It may be because I had deleted and reinstalled the game, but even after I did that my files were still there. So I'm at a loss. I don't want to restart for the second in the span of two months. So, I finally stopped being an idiot and checked online, but all the answers I got up until now were either completely useless to me, potentially made it worse, gave no real information, or were just very confusing. What I'm trying to say I have no idea what I'm doing and someone needs to take over for me before I end up accidentally breaking my desktop. Below I am putting the two backup versions, as they were the only ones I could find. They are two folders zipped into one, as that is how I found them.
                   

                    Attached Files:

                  • MysticTempest

                    MysticTempest Ketchup Robot

                    That sounds more like a system issue than a save related one. A new thread with error logs if it crashes as well. And, make sure you have enough free disk space to save as well.


                    I'm not familiar with the console versions, but generally speaking there isn't really anything that can be done since consoles don't offer the same accessibility that computers do.



                    A few of those files were as you saw; completely wiped out. Perhaps the game crashed while saving or something. The backups seem to work though.

                    So, I recreated the folders for the characters, renamed the save files to their proper format & recreated a SaveGameInfo file; then did a test with the copies. They load, and save fine on my end now.
                    So, here's the fixed files.
                     

                      Attached Files:

                    • JolteonGirl

                      JolteonGirl Space Hobo

                      Unfortunately, it seems to still not be working. I checked the save file, and it's completely fine, but I did get this error message.



                      [SMAPI] Type 'help' for help, or 'help <cmd>' for a command's usage
                      [game] Exception occured trying to access file 'C:\Users\Emma\AppData\Roaming\St
                      ardewValley\Saves\Emma_146202737\SaveGameInfo'
                      [game] System.Xml.XmlException: Root element is missing.
                      at System.Xml.XmlTextReaderImpl.Throw(Exception e)
                      at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
                      at System.Xml.XmlTextReaderImpl.Read()
                      at System.Xml.XmlTextReader.Read()
                      at System.Xml.XmlReader.MoveToContent()
                      at Microsoft.Xml.Serialization.GeneratedAssembly.XmlSerializationReaderFarmer
                      .Read68_Farmer()
                      [game] Exception occured trying to access file 'C:\Users\Emma\AppData\Roaming\St
                      ardewValley\Saves\Rina_192636360\SaveGameInfo'
                      [game] System.Xml.XmlException: Root element is missing.
                      at System.Xml.XmlTextReaderImpl.Throw(Exception e)
                      at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
                      at System.Xml.XmlTextReaderImpl.Read()
                      at System.Xml.XmlTextReader.Read()
                      at System.Xml.XmlReader.MoveToContent()
                      at Microsoft.Xml.Serialization.GeneratedAssembly.XmlSerializationReaderFarmer
                      .Read68_Farmer()

                      This mean anything?
                       
                      • MysticTempest

                        MysticTempest Ketchup Robot

                        That's odd. Make sure to delete any previous versions of these saves from your save folder, and possibly pause Steam's cloud sync.
                        Then copy the folders I sent directly into your save folder.
                        That'll ensure it's reading the files I sent, and not any remainders of the broken versions.

                        The error looks similar to an old issue where the game had issues with reading the "startup_preferences" file. Not sure why it'd be giving errors on the SaveGameInfo file; as it works fine on my end.

                        You can also try verifying your game files; just note that it'll overwrite your XNB mods and SMAPI will need to be re-installed. So backup those as needed.

                        Instructions for verifying files:
                        Right click Stardew Valley in your Steam Library.
                        Then select 'Properties' from the popup.
                        After that a new 'Properties' window should show up.
                        Go to the 3rd tab, 'Local Files', and select; "Verify Integrity of Game Files".
                         
                        • brw

                          brw Intergalactic Tourist

                          Hi, I have registered here in the hope that someone can look at my save game and fix whatever the problem is
                          (I should state that the save is from my psvita)
                          Im 70+ hours in so really need this save
                          Thanks in advance
                          (I had to .zip the save)

                          Thought Id better say, I cannot load this save at all it crashes on vita and pc version
                           

                            Attached Files:

                          • MouseyPounds

                            MouseyPounds Phantasmal Quasar

                            I worked with brw on this in the Discord server. It should be sorted now (at least the PC test went well).
                             
                            • ovea

                              ovea Aquatic Astronaut

                              Would anyone be able to assist me with my save problems?
                              The thing is; since the 1st of winter (In-game-time) my game skips every other day, ie. after day 1 it changes to day 3.
                              I noticed this during the first week of winter. As I was unable to find the root of the problem, I loaded an old backup from early fall (in-game-time). However, as winter again began, the same thing happened. Every other day is skipped by the game. I cannot make sense of the technical information I am given. Can anyone give it a read and help me? Thank you in advance!

                              I'll leave the log here:


                              [SMAPI] An error occured in the base update loop: System.ArgumentException: An item with the same key has already been added.

                              at System.ThrowHelper.ThrowArgumentException (ExceptionResource resource) <0x18cfd4720 + 0x00039> in <filename unknown>:0

                              at System.Collections.Generic.Dictionary`2[TKey,TValue].Insert (System.Collections.Generic.TKey key, System.Collections.Generic.TValue value, Boolean add) <0x17bdea3f0 + 0x00140> in <filename unknown>:0

                              at System.Collections.Generic.Dictionary`2[TKey,TValue].Add (System.Collections.Generic.TKey key, System.Collections.Generic.TValue value) <0x17bdea3b0 + 0x00023> in <filename unknown>:0

                              at StardewValley.NPC.parseMasterSchedule (System.String rawData) <0x17bde1bf0 + 0x01251> in <filename unknown>:0

                              at StardewValley.NPC.getSchedule (Int32 dayOfMonth) <0x17bdde260 + 0x00f7d> in <filename unknown>:0

                              at StardewValley.NPC.dayUpdate (Int32 dayOfMonth) <0x18cfd26c0 + 0x004fe> in <filename unknown>:0

                              at StardewValley.Game1._newDayAfterFade () <0x18cfb8000 + 0x035b1> in <filename unknown>:0

                              at StardewValley.Game1+<>c__DisplayClass512_0.<newDayAfterFade>b__0 () <0x18cfb2ca0 + 0x00017> in <filename unknown>:0

                              at StardewValley.ModHooks.OnGame1_NewDayAfterFade (System.Action action) <0x18cfb2c80 + 0x00011> in <filename unknown>:0

                              at StardewValley.Game1.newDayAfterFade (System.Action after) <0x18cfb2b20 + 0x00125> in <filename unknown>:0

                              at StardewValley.Game1.UpdateOther (Microsoft.Xna.Framework.GameTime time) <0x17d8f6790 + 0x0138c> in <filename unknown>:0

                              at StardewValley.Game1.Update (Microsoft.Xna.Framework.GameTime gameTime) <0x17af78000 + 0x039c5> in <filename unknown>:0

                              at (wrapper dynamic-method) StardewModdingAPI.Framework.SGame:Update_Patch1 (object,Microsoft.Xna.Framework.GameTime)


                              Edit:
                              I'd like to add that I suspect that the problem originates from saving the current day. I suspect this due to the game, while adding all values of the items in the result screen at the end of the day, already changes the day. Ie. at the end of day 1, the game lags a little and then proceed to show the results from day 1, but the screen says day 2. After the addition and saving, it starts up at day 3!
                               
                                Last edited: Aug 31, 2018
                              • brw

                                brw Intergalactic Tourist

                                MouseyPounds is a genius, ive been playing for a few ingame days no problems thanks again for all your help. brw

                                just to add if anyone else is having issues drop by the discord server friendly people willing to help
                                 
                                • BlueChicken

                                  BlueChicken Space Hobo

                                  Hi I fixed my save game and it is there again but now every time I try and load my character it goes to the chucklefish logo like nothing happened.I've gone through the other replies about this but it doesn't work.Any help???

                                  EDIT- (I'm in 1.3)
                                   

                                  Share This Page