Modding Discussion Migrating XNB mods to Content Patcher packs

Discussion in 'Mods' started by Pathoschild, Mar 5, 2018.

  1. rosei21

    rosei21 Void-Bound Voyager

  2. Skyzrielle

    Skyzrielle Space Hobo

  3. Moragaine

    Moragaine Pangalactic Porcupine

    That is a Smapi mod, not an XNB mod.
     
    • coldazrael

      coldazrael Void-Bound Voyager

      My pleasure. :DD
      The answer is from your own post here. :rofl:
      v
      v
      v
       
      • rosei21

        rosei21 Void-Bound Voyager

        Last edited: Jan 3, 2019
      • coldazrael

        coldazrael Void-Bound Voyager

        Surely you're not making a mistake? o_O
        I clearly saw the last update of the file is 14 Sep 2018, 1:04AM
        upload_2019-1-3_9-18-39.png
        It doesn't seem to be a new shirts or something, missy only reuploaded the file because of troubles with opening the archive and the most recent file is only 7zip version of it.
         
          Last edited: Jan 3, 2019
        • rosei21

          rosei21 Void-Bound Voyager

          earlier that file was under the the 7zip dated 1st jan 2019 and and im sooooooo sorry:oops:
           
          • coldazrael

            coldazrael Void-Bound Voyager

            No worries. :D
            But if you are still not sure if the file was updated, it's pretty much simple to update the conversion though. Just drop the shirts.xnb from nexus to 'asset' folder in the conversion. Then open up the content.json, change "FromFile": "assets/shirts.png" to "FromFile": "assets/shirts.xnb".
             
            • vadie

              vadie Orbital Explorer

              Thank you so much for doing this~ Sorry it took so long to check it out. The main problem I ran into is that in the content file, you added an "s" to the end of "Data" and "Dialogue", so SMAPI couldn't find the correct files to replace or what to replace it with. By getting rid of the extra "s" things seem to load fine, though!
              Aside from that little loading issue, I haven't tested it enough to see if everything works fine. But as I playtest it, I'll reply back if there are any issues. Thanks again~
               
              • coldazrael

                coldazrael Void-Bound Voyager

                That was a small mistake once and I copy-paste'd it to many :rofl:
                Anyways, did you spot any buggy animations? tbh I got a little confused in the animationDescription file, and I was expecting the bug o_O
                 
                • forkish5213

                  forkish5213 Tentacle Wrangler

                • coldazrael

                  coldazrael Void-Bound Voyager

                  Attached Files:

                • EmiliaGray

                  EmiliaGray Intergalactic Tourist

                  Could anyone convert the higher-res version of this to CP? They have the lower resolution version available but are unsure of how to convert the higher res one (I believe its not an xnb mod though - if this is not the right place to post let me know where I should). https://www.nexusmods.com/stardewvalley/mods/2974?tab=files
                   
                    Last edited: Jan 4, 2019
                  • coldazrael

                    coldazrael Void-Bound Voyager

                    EmiliaGray likes this.
                  • rosei21

                    rosei21 Void-Bound Voyager

                  • coldazrael

                    coldazrael Void-Bound Voyager

                    Attached Files:

                  • rosei21

                    rosei21 Void-Bound Voyager

                    thank you so much :up:
                     
                    • coldazrael

                      coldazrael Void-Bound Voyager

                      My pleasure. :DD
                       
                      • rosei21

                        rosei21 Void-Bound Voyager

                      • Cassichu

                        Cassichu Void-Bound Voyager

                        Hmm. I seem to be having an error between two of my mods? I was wondering if anyone might be able to help me figure out what it is?

                        This is the error I'm getting:

                        [​IMG]
                        https://gyazo.com/79ecdb25062aa328e843f92251098e53

                        So it seems it's Kamylla's immersive mod and the early open shops conflicting but... I'm not sure why? Could someone gimme a hand here?

                        I was also wondering if anyone has found an updated 2.4 Kamylla's SMAPI file? It says that it's not updated to the most recent SMAPI on the official nexusmods page, but the last update seems to have been april of last year?

                        https://www.nexusmods.com/stardewvalley/mods/1149
                         

                        Share This Page