Modding Help Might've ruined game from smapi misuse?

Discussion in 'Mods' started by Honey Dragon, Jun 8, 2019.

  1. Honey Dragon

    Honey Dragon Void-Bound Voyager

    Hello Chucklefish community! I think I may have majorly messed up my stardew game, or at least my smapi. Kind of panicking a bit here.

    link to smapi log (I tried to reload it twice, so I don't have the original error log unfortunately;;; ) :

    what I did:
    I think the issue came from my attempt to move mods from my mod folder to a separate folder I have to play the game vanilla with a friend who doesn't use mods.I have never had an issue with doing so before, but in my haste I removed everything, leaving a blank mod folder. I tried to launch Stardew Valley, but the game gave me a flickering purple screen, and then crashed. The smapi log was filled with long red error messages, ending in it forcibly crashing the game. I put all the mods I had removed back into the mods folder, but the same thing happened.
    (The smapi log linked is the version with all the mods moved back into the mods folder, the version with an empty folder was deleted since I tried reloading)

    Possible reasons...?:
    -using smapi 2.10, haven't updated to 2.11.2
    -accidentally removed content patcher when removing all mods (moved back into mods folder after first error log)
    -possibly incompatible mods? (they all worked fine before, but maybe I added one or two extra when moving back into mod folder)

    I would really appreciate some help with solving my issue. From what I can tell right now, I'm unable to access Stardew Valley at all. Did I corrupt my game? Is this permanent? I'm not a coder/programmer, but I could probably do something if given descriptive instructions.

    Thanks for the help!
    • MouseyPounds

      MouseyPounds Cosmic Narwhal

      You do need SMAPI 2.11 for the current version of Stardew Valley, so you might as well update to 2.11.2 and see if that solves your problem. In the future, to run without mods you can either just temporarily rename the Mods folder or run the StardewValley-original command file instead rather than moving files around.
      • SpringsSong

        SpringsSong Cosmic Narwhal

        You're also missing a mod that is required for another mod.
        16:43:34 ERROR SMAPI       These mods could not be added to your game.
        16:43:34 ERROR SMAPI       - Harvest With Scythe 1.0 because it requires mods which aren't installed (bcmpinc.StardewHack).
        • pepoluan

          pepoluan Big Damn Hero

          I see that you're on Steam. My suggestion is:
          1. First, backup the Mods directory -- except for these 2 "mods": ConsoleCommands and SaveBackup <== they came from SMAPI
          2. Uninstall the game
          3. Remove its directory (from the logs, it would be "/Users/Emily/Library/Application Support/Steam/steamapps/common/Stardew Valley")
          4. Reinstall the game
          5. Install the latest SMAPI according to SMAPI's instructions
          These steps will ensure that all files are "fresh" and non-modified.

          Follow up the above steps by:
          1. Install all mods except CP and [CP] mods.
          2. Try running the game.
            1. If there's an error, disable the mods one by one until the error is gone. The last mod you disabled will be the problematic mod.
          3. Install ContentPatcher but NOT the mods needing ContentPatcher
          4. Try running the game
          5. Install the [CP] mods
          6. Try running the game
            1. If there's an error, do a bisecting: Disable the mods half-by-half until the error is gone. One of the mods in the last batch you disabled will be the problematic mod. Reenable the batch one-by-one until you find the culprit.
          Good luck!

          Share This Page