1. Thanks for visiting! These forums are for the original Risk of Rain, if you're interested in discussing the newly released Risk of Rain 2 head over to that game's steam discussion forum
    Dismiss Notice

Memory leak issues

Discussion in 'General Discussion' started by Relinies, Nov 10, 2013.

  1. Relinies

    Relinies King Homestuck III

    I got this game from a friend who bought a four pack, under the terms that I would host a server. Normally, I can do that.
    When I booted the game up, it ran happily at 60 FPS for maybe 12 seconds.
    It progressively got slower and slower as the game ran, and upon checking the memory usage via task manager I found it to be at 430k mb, while the game itself was running 8-10 FPS at that moment.
    Restarting the game reveals that the game normally uses only 115k mb of memory.
    This isn't a Multiplayer specific thing, either. It happens even on the title screen.

    I am on the latest version as of 5:50 PM Central on 11/10/2013.
    I'm running Windows 7, 64 bit.
    When I acquired a 1.0.0 copy of the game to compare my FPS to, there was no apparant memory leak or lag of any kind. Full 60 fps, easily. Something changed in the 1.0.1 update is to blame.

    It's good to note that this is probably a similar issue as described in this thread, but I didn't see any mention of a memory leak or framerate dropping constantly to nil, so I figured a different thread would be in order to bring further attention to the issue.
      MordredN likes this.
    • Relinies

      Relinies King Homestuck III

      EDIT: Actually, I just solved this issue. Fuuunny story.
      This is the exact same problem I experienced in Wanderlust: Rebirth. It's all better now!
      All you have to do is plug in your controller before starting the game.
      I have no idea why the 1.0.0 copy didn't have the same problem, though.
      • Treadlight

        Treadlight Existential Complex

        Oh uh... Thanks, I guess? I don't know how to thank someone for fishing through an old bug report thread to find information on an odd issue. How did you even know to look there?
        Either way, I'm glad you got it working again.
        • Relinies

          Relinies King Homestuck III

          It was a similar issue describing low FPS and was on the front page of general discussion, not a hard find.
          • amov1ngtarget

            amov1ngtarget Orbital Explorer

            I am having the same issue. I start the game with 60 fps and it slowly drops until it gets down to about 8, even just sitting in the main menu. I have tried highest settings, lowest settings, controller, no controller, compatibility modes, and nothing helps.
            My specs are:
            Windows 7, 64-bit
            AMD Athlon II x4 645 Processor ~3.1GHz
            6 GB Ram
            AMD Radeon HD 6770
            • hopoo

              hopoo Risk of Rain Developer Developer

              Do you mind sending both your Prefs.ini and Save.ini to spacegame2012@gmail.com? How long does it usually take for the FPS to drop?
              • Tunnl Armr

                Tunnl Armr Void-Bound Voyager

                Having the same issue here, even with no controller and off a fresh computer restart. Framerate starts at 60, then steadily drops over 1-2 minutes, with lowest settings and surfaces disabled. Will send both those files.

                Windows 7 64bit
                Intel Core2 Quad Q9300 @ 2.50GHz
                8GB RAM
                NVIDIA GeForce GTX 560 Ti
                • Tunnl Armr

                  Tunnl Armr Void-Bound Voyager

                  Was looking in the Wanderlust forums as had similar issues trying to run that. It was suggested mouse or keyboard drivers were possible culprits. I didn't get to uninstalling them (though they are up to date), but I did try unplugging all my inputs. Frame rate seemed to stay stable with no keyboard, gamepad, or mouse active. Tried again off a fresh restart with just controller plugged in, still dropped but at a drastically reduced rate (got a couple mins play in before the frame rate dropped too much to play).

                  Share This Page