1. Please be advised of a few specific rules and guidelines for this section.

RELEASED Matter Manipulator Plus (new manipulators for each pickaxe tier) (Archive)

Discussion in 'In-Game Tools' started by Xuhybrid, Dec 7, 2013.

  1. yk999

    yk999 Subatomic Cosmonaut

    I did, my game folder is clean, there are no old mod files.

    Nevermid, i'll think about this later. Thanks for the help anyway. :)
  2. Xuhybrid

    Xuhybrid Scruffy Nerf-Herder

    Damn, im sorry i couldn't get it sorted for you.

    No problem.
  3. yk999

    yk999 Subatomic Cosmonaut

    Okay i fixed it, it was my fault. Sorry for wasting your time. :)
  4. Xuhybrid

    Xuhybrid Scruffy Nerf-Herder

    Glad to hear it lol :rofl:
  5. xtomass

    xtomass Orbital Explorer

    Cool Addition to the Game. Like using these more then the pickaxes :)

    Also Covered it on my Mod List Video
  6. Furinex

    Furinex Phantasmal Quasar

    This mod worked for me for a short while then all of a sudden I can no longer see the tool when used in my characters hands. I think the update may have messed with something. Any ideas?
  7. yk999

    yk999 Subatomic Cosmonaut

    Oh, this mod gave me all kinds of trouble (some of them were my fault), i'd like to help. Here is how i fixed everything:

    First create this and put all "xxxgravgun.png" files in there:

    Then create this and put all "xxxbeamaxe.beamaxe", "xxxgravgunicon.png", "xxxgravgunlarge.png" files in there:

    And then create this and put all "xxxbeamaxe.recipe" files in there, except "stonebeamaxe.recipe" file:

    And create this and put "stonebeamaxe.recipe" file in there:

    Starbound\mods\mattermanipulatorplus\recipes\starter\crafting table\
    Now open "copperbeamaxe.beamaxe" file (in the "Starbound\mods\mattermanipulatorplus\items\tools\" directory) and find this line:

      "image" : "/mods/mattermanipulatorplus/items/coppergravgun.png",
    And change it like this:

      "image" : "/humanoid/any/coppergravgun.png",
    Now do the same thing with the other "xxxbeamaxe.beamaxe" files. All of them should see the correct location for their own "xxxgravgun.png" files. Otherwise they will be invisible in the game.

    Last, open Starbound\win32\bootstrap.config file. Do this:

      "assetSources" : [
      "storageDirectory" : ".."
  8. Furinex

    Furinex Phantasmal Quasar

    You know... I did this ENTIRE process thinking I could look at the format for the default starbound directory and figure it out. It didnt work. You type it all out and I followed it step by step and it works. So I guess I just needed to see it in front of me. Thank you so much for posting this.

    EDIT: Spoke too soon!!! Still cant get the item to show in my hands! Damn Ive double checked these instructions!
    Last edited: Dec 11, 2013
  9. Xuhybrid

    Xuhybrid Scruffy Nerf-Herder

    The original version for Irritated Koala was formatted like that. It's not necessary for it to work as it can find new items/recipes regardless of their folder. The item showing in your hands is an issue with the base directory that it looks for the image. I set the location manually so there's a chance that it doesn't work with mod loaders. I just installed the mod in the latest version, following my instructions, and there are no problems. Again, there might be some path problems with finding the hand image if its installed with a mod loader. I'll look into that shortly.
  10. Furinex

    Furinex Phantasmal Quasar

    With the path humanoid/any the only way I got it to work was by putting the hand images into the acumtual asset folder which I didn't want to do.

    I also dont use loaders. I noticed this is a problem if the folder you are looking to load the picture is in a directory that lies behind the file it is loading it from.


    if the .beamaxe file is in mattmanipplius/item/tools, it cant locate a picture in mattermanipplus/item. Even if you set the path to mod/mattmanipplus/item

    (sorry for any path mistakes, im on an iphone atm)
  11. Xuhybrid

    Xuhybrid Scruffy Nerf-Herder

    Yeah, that's more of a problem with the game code than anything. The root directory should where the .beamaxe file is location but unfortunately it is not. I put everything into a mods folder inside assets with the latest version because it was a bit messy to throw files in with the core assets. That said, as long as it's linked to the right file path, it doesn't appear to matter where the images are.
  12. yk999

    yk999 Subatomic Cosmonaut

    Hey Xu!

    "as long as it's linked to the right file path, it doesn't appear to matter where the images are"

    For some reason this doesn't apply to my game. I had to change the location of images, and then enter the correct path to .beamaxe files to get them to work properly. This mod installation stuff is really confusing, some mods work like a charm despite the lack of proper sub-directories, other mods don't. I don't know what's the problem really. Anyway, your mod works like a charm now. :)
  13. yk999

    yk999 Subatomic Cosmonaut

    Sorry my friend, that worked for me. Hope you fix it.
  14. Furinex

    Furinex Phantasmal Quasar

    I got it fixed by following your steps except the only different thing I did was put the xxxgravgun.png files in assets/humanoid/any of the actual starbound assets. Not my first choice but it worked.
  15. yk999

    yk999 Subatomic Cosmonaut

    Yeah if the mods folder method doesn't work, assets folder method always works. Have fun. :)
  16. VeryOpinionatedGamer

    VeryOpinionatedGamer Scruffy Nerf-Herder

    I also don't use loaders but i managed to find a simple fix for this, took a little bit of time but i worked it out.

    before going on the name xxxbeamgun is used so i don't have to type out every beamgun there are six. xxx is to be replaced with their proper names, stone, copper, silver, gold, platinum, and diamond.

    just move the xxxgravgun.png to the /humaniod/any. This is in the assets folder, under effects. (just for those having problems finding it.) Those are the only ones that I moved, I didn't touch any of the others.

    This one is the MOST IMPORTANT, as my computer does care where the PNG files are located if there is a path it is told to follow, which it just so happens that this go around there is.
    go BACK to the items/tools, where you up the xxxbeamaxe.beamaxe files, open every last one of them in notepad++ there should be six in total Stone, Copper, Silver, Gold, Platinum, Diamond

    Change the "image" path from /mods/mattermanipulatorplus/items/ to /humaniod/any/ leave the actual name of the png alone. so all six should read"

    3. )
    Leave the other two png, as well as the .beamaxe configs in the tools folder they don't need to be moved.

    after I did this everything was back to the way it worked before. I don't suggest messing with anything if the mod works just fine, this is just for those of us who aren't using Mod loaders, I for one won't use one unless i have to, as I like to keep personal account of just what has been done to every file and config in my game. others may have their own reasons.
  17. Xuhybrid

    Xuhybrid Scruffy Nerf-Herder

    Perhaps some of your files are out of date or different to mine. Ive downloaded my version, cleared all files, started new characters. Literally done everything i can to duplicate the problem you're having but the image always appear in hand as its supposed. Also, changing the 'image' property to another static path with 'assets' as the root directory is no different. There is 100% no difference between having an image in /humanoid/any/. Not trying to devalue your problem, i just don't see how its even possible for the problem and your solution to exist :rofl:
  18. VeryOpinionatedGamer

    VeryOpinionatedGamer Scruffy Nerf-Herder

    Never assume my friend, all of my files are up to date, i've cleared every file before installation of the newest version, this isn't my first rodeo with mod's or modders for that matter lol. My game is up to date, the mod files were downloaded just this evening prior to me making the post, so if there is anything different from my files to yours it's on YOUR end as i downloaded it from YOUR nexus link. Also change the "image" property DOES make a difference, when you specify a path for a program to read, it reads that path.

    For the sake of this debate i went and changed the "image path for my Diamondbeamaxe back the what your .beamaxe stated. as you can see this is the file that is in my asset's folder and it has been saved and is quite up to date.

    beamaxe config.PNG

    this is the result in game...


    when i change it back to what i changed it to.

    beamaxe config 2.PNG

    This is the brilliant result...


    my point being that if you state in a config file a clear cut path when the program reads that data it will search that path, since in my case i don't have a mod folder in which to put mods in i literally put them in the folders they go in, the path has to be changed to the correct path or it WON'T SHOW UP. If i have to i will create a video to show you that it is what it is, I have no reason to sit here and make up something wrong with someones mod, i love this mod as it's balanced and more in line with what i feel starbound needs (pickaxes, REALLY, nah i prefer beamaxe's). I have no reason to troll either. I never once said there was a bug or flaw in your mod, so there no need to become defensive, my post simply helps anyone who like myself prefers to mod their game without the help of mod loaders that do everything out of my sight and thus if something goes wrong i have no clue how to fix it.

    Next time try shift the blame a little less, ask questions before assuming it saves people the hassle of getting upset and frustrated, and makes you look heck of a lot less judgemental. Again if you need, i can make a video showing that my post is on the level, and so is my solution.
  19. Xuhybrid

    Xuhybrid Scruffy Nerf-Herder

    Yeah, ive cleared my files and redownloaded too, which is why i thought it could be an issue. Id love to set a relative path from the .beamaxe file but the game refuses to do this. Like i said, i wasn't trying to devalue or disprove your problem, im just stumped as to why its a problem in the first place ;) In an effort to resolve this issue for mod loaders using the bootstrap, ive uploaded a new version with updated instructions/files to fix the hand graphics. Leaving the .beamaxe files alone and copying the images into their expected folder works as intended now.

    PSA - New file uploaded with a workaround for mod loaders.
    Last edited: Dec 12, 2013
  20. Xuhybrid

    Xuhybrid Scruffy Nerf-Herder

    By the way, having looked at your file location, i think i see the problem.


    This is not the file structure i provided. This is where they should be;


    So im not surprised that it doesn't work if you reorganised the files yourself.

Share This Page