1. Hey Guest! Our new game Wargroove has released! Check out the forums or wiki for more information!
    Dismiss Notice

Notice Manually Uploading to Steam workshop with Linux and Mac and Windows

Discussion in 'Starbound Modding' started by The | Suit, Jul 25, 2016.

  1. Monijir

    Monijir Scruffy Nerf-Herder

    That was the method I used when I ended up with my conflict problem - just whichever mod was downloaded most recently would show up in the mod list. Don't think I have the right files to replicate it now though. I have learned to first upload a private version to make sure everything's up and running.
     
  2. ManicRykker

    ManicRykker Phantasmal Quasar

    If anyone knows how you'd add a mod to categories with this method (Now that that workshop mod category tag feature's live) that would be very useful to know.. as I currently don't even know how to reap the new feature. :/
     
  3. GonDragon

    GonDragon Pangalactic Porcupine

    Just add to your .metadata file a new parameter called "tags" with the tags in the next format:

    Code:
    "tags" : "tag1|tag2|tag3",
    Here, an example with all the actual tags of steam.

    Code:
    "tags" : "Crafting and Building|Miscellaneous|Planets and Environments|Musical Instruments and Songs|NPCs and Creatures|Weapons|Quests|Dungeons|Cheats and God Items|Ships|Species|User Interface|Furniture and Objects|Character Improvements|Food and Farming|In-Game Tools|Mechanics|Vehicles and Mounts|Armor and Clothes",
     
    The | Suit and ManicRykker like this.
  4. The | Suit

    The | Suit Agent S. Forum Moderator

    For those not aware | is done by Shift + \ for Windows. It is not the lower case letter l or number 1.
     
  5. ManicRykker

    ManicRykker Phantasmal Quasar

    For some reason I couldn't get this to work... I got everything uploaded to the workshop, waited like a day, and neither mod I added the tags metadata line to show up in the tags I specified..
    That said, they don't use all of the tags so... did I just do something wrong?


    (Other metadata not included due to redundancy)

    PENGUINPIRACY
    "tags" : "Species|Furniture and Objects|Armor and Clothes",

    PANDORASBOX
    "tags" : "Miscellaneous|NPCs and Creatures|Furniture and Objects",
    (I think one was out of place for the latter... but that still doesn't explain the former..)

    Any ideas?
     
  6. GonDragon

    GonDragon Pangalactic Porcupine

    Mmmm, they looks right... May be that the place where the "tags" line is it also important?

    Here an example of a working metadata (uploaded with the official mod upload tool)

    Code:
    {
      "author" : "GonDragon",
      "description" : "I found a very good race mod but, sadly, isn't supported by frackin races. The race already have some inherent \"special ability\" coded into it, but it lack of some things to be a full Frackin' Races experience.\n\nSo, I decided to make that patch by myself. First, I maded it for personal use, but as I saw some people asking for it, I think to better release it.\n\nTo use this patch you need both, the Blattra race and Frackin' Races.\n\nThese are the changes in this patch:\n[list]\n[*] Diet: Omnivores.\n[*] Negative traits: -10% HP, 50% Ice Weakness\n[*] Positive traits: Low food consumption, +10% Energy , +10% speed\n[*] Resistances: +50% Poison, +30% Radioactive\n[*] Bonus: Gain a hefty health bonus in toxic, irradiated and decayed biomes.\n[*] Immunities: Poison, Radiation (both already in the race mod)\n[/list]\n\nI want to say thanks to the mod creators of both mods, for creating such amazing things and features to customize Starbound. That game wouldn't be the same without moders like you two. Thanks!",
      "friendlyName" : "Racial Roaches",
      "includes" : [],
      "link" : "steam://url/CommunityFilePage/1132476329",
      "name" : "FrackinRoaches",
      "requires" : ["Blattra", "FrackinRaces"],
      "priority" : 100,
      "steamContentId" : "1132476329",
      "tags" : "Character Improvements|Mechanics",
      "version" : "1.1.3"
    }
    As you see, the "tags" parameter is between "steamContentID" and "version". Maybe is that?
     
  7. ManicRykker

    ManicRykker Phantasmal Quasar

    Not too sure... Frackin Universe has it under author, and theirs works perfectly fine... this is very odd.

    UPDATE: Never could get the tags working with this method, so I guess we may be out of luck on that front, unless anyone's found anything on this. :/
     
    Last edited: Jan 14, 2018
  8. Zancuno

    Zancuno Phantasmal Quasar

    By any chance, can you link a good packing software to make .pak files? I tried the first method but failed, so I may have to pack my mod up first.

    Edit: Issue solved, never mind

    I did not insert the full path into the cmd.
     
    Last edited: Apr 9, 2018
  9. nnnn20430

    nnnn20430 Scruffy Nerf-Herder

  10. The | Suit

    The | Suit Agent S. Forum Moderator

Share This Page