1. Welcome to the Starbound support forums. Please check the support FAQs before posting: http://playstarbound.com/support

[Linux] Won't launch "Floating Point Exception Encountered!"

Discussion in 'Starbound Support' started by Kryger, Jan 30, 2018.

  1. Kryger

    Kryger Void-Bound Voyager

    Launching the game, through Steam, briefly seem to flash a window which immediately closes. Happens every time, have never seen any game screens. No mods, pristine installation.

    Error from log:
    Fatal Fatal Error: Floating Point Exception Encountered!
    [11:27:21.220] [Info] Root: Loaded ImageMetadataDatabase in 0 seconds
    [11:27:21.355] [Error] Fatal Error: Floating Point Exception Encountered!
    ./starbound(_ZN4Star10fatalErrorEPKcb+0x43) [0xaaa7e3]
    /lib/x86_64-linux-gnu/libc.so.6(+0x37140) [0x7faf51061140]
    ./starbound(_ZN4Star4Time21monotonicMillisecondsEv+0x49) [0xa9fc09]
    ./starbound(_ZN4Star17AssetTextureGroup11loadTextureERKNS_6StringE+0x3b9) [0x13d6689]
    ./starbound(_ZN4Star10GuiContext11textureSizeERKNS_6StringE+0x1f) [0x141fa8f]
    ./starbound(_ZN4Star4Pane5setBGERKNS_6StringES3_S3_+0x124) [0x1442c54]
    Ubuntu 17.10 x64
    Geforce GTX 970 with Nvidia binary driver 390.12 (also tried the Nouveau driver, same error in log).
    i5-2500K CPU (3.30GHz)
    8GB RAM

    Tried a few things:
    Uninstalled and cleaned dirs and did a reinstall. Error in logs remained the same.
    Tried "Starbound - Unstable", with same result.
    Install disk have over a TB free.
    Starbound server also won't start, but there are no errors in the logs - last line is
    [11:11:38.034] [Info] Root: Loaded MaterialDatabase in 0.316 seconds
    See attached error log.

    Any advice of things to try or workarounds would greatly appreciated!

    Attached Files:

  2. Kryger

    Kryger Void-Bound Voyager

    Still can't launch the game, still haven't played a minute of it. Please Chucklefish!
  3. Kryger

    Kryger Void-Bound Voyager

    Still looking for help - will update if I receive ANY word from Chucklefish.
  4. Kryger

    Kryger Void-Bound Voyager

    ... I am giving up.
  5. Healthire

    Healthire Can't Most Program the Least


    Sorry about the late response.

    Your issue is not one we've seen encountered by anyone else, and looking at it I can't see what the issue would be from Starbound's end. I'll look into it but I can't guarantee that we'll have a solution, as the issue seems to be fairly unique either to your version of Linux or to your system.
  6. Kryger

    Kryger Void-Bound Voyager

    Hey! So glad to hear from you. I have seen references to this in other places on the net - but no solutions. People suspect libraries - libc in particular.

    Will try and round up some posts.

    Again, thank you for answering!

Share This Page