1. This forum is archived for reference. For support & bug reports visit the help section of forums.stardewvalley.net

Bug/Issue Keyboard not working in Kubuntu 18.04

Discussion in 'Mac / Linux Bug Reports' started by Achtland, Dec 22, 2018.

  1. Achtland

    Achtland Void-Bound Voyager

    I recently bought the game at gog and installed the linux version 1.3.32 on my new thinkpad. It starts fine, but does not recognize any keyboard inputs. Mouse works fine. I do not have trouble with any other application.
    After starting the game the application menu on my desktop isn't working anymore until reboot.
    I'm running an up-to-date Kubuntu 18.04 (KDE Frameworks: 5.44.0).
    Installing the game on an old thinkpad running kubuntu 14.04 works fine. Just not very fast.
    • Achtland

      Achtland Void-Bound Voyager

      I tried again with an updated version: 1.3.33 (26507) from gog.
      It still won't let me type anything, that means I cannot start a game, since I cannot type in a name.
      Plugging in an external USB keyboard changes nothing.
      I can close the game with ALT+F4.
      The new version doesn't block the desktop menu anymore though, but maybe that was an OS fix.
      • Achtland

        Achtland Void-Bound Voyager

        I have additional information about the bug plus a workaround for those struggling with it. It's just not a pretty one...
        The problem is only with the starting screen, i.e. the screen where you have to choose your character and type in names for you and your farm. Typing there does simply not work at all. I tried everything.
        But once a game starts, everything works fine, I can move around, select tools, etc. I found that out by asking a friend with a windows pc to send me a savegame. I can then open the savegame and play normally. Only creating a new character/game does not work. So despite having a native linux version, which was the reason for me to buy the game, you still need a windows pc to start a new farm.
        This is a strange bug.
        I'm on version 1.3.36 now.

        Share This Page