Bug/Issue Keyboard control won't work in game

Discussion in 'Mac / Linux Bug Reports' started by ninesue, Jun 14, 2019.

  1. ninesue

    ninesue Space Hobo

    Hi. I only bought this game a few hours ago, and I'm already loving it.

    So here's the problem.
    * Keyboard control won't work in game. I cannot move properly, or choose action.
    The only key I know I can use is ESC.
    I'm not sure what caused this problem.


    I started the game, and at first, it was fine.
    But when I tried to load the game after I quit it, my character won't get out of the bed.
    At this point, I was able to see that the system responded to the mouse clicks, and ESC key, but not to the keyboard controls regarding movements, and actions.

    So I tried to change the keyboard settings, and it worked! My character got out of the bed!
    But the other problem occurred right after. I still could not use other keys other than movements and ESC keys(mouse worked fine).

    So I tried to changed the action keys. But this time, It won't change. The system kept saying that the key I was trying to use was occupied(not the exact wording. Anyway, I checked that it was not occupied). I tried to change the movement key settings again, but now I can't change that, or every other control keys.


    Here's some background info.

    - OS: macOS Mojave 10.14.3
    - In windowed mode.
    - I bought & installed the game via Steam (a few hours ago!).
    - I may have been switching languages between Korean and English almost right before this happened. Not sure if this was the cause, though.
    Error occurred in both languages. The game worked fine in both languages before the error occurred, too. Maybe the switching them was the cause?


    Note: loading a game file wasn't a cause. I uninstalled & installed the game, and it happened again with 'New game,' too. The constant thing was that I was switching languages. At the first time, I played in English, then I made another game file, and switched language from English to Korean. The second time(after the re-installation), I played in Korean, deleted the save file, switched language to English, made new character(skipping intro).

    Note 2: I'm going to uninstall & install the game again, and going to try playing it without switching languages(either KOR or ENG). If the error doesn't immediately happens, I'll leave comment some time later.


    If you're curious to why I was changing languages again and again, here's the answer: I'm more comfortable with KOR, but I wanted to see if ENG version would felt different big time, especially in interacting with other characters. If so, I wanted to play in ENG. If the difference was not that big, I wanted to play in KOR.


    I hope someone will recognize the problem and share the solution.:cathug:
    Thank you for reading it.
     
      Last edited: Jun 14, 2019
    • ninesue

      ninesue Space Hobo

      Apparently this was something to do with language(in KOR or other languages).
      I reinstalled it, and it works fine in ENG, but the error still occurs in KOR, even right after the re-installation.
      I think I'll need to delete every file related to the game outside of steam uninstall process, in order to play the game in KOR. I'll have to try later.

      Edit: I deleted Steam cache. It seems like sometimes it works without error, but it keeps happening.
      Also, ENG setting, too, had error again. I'm still not sure what actually caused initial error. It's all speculation.
      Where even is the game file located?
       
        Last edited: Jun 14, 2019

      Share This Page