1. Please be advised of a few specific rules and guidelines for this section.

RELEASED Intrusive Teleport Animation Removal [Deleted]

Discussion in 'Other' started by MrChow, Apr 10, 2015.

Thread Status:
Not open for further replies.
  1. MrChow

    MrChow Pangalactic Porcupine

    Last edited: Jul 20, 2015
  2. Xirukai

    Xirukai Pangalactic Porcupine

    Thanks for this mod and for providing it seperately.
    Also a question.
    Is this vanilla MP friendly, so it wont break the server you're playing on.
  3. MrChow

    MrChow Pangalactic Porcupine

    I haven't tested it on multiplayer, since my connection is not suitable. It changes the client.config, so there's a chance it might be incompatible (still, it only removes the 3 second delay).
  4. Retr0

    Retr0 Pangalactic Porcupine

    Hey, this mod doesn't seem to work on a Mac. Do you have any idea why? Thanks.
  5. MrChow

    MrChow Pangalactic Porcupine

    Have you unpacked the zip archive properly?
    Have you created the sub-directory for the mod before unpacking it?
    Have you placed it to /starbound/giraffe_storage/mods/teleport_anim_removal/ ?
    Have you have you?
    Have you you?
    Last edited: Apr 13, 2015
  6. Retr0

    Retr0 Pangalactic Porcupine

    Uh..? *>< I think...
  7. MrChow

    MrChow Pangalactic Porcupine

    I really have no idea then. Mac is a shady territory for me.
  8. Xirukai

    Xirukai Pangalactic Porcupine

    I think if its a modification of existing files. It wont do any harm in MP.
    Since the server only checks if it has the same file by name, I think.
    Like if you run around with those XS mechs on a server that does not have them, server will crash since it didnt have them too.
  9. Retr0

    Retr0 Pangalactic Porcupine

    K then ill try to fix.
  10. Niteskale

    Niteskale Void-Bound Voyager

    I tried to use this mod. Didn't work.

    I'm using Nexus Mod Manager to install mods so far.

    When I tried the above suggestion of creating a folder for it to install manually, I got an error when trying to load starbound claiming I need CLeF despite this being the standalone version. The .modinfo file does have a "requires" : [ "CLeF" ] section in it.

    I created a folder and moved the mod files into the folder. Teleport animation still plays but for a shorter period of time.

    In the file with the text

    { "op" : "replace", "path" : "/playerWarpDelay", "value" : 1.0 },
    { "op" : "replace", "path" : "/playerWarpCinemaMinimumTime", "value" : 1.0 }

    I replaced the second 1.0 value with 0.0 and the game TRIES to briefly flash the teleport animation basically until it loads the location I'm warping too, which for me is near-instant but I still see it for a flash sometimes.

    EDIT: Also I am playing using the 64-bit launcher option, if that matters.
  11. MrChow

    MrChow Pangalactic Porcupine

    The CLeF requirement is a copy-paste oversight from my side, and somehow nobody has pointed me to it all this time. Sorry. ^_^'

    The animation is not supposed to play if you've properly copied teleport.cinematic.patch.

    I'll upload fixed version in a short time.
    Last edited: Jul 20, 2015
  12. MrChow

    MrChow Pangalactic Porcupine

  13. Niteskale

    Niteskale Void-Bound Voyager

    Oh cool, thanks very much for the response and update.
  14. Deerdancer

    Deerdancer Big Damn Hero

    How to install it D:
  15. MrChow

    MrChow Pangalactic Porcupine

    Unpack files from zip archive into:

  16. MrChow

    MrChow Pangalactic Porcupine

    MrChow updated Intrusive Teleport Animation Removal with a new update entry:

    Version check removal

    Read the rest of this update entry...
  17. SomePixel7

    SomePixel7 Subatomic Cosmonaut

    How do i get it to work?

    i extract the files in the mod folder,and when i go to test it,it still has the animation thing,then i tried putting the files in the "cinematic" folder but that also didnt do anything

    can anyone help?
  18. MrChow

    MrChow Pangalactic Porcupine

    This mod has been removed and is no longer available for download.
Thread Status:
Not open for further replies.

Share This Page