1. Welcome to the Starbound support forums. Please check the support FAQs before posting: http://playstarbound.com/support

Bug/Issue Internal Server Lag in SP/Momentarily Losing Connection(?)

Discussion in 'Starbound Support' started by Cally94, Feb 8, 2020.

  1. Cally94

    Cally94 Scruffy Nerf-Herder

    Hey all. Firstly, I saw the main thread from all the way back to 2016, but the last update was from November last year, so I wasn't sure if posting there would count as necro-posting... Sorry if this post was better made under that thread. :catcry:

    So, I see a lot of other people talking about this, and after going through tons of forum posts here and on other sites (seemingly hundreds of "v-sync" fixes), I'm at a loss :catconfused:.... I know in troubleshooting for computer games, PC specs are always the first question, so let me get that out of the way real quick... Oh, and I bought the Steam version of the game.

    My PC Specs
    Model: Omen by HP Obelisk Desktop 875-1040st
    OS - Windows 10 Advanced
    CPU - 9th Gen Intel Core i7-9700K CPU @ 3.60 GHz, 8 Cores, 8 Logical Processors, Liquid Cooled
    RAM - 16GB DDR4-2666 SDRAM (2 x 8 G:cool:
    GPU - NVIDIA GeForce RTX 2070 (8GB GDDR6 dedicated)
    Memory - 2 TB HDD
    PSU - 750W Platinum Efficiency

    Attempting to find the issue on my own, I discovered the debug UI, which appears to show that I am losing complete connection to the internal server in SP mode. This is on top of the normal unexplained stuttering and lag spikes that so many other people are having trouble with. This persists with no change in symptoms or frequency on a dedicated server as well. Also, I keep having huge jumps in ping to the internal server. One time, before making this post, I had a near 10 second lag spike and the ping in the debug menu showed over 5000 for a brief second when the game finally started going again. I want to clarify that I have used the task manager resource tab thingy to monitor the computer's hardware and nothing is even coming close to struggling, and Omen Command Center shows there are no cooling issues. Frames are also 60 constantly when it's not lagging. All of the lag and freezing up appears to be from the communication between the client and the internal server.

    What I have tried:

    - The V-Sync fix that is everywhere on the internet... Noticed no change no matter what I tried with v-sync, so now it just leave it off in-game and enable it in the NVidia Control Panel -> 3D Settings -> Program Settings for Starbound
    - Restart computer
    - Validate game files
    - Run without steam overlay & ran without steam (directly from .exe in install folder)
    - Compatibility settings (including run as admin)
    - Tried both 64-bit and 32-bit .exe's
    - Comp already runs in high perf mode
    - Shutdown background tasks
    - Checked firewall rules (both in firewall settings and in elevated CMD "netsh advfirewall firewall show rule all")
    - Disabled anti-virus
    - Running the game with Steam in Offline Mode
    - Running the game with no internet connection (I know these last two shouldn't make a difference because the server is local on the computer, but worth a try)
    - Re-installed

    All with no effect. No change in symptoms or frequency of any kind.

    After all of this, I also tried installing some mods, namely OptimizeBound and More Threads - Lag Reducer 8-thread edition, but neither had an effect... I saw someone else say something about checking the system's Event Log for errors, but there is nothing of use there either... I don't seem to have any problems with HDD write and read times or network either as I can play a lot of other games at max settings online with other players, including games like GTAV, Apex, and various MMO's and MOBA's. I feel like this is probably an optimization issue, but I also don't know if there's something firewall or AV related I haven't checked yet (I'm not an expert obviously :catbleh:)

    Video linked below shows some instances of the problem. All of the issues shown took place over a 5-minute time span, and I cut out some of the smaller hiccups that could be explained as the open world loading.
    Skip to 1:05 to skip how to get in to debug mode and smooth demonstration

    Hoping I can get some help troubleshooting this, but I have a feeling with how many other people have had this issue, I have a feeling this is something that needs a patch... Idk if the devs are even working on this game anymore, but hopefully this will help. I see their Twitter is still active, so... Fingers crossed? This problem seems to be killing off the player base as people are getting fed up with it though which is a shame... But I admit, if I can't fix this or if it's not fixed by the devs, I'll join the ranks of those leaving cause this is so bad...

    What I'm hoping to accomplish through my contribution of this post to the plethora of other posts from other players about this years old issue:

    Me ---> :cathug: <--- Starbound
    Last edited: Feb 8, 2020
  2. Cyastic

    Cyastic Space Hobo

    Hey Cally, created an account just to comment on this...

    First of all, hugs... :avalihug:
    This problem has plagued many for a long time...

    I also have the same problem. Led me to give up on the game entirely a while back. Sad to see this is still a thing in 2020, as I had this issue in 2018 :/ . Judging by the fact we bought matching PC's, (cause you can't just let me be original) I can verify it's probably the game or a setting we have enabled in windows. What did you change in firewall rules, just exceptions? I remember having to add exceptions for the starbound .exe as well as adding one for the server .exe. It didn't fix it for me, but it did for some...
  3. Cally94

    Cally94 Scruffy Nerf-Herder

    Oh, I thought you already had an account :nurutease:

    I added exceptions for all of the .exe's, 64 and 32, but it only let me add one for the 32 server exe which is what I am using now.
  4. Cyastic

    Cyastic Space Hobo

    Okay, I know you already re-installed the game, but have you tried wiping the universe file? You can rename the "universe" folder to something else in ...\Steam\steamapps\common\Starbound\storage and re-launch the game. Can I bug you for a log file too, if that last step doesn't help? Keep in mind resetting universe files resets the universe so you will lose builds, but I know you don't like to build much so you prolly don't care...
  5. Cally94

    Cally94 Scruffy Nerf-Herder

    Nope, still does it, but the log is showing something about player error? Couldn't load a player file cause of "versioning"?
  6. Cyastic

    Cyastic Space Hobo

    Still save files from older versions of the game I suppose. Reload all your existing characters and then refresh the save folder in ...\Steam\steamapps\common\Starbound\storage\player, sort by date modified, and delete any not from today.
    Do you use "/admin" a lot? Try disabling any admin privs on characters as you load them up. Idk if that would effect the server, but the mp servers remember admins so if you have a lot of characters that are all in admin, that might slow things down. Idk for sure though...
  7. Cally94

    Cally94 Scruffy Nerf-Herder

    I do leave characters in admin mode, but it looks like resetting the universe turned it off for all characters. I have a lot of characters to load up and re-save, so while I'm doing that, is there a way to check if there is connection interference with an internal server?

    EDIT: Also, is there a way to limit to 30 fps? I'm wondering if this is like GTAV where the game runs too fast without v-sync. I do have v-sync on, but that's at 60 fps. I'm not sure if changing that would help?
  8. Cyastic

    Cyastic Space Hobo

    Internal server, idk. There is with external servers, through event log, but you said you already checked that so I don't think that's it. Seems to me if it was the firewall, you wouldn't be connecting at all. And as far as I know, the firewall is only for outbound and inbound across a network anyways. Internal servers run "internally", it doesn't even go out to the network. Exceptions are worth having anyways, just in case, but I'm not sure if it makes any difference.

    Go to NVCP and there should be a max framerate option. Set it to 30.
  9. Iris Blanche

    Iris Blanche Pudding Paradox Forum Moderator

    Setting the server fidelity to high instead of automatic in the config seems to get almost rid of this problem (SP only). The specs of your machine should be more than sufficient tho. Also with debug mode enabled performance will take an impact.
    For the freeze seen in the vid it might be nividia's "Optimal performance mode". Set it to "Prefer maximum performance" instead.

    Game is more than playable with these settings imho.
  10. Cally94

    Cally94 Scruffy Nerf-Herder

    That definitely helped a lot, it's now playable. Still a bit of lag, but not bad. Thanks so much! This saved the game for me :nuruhappy:

Share This Page