1. Hey Guest! Our new game Wargroove has released! Check out the forums or wiki for more information!
    Dismiss Notice

Tutorial Installing mods for Starbound 1.0

Discussion in 'Starbound Modding' started by The | Suit, Jan 20, 2015.

Thread Status:
Not open for further replies.
  1. JetXarison

    JetXarison Space Hobo

    I have MAC and I dont understand what to do. I installed https://community.playstarbound.com/resources/human-beards-and-accessories.3829/ this mod. Somewhere i read that you need to do next - Go > Go to folder > ~/Library/Application\ Support/Steam/SteamApps/common/Starbound . Or something like that (My main language is Russian, sorry). But my MAC says that this folder do not exist. And when i extracted that file i got a folder. In this tutorial, tho, you didn't say what I suppose to do with folder with no PAK file...
     
  2. JetXarison

    JetXarison Space Hobo

    okay, I understood that you need to copy those two files into folder 'mods'... Last trouble is that i dont know how to find that folder
     
  3. GonDragon

    GonDragon Pangalactic Porcupine

    Why you want to do that? If you subscribed to that mod from steam, then you don't need to do anything else.
     
  4. JetXarison

    JetXarison Space Hobo

    But there is no such mod in steam
     
  5. GonDragon

    GonDragon Pangalactic Porcupine

    Oh, I was missunderstanding what are you trying to do, sorry.

    To found the "mod" folder (where you should put any pack file), you should Open Steam > Library > Right Click on Starbound > Properties > Local Files > Watch Local Files (or something like that).

    That will open the main directory of starbound, where you can find the "Mods" folder.
     
    JetXarison likes this.
  6. JetXarison

    JetXarison Space Hobo

    Oh my goodness man, I was so stupid)) Thank you so much, saved me :rofl: Now I have this amazing mod working good) I spent hours to understand how it was suppose to be done. Thanks again :p
     
  7. M0NSIEUR C00KIE

    M0NSIEUR C00KIE Aquatic Astronaut

    Hello, and excuse me but i have a problem with a mod, the spawn object though but they are invisible. Should you drag the folders as "item" and "stats" in files other than metadata ?
     
  8. chattboy

    chattboy Space Hobo

    None of the pictures or whatever is under the "correct way" and "incorrect way" show up can some one walk me through it please????
     
    Last edited: Nov 11, 2017
  9. pen_DL

    pen_DL Aquatic Astronaut

    how did you put PAK file in that Mod folder tho? i didn't see any PAK file after i extracted too. i am also on a mac
     
  10. Anguspw80

    Anguspw80 Space Spelunker

    The problem is that the folders are .rar files. they can't seem to be opened on my mac so I assume thats the same problem. I also don't get any trace of pak/rar files in starbound.
     
  11. The | Suit

    The | Suit Agent S. Forum Moderator

  12. DireWolfDragon

    DireWolfDragon Space Hobo

    okay, I've been trying this for like 2 hours now...
    I have a mac, downloaded the Skath Race mod but it's not working, it is already placed in the mods folder.
    but the .metadata is missing
    also I dont have the option of using the launch mod uploader tool when starting the game, I don't have that option...
    really desperate and I have no idea what to do anymore...anyone got an idea?
     
  13. Samara

    Samara Orbital Explorer

    Uhm... The|Suit im having some issue. I extract the file in the mod folder, but the game just crashes, so...if you could help me it would be nice, and the Location of the mods ain't in Girafe_storage, its Starbound\mods
    ~Samara~
     
  14. lazarus78

    lazarus78 The Waste of Time

    Post your starbound.log file.
     
  15. Samara

    Samara Orbital Explorer

    Here
     

    Attached Files:

  16. lazarus78

    lazarus78 The Waste of Time

    "Eeveefuelhatch" from the mod Eevee 1.3 seems to be broken. That is your issue.
     
  17. Samara

    Samara Orbital Explorer

    Oh well
    Thanks!
     
  18. SnowPandas

    SnowPandas Space Hobo

    Someone should update this cause the images are just a small rectangle with an red x in a corner for me. Luckily i just tried dropping the unpacked Rar/zip file in the mods folder and it seemed to have worked.
     
  19. BirdieTheStarStruck

    BirdieTheStarStruck Space Spelunker

    I have a few mods, when I try to use the Avali mod, my starbound crashes
    You said something about the .metadata file
    well, this mod has more then just two files before the metadata, what do I do?
     

    Attached Files:

  20. wylandylan22

    wylandylan22 Space Hobo

    @BirdieTheStar
    " have a few mods, when I try to use the Avali mod, my starbound crashes
    You said something about the .metadata file
    well, this mod has more then just two files before the metadata, what do I do?"

    take the second Avali-triage folder and move it to the mods folder WITHOUT the first folder.

    Since you still have it in downloads:
    go to downloads and open the FIRST Avali-triage folder
    Copy/Move the Avali-triage folder (found within the one you just opened) to the mods folder within your Starbound install
    You're done



    Just curious, Why do you not use Windows 10?
     
Thread Status:
Not open for further replies.

Share This Page