Modding Help (~Important~) I have bad luck. Comments are appreciated

Discussion in 'Starbound Modding' started by NeoslayerX, Aug 7, 2016.

  1. NeoslayerX

    NeoslayerX Big Damn Hero

    Okay, listen up: (pleaseP

    Please read this all, it is not as much as it looks like; it will be done in a snap. Plus, reading is fun.
    comments are appreciated.

    Read my previous post if you are not aware.. About.. What's going on.
    It's in my signature, along with the florn and yours truly... ;D (/troll)
    Anyway, Putting my mods in the "Blah blah x86-->common-->Blahblahsteamblah-->Giraffe_storage/mods, DOES NOT WORK for me.
    BUT.. I was curious about what the red text in the menu says. see, in this photo, it says "Asset SOURCE"
    so I decided to put my mods inside the user folder.
    Guess what.
    It worked.
    Somewhat. :zzz:
    The Lyiria's Gunshop (Glad) mod worked, but was useless because the game crashes when I try to enter her crafting interface :fireball::facepalm:
    Tabula Rasa mod crashes when I use that as well
    The only one that functions properly is the "Racial Crafting" mod, and still some items won't appear.
    CAFSpawnerbase (CustomNPC) also works but crashes when I place it, so it renders useless.

    I got Cheerful giraffe and glad giraffe, but cheerful gets an error when I play it..Therefore Radiant blocks doesn't work because it is cheerful not glad.
    Some mods are incompatible with the current version, even though on the description it doesn't say "OUTDATED"
    Something about a "Fatal Exception (StarException) loading (MapException) Key 'petsConfig' not found in Map::get()

    When I ask for help I simply get some obvious answer like "Drop it in the mods folder" or no response at all
    Don't you think I know that already?

    FrackinUniverse,Anime eyes and AnTiMonster (The mods I wanted most) are all .Pak files, and they don't work wherever I put them. If I figure out how to put them inside the "Packed.pak, it might work but don't know how to do that without my mind getting blown.

    I also tend to have bad luck and I'll probably crash once that happens..

    About my other mods:

    Yourstarboundcrew has errors when about "ERROR repeatmonstertype Robotboss, penguinufo," etc. One time I deleted some of those monsters and the game worked but I had to delete an entire folder and as a result nothing even worked. Extra Dungeons doesn't work; it says something about "itemnotfound pixeldispenser"
    Dungeons Everywhere doesn't work as well, but I don't mind that because I barely know what that mod is.

    There is no proof the mods work on the menu but they worked somewhat, when I place them in the "user" folder
    (Giraffe_storage doesn't work; I went over this, I am just repeating because I doubt most of you read this thread at all)

    Attached Files:

  2. Mackinz

    Mackinz The Waste of Time

    Do not place them in the User folder. Place them in the mods folder found in the Starbound folder. Not starbound/giraffe_storage/mods/. Starbound/mods.
  3. NeoslayerX

    NeoslayerX Big Damn Hero

    Don't think that works either.
  4. NeoslayerX

    NeoslayerX Big Damn Hero

  5. NeoslayerX

    NeoslayerX Big Damn Hero

    Yep. Doesn't work. The best bet for me so far is Assets/user/starbound
    Please consider talking about the other things I talked about
  6. NeoslayerX

    NeoslayerX Big Damn Hero

    Ugh. No responses. I gotta wait another week or something..
  7. Nefer007

    Nefer007 Phantasmal Quasar

    Well, Anime Eyes for Humans and Frackin Universe can all be found on Steam.
  8. Mackinz

    Mackinz The Waste of Time

    This is as simple as it gets. First, verify your game version. If you are running Starbound 1.0.5 then you are up to date. If not, then update your game.

    Now, navigate to your Starbound installation. For me, its a Steam game so it's found at at C:\Program Files (x86)\Steam\steamapps\common\Starbound\. For you, assuming a non-steam install or non-Windows OS it will be wherever you installed it. In your Starbound folder, there will be a "mods" folder. If there isn't, create one. This is where your mods must be installed to properly work.

    Now, to install a mod you either need to open zip files for folders or use pak files. In either case, place them in your /mods/ folder. For folder mods, ensure that their contained .metadata or _metadata files are within the initial folder, i.e. /mods/*modfolder*/_metadata. If there is an additional folder between the mods folder and the metadata file the mod was improperly installed, ex. /mods/*modfolder1*/*modfolder2*/_metadata, and should be reinstalled so that the metadata file is in the proper location - DO NOT MANUALLY MOVE THE METADATA FILE BY ITSELF. Pak file mods are simpler to install, as they are just drag and dropped into the mods folder. If the mod has a modinfo file, then the mod is old and should not be updated unless you know what you're doing.

    Now, assuming you are running the latest game version and followed my instructions to the letter then there should be no issues. Modding Starbound manually requires a modicum of intelligence and patience but it requires far less of either than, say, TES 5: Skyrim. If you don't have time for that and are using Steam, use the Steam Workshop - otherwise, learn how to install mods properly. Here's the stickied tutorial on how to do so:

    And do not use the /user/ folder for released mods. Ever.
  9. NeoslayerX

    NeoslayerX Big Damn Hero

    If you read my post... :facepalm:
    You would know... :facepalm::facepalm:
    THAT...:facepalm: :facepalm: :facepalm: :fireball:
    I... :whoop:
    Already tried that.. And I told you, Putting them in all the categories does not work.
    When I use user, at least I get to know something actually worked.

    This time, I unpacked the packed.pak, the final thing I can do is put some mod files (excluding mod pak files, they still don't work anywhere) inside of the "packed.pak" folder. (I turned it into a folder, it still works, but I edited the picture of the Humanoid/human/malehead, but now they all have a huge white square around them..
  10. Mackinz

    Mackinz The Waste of Time

    Then you are doing something wrong. 99.99% of people can get mods to work by installing them properly. You can't. Did you even stop to consider that the issue is user error and not anything else? I am trying to help you by encouraging you to try again.

    If you are running the latest version of Starbound (please ensure that you are), then there should be no issues what-so-ever if you install mods properly in your mods folder.

    So, to root out the issue, please bear with me.

    I want you install one mod in your mods folder. Then I want you to take a screenshot of your mods folder. Then I want you to open that one mod's folder and take a screenshot of that. I also want you to take a screenshot of your game menu after it boots up.

    Post all of those screenshots in the next reply.

    Also, the reason you have the white squares is because you did not save the image with transparency. Use an image editor that supports image transparency like Paint.NET or GIMP.
  11. NeoslayerX

    NeoslayerX Big Damn Hero

    Takes a long time to load.. Wait a sec..
  12. NeoslayerX

    NeoslayerX Big Damn Hero

    I tried ExtraBiomes, I get this error:

    Start logging at: 2016-08-08 01:57:00.900
    [01:57:00.901] Info: Star::Root using bootstrap file 'C:\Program Files (x86)\Steam\steamapps\common\Starbound\win64\sbboot.config'
    [01:57:00.901] Info: Star::Root using storage directory 'C:\Program Files (x86)\Steam\steamapps\common\Starbound\giraffe_storage\'
    [01:57:00.901] Info: Preparing Star::Root...
    [01:57:00.902] Info: Detected mod 'extra dungeons' at '../giraffe_storage/mods\extradungeons\.'
    [01:57:00.902] Info: Loading Configuration with config file: 'starbound.config'
    [01:57:00.902] Info: Loading Star::Configuration from 'Just (.\..\giraffe_storage\starbound.config)'
    [01:57:00.904] Info: Writing Star::Configuration to '.\..\giraffe_storage\starbound.config'
    [01:57:00.914] Info: Initializing Star::Root with 3 assets sources
    [01:57:00.914] Info: Done preparing Star::Root.
    [01:57:00.914] Info: Client Version 'Beta v. Glad Giraffe - Update 3' Revision: 30555b17a491c2a97ab0afbff3b848a1fd937dbd Protocol: 711
    [01:57:00.914] Info: Initialized SDL
    [01:57:00.927] Info: Initialized SDL Video
    [01:57:00.936] Info: Initialized SDL Joystick
    [01:57:00.936] Info: Initialized SDL Sound
    [01:57:00.961] Info: Opened default audio device with 44khz / 16 bit stereo audio, 2048 sample size buffer
    [01:57:00.962] Info: Loading Assets
    [01:57:00.962] Info: Loading assets from: '../assets/packed.pak'
    [01:57:00.962] Info: Loading assets from: '../assets/user'
    [01:57:00.963] Info: Loading assets from: '../giraffe_storage/mods\extradungeons\.'
    [01:57:01.451] Info: Done loading Assets in 0.489 seconds
    [01:57:01.458] Info: Loading NameGenerator
    [01:57:01.460] Info: Initializing SDL Window
    [01:57:01.469] Info: Done loading NameGenerator in 0.0110002 seconds
    [01:57:01.469] Info: Loading ObjectDatabase
    [01:57:01.709] Info: OpenGL version: '4.5.0 NVIDIA 353.82' vendor: 'NVIDIA Corporation' renderer: 'GeForce GT 610/PCIe/SSE2' shader: '4.50 NVIDIA'
    [01:57:01.709] Info: Created initial window 1001x633
    [01:57:01.746] Info: Renderer initialized
    [01:57:01.747] Info: Renderer destroyed
    [01:57:01.747] Info: Initializing SDL Window
    [01:57:01.759] Info: OpenGL version: '4.5.0 NVIDIA 353.82' vendor: 'NVIDIA Corporation' renderer: 'GeForce GT 610/PCIe/SSE2' shader: '4.50 NVIDIA'
    [01:57:01.760] Info: Re-created window 1001x633
    [01:57:01.760] Info: Renderer initialized
    [01:57:01.760] Info: Loading ImageMetadataDatabase
    [01:57:01.761] Info: Done loading ImageMetadataDatabase in 0 seconds
    [01:57:02.596] Info: Done loading ObjectDatabase in 1.127 seconds
    [01:57:02.596] Info: Loading PlantDatabase
    [01:57:02.786] Info: Done loading PlantDatabase in 0.19 seconds
    [01:57:02.786] Info: Loading ProjectileDatabase
    [01:57:04.016] Info: Done loading ProjectileDatabase in 1.23 seconds
    [01:57:04.016] Info: Loading MonsterDatabase
    [01:57:04.444] Info: Done loading MonsterDatabase in 0.428 seconds
    [01:57:04.444] Info: Loading NpcDatabase
    [01:57:04.542] Info: Done loading NpcDatabase in 0.098 seconds
    [01:57:04.542] Info: Loading StagehandDatabase
    [01:57:04.543] Info: Done loading StagehandDatabase in 0.000999928 seconds
    [01:57:04.543] Info: Loading VehicleDatabase
    [01:57:04.546] Info: Done loading VehicleDatabase in 0.00300002 seconds
    [01:57:04.547] Info: Loading PlayerFactory
    [01:57:04.551] Info: Done loading PlayerFactory in 0.00400019 seconds
    [01:57:04.551] Info: Loading EntityFactory
    [01:57:04.551] Info: Loading VersioningDatabase
    [01:57:04.553] Info: Done loading VersioningDatabase in 0.00199986 seconds
    [01:57:04.553] Info: Done loading EntityFactory in 0.00199986 seconds
    [01:57:04.553] Info: Loading ItemDatabase
    [01:58:56.968] Info: Loading FunctionDatabase
    [01:58:57.344] Info: Done loading FunctionDatabase in 0.376 seconds
    [01:58:57.347] Info: Loading ParticleDatabase
    [01:58:58.904] Info: Done loading ParticleDatabase in 1.557 seconds
    [01:59:09.380] Info: Done loading ItemDatabase in 124.827 seconds
    [01:59:09.380] Info: Loading MaterialDatabase
    [01:59:17.605] Info: Done loading MaterialDatabase in 8.225 seconds
    [01:59:17.605] Info: Loading TerrainDatabase
    [01:59:18.637] Info: Done loading TerrainDatabase in 1.032 seconds
    [01:59:18.637] Info: Loading BiomeDatabase
    [01:59:20.715] Info: Done loading BiomeDatabase in 2.078 seconds
    [01:59:20.715] Info: Loading LiquidsDatabase
    [01:59:20.852] Info: Done loading LiquidsDatabase in 0.137 seconds
    [01:59:20.852] Info: Loading StatusEffectDatabase
    [01:59:21.285] Info: Done loading StatusEffectDatabase in 0.433 seconds
    [01:59:21.285] Info: Loading DamageDatabase
    [01:59:21.883] Info: Done loading DamageDatabase in 0.598 seconds
    [01:59:21.884] Info: Loading EffectSourceDatabase
    [01:59:22.084] Info: Done loading EffectSourceDatabase in 0.201 seconds
    [01:59:22.084] Info: Loading TreasureDatabase
    [01:59:22.225] Info: Done loading TreasureDatabase in 0.141 seconds
    [01:59:22.225] Info: Loading DungeonDefinitions
    [01:59:23.335] Info: Done loading DungeonDefinitions in 1.11 seconds
    [01:59:23.335] Info: Loading TilesetDatabase
    [01:59:23.336] Info: Done loading TilesetDatabase in 0.000999928 seconds
    [01:59:23.336] Info: Loading EmoteProcessor
    [01:59:23.345] Info: Done loading EmoteProcessor in 0.00900006 seconds
    [01:59:23.346] Info: Loading SpeciesDatabase
    [01:59:23.383] Info: Done loading SpeciesDatabase in 0.0370002 seconds
    [01:59:23.383] Info: Loading QuestTemplateDatabase
    [01:59:23.565] Info: Done loading QuestTemplateDatabase in 0.182 seconds
    [01:59:23.565] Info: Loading AiDatabase
    [01:59:23.850] Info: Loading TechDatabase
    [01:59:23.976] Info: Done loading TechDatabase in 0.126 seconds
    [01:59:23.977] Error: Exception raised during Root finishLoad: (JsonException) Improper conversion to JsonArray from object
    [0] 7ff66a861933
    [1] 7ff66a85e2c8
    [2] 7ff66a642415
    [3] 7ff66a6423c6
    [4] 7ff66a8772a2
    [5] 7ff66a47c58f
    [6] 7ff66a47d324
    [7] 7ff66a47d6ed
    [8] 7ff66a47b69c
    [9] 7ff66a23cd45
    [10] 7ff66a2397ea
    [11] 7ff66a236b42
    [12] 7ff66a2387d0
    [13] 7ff66a2396f9
    [14] 7ff66a23910c
    [15] 7ff66a23885e
    [16] 7ff66a23872e
    [17] 7ff66a2434b2
    [18] 7ff66a8c70ca
    [19] 7ff66a8c69d1
    [20] 7ff66a875f0d
    [21] 7ffdaf778102 BaseThreadInitThunk
    [22] 7ffdb01ac5b4 RtlUserThreadStart
    [01:59:23.990] Info: Renderer destroyed
    [01:59:24.078] Info: Shutting down Star::Root
    [01:59:24.322] Error: Fatal Exception caught: (StarException) An error occurred during loading: (JsonException) Improper conversion to JsonArray from object

    Trying a different mod.. Here are the screenshots

    Attached Files:

  13. Mackinz

    Mackinz The Waste of Time

    Okay, so the forums were down most of yesterday and I was out of energy when they came back up, so I'll look at your screenshots now.

    The first thing I see is that you are running Glad Giraffe. My advice for that is to update your game version immediately. There is no good reason to run Glad Giraffe over 1.0/Cheerful Giraffe unless whatever issues you were having on 1.0 are truly insurmountable, and my guess is they are not. All of the mods which you are attempting to run Glad Giraffe versions of should have 1.0 versionsas well.

    After you have re-updated your game, remove your mods in /assets/user/. Putting anything in there aside from the song files in it is bad practice.

    Then, properly install the updated versions of your desired mods in /starbound/mods/ so Starbound 1.0 can find and read them.

    I am here to help you address whatever issues you are having with Starbound 1.0; not to debug issues with an old game version.
  14. NeoslayerX

    NeoslayerX Big Damn Hero

    I get an error when I play the new Cheerful. For the third time..
  15. Mackinz

    Mackinz The Waste of Time

    An error... what error? Can you screenshot it?
  16. Shadox2.0

    Shadox2.0 Spaceman Spiff

    You don't use the last version of the game ? (1.0.5)
  17. NeoslayerX

    NeoslayerX Big Damn Hero

    I already put said error in my post long ago
    I gave up on this game so nevermind..
  18. Mackinz

    Mackinz The Waste of Time

    Don't give up. Link me to this error post you made. I will help you get through that error so you can enjoy a fully updated Starbound experience.
  19. NeoslayerX

    NeoslayerX Big Damn Hero

    Ok, I won't give up!

    "Keep trying!
    Keep trying!
    Don't give up!
    Never give up!

    Keep trying!
    Keep trying!
    Don't give up! Don't stop!
    Never give up! Don't stop!"
  20. NeoslayerX

    NeoslayerX Big Damn Hero

    I get this:
    Fatal Exception: (StarException) An error occured during
    loading:(MapException) Kep 'petsConfig' not found in Map::get()

    Can I have a copy of your packed.pak?
    I think I know what happened.

Share This Page