1. Welcome to the Starbound support forums. Please check the support FAQs before posting: http://playstarbound.com/support

Bug/Issue Huge input lag when opening inventory

Discussion in 'Starbound Support' started by Yomoj0, Jun 15, 2019.

  1. Yomoj0

    Yomoj0 Yeah, You!

    So, I will start by saying this: from what I've read so far trying to figure out this issue, you will probably ask me for my specs, and when I give them you'll probably say they don't meet minimum system requirements. But I wasn't having this issue at all before the most recent update.

    Title is a good summary of what's happening, but let me explain further. If I'm just standing around normally and open up my inventory, all of my inputs get laggy and unresponsive. When I open some sort of storage interface, it almost stops recognizing my inputs completely. I specify inputs, because nothing else slows down. NPCs keep moving, particle effects keep happening, music is still perfectly fine etc. The only thing it affects is my inputs (mouse movement and clicking, wasd to move etc.)

    The problem seems to be more pronounced while I'm on my ship, and opening larger containers like storage lockers seems to more completely and more reliably freeze up my controls. Most of the time, by mashing the escape key, I can exit out of the storage UI and keep playing perfectly normally. This is quite the issue, as I can't loot items, store items, or even do things like put my pets in the healing station.

    Just for completeness sake, I will provide my specs. However, as I said, while they are god-awful and below the listed system requirement, I was having absolutely zero issues of this kind before the latest update. Why I'm so confused is that I don't think anything should have changed with opening storage and the inventory UI, as the newest update was mainly bounties and rare creatures. It's a real headscratcher on my part...

    • Windows 10 pro
    • intel core i3-2330m cpu @ 2.20GHz
    • 3 GB ram
    • 64-bit os and processor
    • intel 3000 integrated laptop graphics
     
  2. Yomoj0

    Yomoj0 Yeah, You!

    Update: When launching them game fresh (such as after restarting my computer), everything seems to work normally for about 1 minute, including opening storage lockers on my ship. It doesn't take long, however, for my inputs to start freezing when opening storage again.
     
  3. ChewedPencil

    ChewedPencil Big Damn Hero

    Yeah im having the exact same issues. I dont know itf it is a mod or not but i have been uninstalling mods for awhile and nothing is fixing it.

    Edit: it seems to start lagging the more interfaces are up. Will test the inventory mods i have

    Edit2: so it turns out the larger inventory mod i was using was causing the lag.
     
    Last edited: Jul 25, 2019
  4. Yomoj0

    Yomoj0 Yeah, You!

    Yeah, I'm not using mods
     
  5. Thaddaios

    Thaddaios Space Hobo

    I'm running a pretty godly computer and I have the exact same issues/complaints + more. I can run any game at ultra settings and have a perfect 60+ fps, but for some odd reason Starbound is 30 or less. It doesn't make sense... I also noticed in task manager that i get those 1sec gpu performance spikes every 1 or 2 minutes. Some say to turn off vsync and get Optimizebound mod then it fixes everything. I do that and i get major screen-tearing so that's not an option. I think there is just some issue with the optimization of the game. Wish the devs could relieve our issue sometime. Are they working on this?
     
  6. Yomoj0

    Yomoj0 Yeah, You!

    It really kinda seems like they're more interested in implementing new features than making sure the game is optimized. Which is fine for most people, I guess, it just sucks for the minority of us who now suddenly can't play one of our favorite games...
     
  7. Thaddaios

    Thaddaios Space Hobo

    Okay, i may have found a solution on reddit that may fix many people's lag issues. Try running the 32-bit version and let us know if this fixed it.
     
  8. Yomoj0

    Yomoj0 Yeah, You!

    Sorry for the very late reply, but running in 32-bit does seem to help quite a lot. Do you know if there's a way to run it like this and still use workshop mods? It would be nice to use the particle disabling mod in addition to improve performance even more.
     

Share This Page